classification
Title: Unable to launch IDLE on Windows
Type: Stage:
Components: IDLE Versions: Python 2.6
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: amaury.forgeotdarc, croy, srid
Priority: normal Keywords:

Created on 2009-03-20 22:33 by croy, last changed 2009-08-18 23:02 by srid. This issue is now closed.

Messages (3)
msg83877 - (view) Author: Chris (croy) Date: 2009-03-20 22:33
I have recently installed python 2.6 and I have been successfully able 
to run python from a command line and from the Python command line.  
However, when I try to launch the IDLE, all I get is a window that 
flashes.  I tried launching the IDLE from a command line with the 
following command:  
c:\Python26\Lib\idlelib>idle.py -n

I get the following error:
************************************************
Traceback (most recent call last):
  File "C:\Python26\Lib\idlelib\idle.py", line 21, in <module>
    idlelib.PyShell.main()
  File "C:\Python26\lib\idlelib\PyShell.py", line 1386, in main
    root = Tk(className="Idle")
  File "C:\Python26\lib\lib-tk\Tkinter.py", line 1643, in __init__
    self.tk = _tkinter.create(screenName, baseName, className, 
interactive, want
objects, useTk, sync, use)
_tkinter.TclError: Can't find a usable init.tcl in the following 
directories:
    {C:\IBMTOOLS\Python22\tcl\tcl8.4} C:/IBMTOOLS/Python22/tcl/tcl8.5 
C:/Python2
6/lib/tcl8.5 C:/lib/tcl8.5 C:/lib/tcl8.5 C:/library C:/library 
C:/tcl8.5.2/libra
ry C:/tcl8.5.2/library

C:/IBMTOOLS/Python22/tcl/tcl8.4/init.tcl: version conflict for 
package "Tcl": ha
ve 8.5.2, need exactly 8.4
version conflict for package "Tcl": have 8.5.2, need exactly 8.4
    while executing
"package require -exact Tcl 8.4"
    (file "C:/IBMTOOLS/Python22/tcl/tcl8.4/init.tcl" line 19)
    invoked from within
"source C:/IBMTOOLS/Python22/tcl/tcl8.4/init.tcl"
    ("uplevel" body line 1)
    invoked from within
"uplevel #0 [list source $tclfile]"

This probably means that Tcl wasn't installed properly.
*************************************************************

I tried changing the python path from c:\IBMTOOLS\Python22 to 
C:\Python26, but that did not work. 

One other note is that I do not have adminstrator priviledges on this 
computer.
msg84182 - (view) Author: Amaury Forgeot d'Arc (amaury.forgeotdarc) * (Python committer) Date: 2009-03-26 16:21
Do you happen to have a TCL_LIBRARY environment variable?
If yes, I suggest to remove it.
msg84191 - (view) Author: Chris (croy) Date: 2009-03-26 17:38
Amaury,
   That worked, the variable was for IBMTools, so I am a little concerned that some other program may have issues.  If I do have problems, I will just add the variable back.
   Thanks for getting back to me.
- Chris

----- Original Message ----
From: Amaury Forgeot d'Arc <report@bugs.python.org>
To: chrisaroy@yahoo.com
Sent: Thursday, March 26, 2009 11:21:08 AM
Subject: [issue5528] Unable to launch IDLE on Windows

Amaury Forgeot d'Arc <amauryfa@gmail.com> added the comment:

Do you happen to have a TCL_LIBRARY environment variable?
If yes, I suggest to remove it.

----------
nosy: +amaury.forgeotdarc

_______________________________________
Python tracker <report@bugs.python.org>
<http://bugs.python.org/issue5528>
_______________________________________
History
Date User Action Args
2009-09-24 13:31:56amaury.forgeotdarclinkissue6987 superseder
2009-08-18 23:02:50sridsetnosy: + srid
2009-07-01 09:55:14amaury.forgeotdarclinkissue6392 superseder
2009-03-27 02:06:34amaury.forgeotdarcsetstatus: open -> closed
resolution: not a bug
2009-03-26 17:38:32croysetmessages: + msg84191
2009-03-26 16:21:06amaury.forgeotdarcsetnosy: + amaury.forgeotdarc
messages: + msg84182
2009-03-20 22:33:36croycreate