Author croy
Recipients croy
Date 2009-03-20.22:33:34
SpamBayes Score 3.89909e-10
Marked as misclassified No
Message-id <>
I have recently installed python 2.6 and I have been successfully able 
to run python from a command line and from the Python command line.  
However, when I try to launch the IDLE, all I get is a window that 
flashes.  I tried launching the IDLE from a command line with the 
following command:  
c:\Python26\Lib\idlelib> -n

I get the following error:
Traceback (most recent call last):
  File "C:\Python26\Lib\idlelib\", line 21, in <module>
  File "C:\Python26\lib\idlelib\", line 1386, in main
    root = Tk(className="Idle")
  File "C:\Python26\lib\lib-tk\", line 1643, in __init__ = _tkinter.create(screenName, baseName, className, 
interactive, want
objects, useTk, sync, use)
_tkinter.TclError: Can't find a usable init.tcl in the following 
    {C:\IBMTOOLS\Python22\tcl\tcl8.4} C:/IBMTOOLS/Python22/tcl/tcl8.5 
6/lib/tcl8.5 C:/lib/tcl8.5 C:/lib/tcl8.5 C:/library C:/library 
ry C:/tcl8.5.2/library

C:/IBMTOOLS/Python22/tcl/tcl8.4/init.tcl: version conflict for 
package "Tcl": ha
ve 8.5.2, need exactly 8.4
version conflict for package "Tcl": have 8.5.2, need exactly 8.4
    while executing
"package require -exact Tcl 8.4"
    (file "C:/IBMTOOLS/Python22/tcl/tcl8.4/init.tcl" line 19)
    invoked from within
"source C:/IBMTOOLS/Python22/tcl/tcl8.4/init.tcl"
    ("uplevel" body line 1)
    invoked from within
"uplevel #0 [list source $tclfile]"

This probably means that Tcl wasn't installed properly.

I tried changing the python path from c:\IBMTOOLS\Python22 to 
C:\Python26, but that did not work. 

One other note is that I do not have adminstrator priviledges on this 
Date User Action Args
2009-03-20 22:33:38croysetrecipients: + croy
2009-03-20 22:33:38croysetmessageid: <>
2009-03-20 22:33:36croylinkissue5528 messages
2009-03-20 22:33:34croycreate