classification
Title: IDLE 3.1 will not open
Type: behavior Stage:
Components: IDLE Versions: Python 3.1
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Unable to launch IDLE on Windows
View: 5528
Assigned To: Nosy List: amaury.forgeotdarc, matthall
Priority: normal Keywords:

Created on 2009-07-01 03:56 by matthall, last changed 2009-07-01 09:55 by amaury.forgeotdarc. This issue is now closed.

Messages (2)
msg89962 - (view) Author: Matt (matthall) Date: 2009-07-01 03:56
IDLE will not open; it does not give an error or even appear on the 
process list.

I am using Windows XP on an IBM Thinkpad. I tried the prescribed 
solution on Issue 4049, and it returned this message:

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Matt>cd \python31

C:\Python31>python.exe Lib\idlelib\idle.py
Traceback (most recent call last):
  File "Lib\idlelib\idle.py", line 11, in <module>
    idlelib.PyShell.main()
  File "C:\Python31\Lib\idlelib\PyShell.py", line 1374, in main
    root = Tk(className="Idle")
  File "C:\Python31\Lib\tkinter\__init__.py", line 1632, in __init__
    self.tk = _tkinter.create(screenName, baseName, className, 
interactive, want
objects, useTk, sync, use)
_tkinter.TclError: Can't find a usable init.tcl in the following 
directories:
    {C:\IBMTOOLS\Python22\tcl\tcl8.4} C:/IBMTOOLS/Python22/tcl/tcl8.5 
C:/Python3
1/lib/tcl8.5 C:/lib/tcl8.5 C:/lib/tcl8.5 C:/library C:/library 
C:/tcl8.5.2/libra
ry C:/tcl8.5.2/library

C:/IBMTOOLS/Python22/tcl/tcl8.4/init.tcl: version conflict for 
package "Tcl": ha
ve 8.5.2, need exactly 8.4
version conflict for package "Tcl": have 8.5.2, need exactly 8.4
    while executing
"package require -exact Tcl 8.4"
    (file "C:/IBMTOOLS/Python22/tcl/tcl8.4/init.tcl" line 19)
    invoked from within
"source C:/IBMTOOLS/Python22/tcl/tcl8.4/init.tcl"
    ("uplevel" body line 1)
    invoked from within
"uplevel #0 [list source $tclfile]"


This probably means that Tcl wasn't installed properly.


C:\Python31>

I am very new to Python (and programming in general), and I have no 
idea how to fix this.

By the way, I did install the program for all users.
msg89967 - (view) Author: Amaury Forgeot d'Arc (amaury.forgeotdarc) * (Python committer) Date: 2009-07-01 09:55
This is a duplicate of issue5528.
The fix is to remove the TCL_LIBRARY environment variable.
History
Date User Action Args
2009-07-01 09:55:14amaury.forgeotdarcsetstatus: open -> closed

nosy: + amaury.forgeotdarc
messages: + msg89967

superseder: Unable to launch IDLE on Windows
resolution: duplicate
2009-07-01 03:56:10matthallcreate