classification
Title: IDLE interactive interpreter crash
Type: crash Stage: resolved
Components: IDLE Versions: Python 3.2
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: Nosy List: ezio.melotti, kbk, pitrou
Priority: high Keywords:

Created on 2010-07-12 10:27 by pitrou, last changed 2010-07-12 11:00 by ezio.melotti. This issue is now closed.

Messages (2)
msg110077 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2010-07-12 10:26
After a few keystrokes in the interactive interpreter, I got the
following traceback:

Traceback (most recent call last):
  File "Lib/idlelib/idle.py", line 11, in <module>
    idlelib.PyShell.main()
  File "/home/antoine/py3k/__svn__/Lib/idlelib/PyShell.py", line 1420,
in main
    root.mainloop()
  File "/home/antoine/py3k/__svn__/Lib/tkinter/__init__.py", line 1009,
in mainloop
    self.tk.mainloop(n)
UnicodeDecodeError: 'utf8' codec can't decode byte 0xc0 in position 0:
invalid start byte


The keystrokes were ['d', 'i', Ctrl+Space], which briefly displayed the
completion popup before crashing.
msg110079 - (view) Author: Ezio Melotti (ezio.melotti) * (Python committer) Date: 2010-07-12 11:00
Closing as duplicate of #1028 (and #6144, #6512, #7884, #6920, #6424, #5156).
History
Date User Action Args
2010-07-12 11:00:28ezio.melottisetstatus: open -> closed

nosy: + ezio.melotti
messages: + msg110079

resolution: duplicate
stage: needs patch -> resolved
2010-07-12 10:27:51pitrousetnosy: + kbk
2010-07-12 10:27:01pitroucreate