classification
Title: IDLE 3.1.1 crashes with UnicodeDecodeError when I press Ctrl-Space
Type: behavior Stage: resolved
Components: IDLE, Tkinter Versions: Python 3.1
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: Nosy List: Bernt.Røskar.Brenna, ezio.melotti
Priority: normal Keywords:

Created on 2010-02-08 12:31 by Bernt.Røskar.Brenna, last changed 2010-02-08 16:25 by ezio.melotti. This issue is now closed.

Messages (2)
msg99044 - (view) Author: Bernt Røskar Brenna (Bernt.Røskar.Brenna) * Date: 2010-02-08 12:31
Platform: Linux
Python 3.1.1 built from source. Tk version 8.4, Tcl version 8.4.

Idle 2.6.4 (also built from source), works correctly (executes force-open-completions).

Test case:
- Start idle3
- press Ctrl-Space in the IDLE shell
- idle crashes, and a traceback is written to stdout:
Traceback (most recent call last):
  File "/usr/local/bin/idle3", line 6, in <module>
    main()
  File "/usr/local/lib/python3.1/idlelib/PyShell.py", line 1420, in main
    root.mainloop()
  File "/usr/local/lib/python3.1/tkinter/__init__.py", line 1009, in mainloop
    self.tk.mainloop(n)
UnicodeDecodeError: 'utf8' codec can't decode bytes in position 0-1: illegal encoding
msg99052 - (view) Author: Ezio Melotti (ezio.melotti) * (Python committer) Date: 2010-02-08 16:25
Duplicate of #1028 (and #6920).
History
Date User Action Args
2010-02-08 16:25:38ezio.melottisetstatus: open -> closed

nosy: + ezio.melotti
messages: + msg99052

resolution: duplicate
stage: test needed -> resolved
2010-02-08 14:53:47brian.curtinsetpriority: normal
type: crash -> behavior
stage: test needed
2010-02-08 12:31:56Bernt.Røskar.Brennacreate