classification
Title: IDLE 3 crashes on Ctrl+Space with "'utf8' codec can't decode bytes in position 0-1"
Type: crash Stage: resolved
Components: IDLE Versions: Python 3.1
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: Nosy List: Yinon, ezio.melotti
Priority: normal Keywords:

Created on 2009-09-16 08:30 by Yinon, last changed 2009-09-16 10:07 by ezio.melotti. This issue is now closed.

Messages (2)
msg92667 - (view) Author: Yinon Ehrlich (Yinon) Date: 2009-09-16 08:30
on Ubuntu 8.04 - 
I downloaded the sources, then:
./configure --prefix=$HOME
make && make install

in ~/bin/idle3 when I press Ctrl+Space (according to the "Edit" menu,
should show completions) idle crashes with the following traceback:
Traceback (most recent call last):
  File "/homes/yinon/bin/idle3", line 5, in <module>
    main()
  File "/homes/yinon/lib/python3.1/idlelib/PyShell.py", line 1420, in main
    root.mainloop()
  File "/homes/yinon/lib/python3.1/tkinter/__init__.py", line 1009, in
mainloop
    self.tk.mainloop(n)
UnicodeDecodeError: 'utf8' codec can't decode bytes in position 0-1:
illegal encoding
msg92676 - (view) Author: Ezio Melotti (ezio.melotti) * (Python committer) Date: 2009-09-16 10:07
This is a duplicate of #1028.
History
Date User Action Args
2009-09-16 10:07:21ezio.melottisetstatus: open -> closed

nosy: + ezio.melotti
messages: + msg92676

resolution: duplicate
stage: resolved
2009-09-16 08:30:52Yinoncreate