classification
Title: Idle3 crashing when using completion
Type: crash Stage:
Components: IDLE Versions: Python 3.1
process
Status: closed Resolution: duplicate
Dependencies: Superseder: [IDLE] UnicodeDecodeError when invoking force-open-completions
View: 6144
Assigned To: Nosy List: amaury.forgeotdarc, tcourbon
Priority: normal Keywords:

Created on 2009-07-05 16:24 by tcourbon, last changed 2009-07-05 22:19 by amaury.forgeotdarc. This issue is now closed.

Messages (2)
msg90159 - (view) Author: Thomas Courbon (tcourbon) Date: 2009-07-05 16:24
Configuration : fedora 11, python3.1 manually compiled and installed
along python 2.6 (provided by the distribution).

Reproducibility : seems to be happening any time

Description : When you try to use the auto-completion (ctrl + space) on
anything (tested with module and custom class), the idle crash with the
message :
Traceback (most recent call last):
  File "/usr/local/bin/idle3", line 5, in <module>
    main()
  File "/usr/local/lib/python3.1/idlelib/PyShell.py", line 1420, in main
    root.mainloop()
  File "/usr/local/lib/python3.1/tkinter/__init__.py", line 1009, in
mainloop
    self.tk.mainloop(n)
UnicodeDecodeError: 'utf8' codec can't decode bytes in position 0-1:
illegal encoding
msg90161 - (view) Author: Amaury Forgeot d'Arc (amaury.forgeotdarc) * (Python committer) Date: 2009-07-05 22:19
Duplicate of issue6144
History
Date User Action Args
2009-07-05 22:19:47amaury.forgeotdarcsetstatus: open -> closed

nosy: + amaury.forgeotdarc
messages: + msg90161

superseder: [IDLE] UnicodeDecodeError when invoking force-open-completions
resolution: duplicate
2009-07-05 16:24:49tcourboncreate