classification
Title: PEP process entrypoint
Type: Stage:
Components: Devguide, Documentation Versions:
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: docs@python Nosy List: christian.heimes, docs@python, ezio.melotti, georg.brandl, giampaolo.rodola, jcea, lemburg, python-dev, techtonik, vstinner
Priority: normal Keywords:

Created on 2013-11-28 13:59 by techtonik, last changed 2013-12-01 02:16 by jcea. This issue is now closed.

Messages (12)
msg204652 - (view) Author: anatoly techtonik (techtonik) Date: 2013-11-28 13:59
https://bitbucket.org/rirror/peps

PEP repository readme lacks information about how to send Python Enhancement Proposal step-by-step.

1. hg clone https://bitbucket.org/rirror/peps
2. cd peps
3. # choose number
4. cp ??? pep-{{number}}.txt
5. # commit
6. # send pull request
7. # discuss
msg204654 - (view) Author: Christian Heimes (christian.heimes) * (Python committer) Date: 2013-11-28 14:04
The process is well explained in the PEP templates right at the top of the PEP list:

http://www.python.org/dev/peps/pep-0009/
http://www.python.org/dev/peps/pep-0012/

New PEP authors should get in touch with experienced core developers or mentors in order to get assistance.
msg204655 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2013-11-28 14:06
> PEP process entrypoint

Do you work with developers of the distutils-* objects? It looks like Daniel Holth works on such PEP for example:
https://mail.python.org/pipermail/distutils-sig/2013-July/021854.html

You may join this mailing list:
https://mail.python.org/mailman/listinfo/distutils-sig
msg204657 - (view) Author: anatoly techtonik (techtonik) Date: 2013-11-28 14:28
The "entrypoint" here means the point of entry for new Python Enhancement Proposals. Christian, what you propose is a 4th order link for someone who knows what PEPs are, and clones PEP repository to submit own proposal.

What I propose it to make PEP repository self-sufficient, so that person who cloned it, can immediately get to work. You can argue that people who don't have time to read on all previous stuff, should not write PEPs, but I'd object that it is good to be inclusive.
msg204658 - (view) Author: Marc-Andre Lemburg (lemburg) * (Python committer) Date: 2013-11-28 14:34
Anatoly, please read http://www.python.org/dev/peps/pep-0012/

The process you are describing is not correct. In particular, the discussion happens before sending in a pull request.

As for discussion of the PEP process: that should happen on python-dev, not in some ticket in the tracker.

Closing the ticket again.
msg204665 - (view) Author: anatoly techtonik (techtonik) Date: 2013-11-28 14:45
> The process you are describing is not correct. In particular, the discussion happens before sending in a pull request.

Post the link to correct process into README.rst and then this issue can be closed.

As for python-dev, I thought it is too obvious and minor issue (still issue) to raise there, so it is just a matter of somebody with knowledge, time and commit privileges to commit the patch. It may worth to raise the question there anyway as I see that communicating usability concerns is a big problem.
msg204667 - (view) Author: Christian Heimes (christian.heimes) * (Python committer) Date: 2013-11-28 14:50
The ticket has been closed by two people. Why do you keep re-opening the ticket?
msg204671 - (view) Author: Marc-Andre Lemburg (lemburg) * (Python committer) Date: 2013-11-28 15:26
On 28.11.2013 15:45, anatoly techtonik wrote:
> 
> anatoly techtonik added the comment:
> 
>> The process you are describing is not correct. In particular, the discussion happens before sending in a pull request.
> 
> Post the link to correct process into README.rst and then this issue can be closed.

The repo readme is not the right place for this. Christian already mentioned
the PEPs and anything should go into the dev guide.

If you have something to contribute, please open a ticket, add a patch
and request review.

Thanks,
-- 
Marc-Andre Lemburg
eGenix.com
msg204679 - (view) Author: anatoly techtonik (techtonik) Date: 2013-11-28 17:19
> The ticket has been closed by two people. Why do you keep re-opening the ticket?

Because you're not providing any arguments. If it is not important for you, just ignore. If something is not clear - ask. What you do is just closing the stuff, because you _feel_ that is not an issue. Provide rationale, address my points and then I'll close it myself. The particular stuff that is not clarified:

>> Post the link to correct process into README.rst and then this
>> issue can be closed.
> The repo readme is not the right place for this. Christian already
> mentioned the PEPs and anything should go into the dev guide.

I want to know why PEPs repository README is not the place to direct users to starting point for submitting enhancement proposals?

> If you have something to contribute, please open a ticket, add a patch
and request review.

I am already keep opening it, damn. I want to contribute an improvement for the PEP process and not forget about it. That's why I fill in into tracker, and not into email.
msg204684 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2013-11-28 17:41
Anatoly, please stop reopening the issue, it's *really* annoying. Not
only you failed to understand correctly your problem (it looks like
nor Christian nor Marc-Andre nor me understood your request), but it
looks like you don't care of our answers.

> PEP repository readme lacks information about how to send Python Enhancement Proposal step-by-step.

Did you at least read the *first* PEP, the PEP which describes the PEP process?
http://www.python.org/dev/peps/pep-0001/

Did you also read the developer guide? The PEP process is also explained there:
http://docs.python.org/devguide/langchanges.html#pep-process

> What I propose it to make PEP repository self-sufficient,

The PEP 1, 9 and 12 are already included in the PEP repository.

I don't understand why you are focused on the README.rst file. PEPs
are more convinient because automatically exported online at:
http://www.python.org/dev/peps/

For example, you must read:
http://www.python.org/dev/peps/pep-0001/

> I am already keep opening it, damn. I want to contribute an improvement for the PEP process and not forget about it. That's why I fill in into tracker, and not into email.

The PEP process is already well described, so your issue is invalid.

You don't propose anything concrete. Example of concrete thing: a
patch on the pep-0001.rst or on README.rst. Or contribute to the
devguide.

Did you sign the contributor agreement?
http://docs.python.org/devguide/coredev.html#sign-a-contributor-agreement

I know that you don't want to sign it, even if I don't understand why
(please don't start discuss it here, the legal mailing list is the
right place), but it's required to contribute to CPython.

--

The PEP process is not so formal. Just start discussing an idea on
python-idea, don't worry of the exact structure of a PEP document. It
can be written later. It is a waste of time to write a full PEP if an
idea is quickly rejected.
msg204696 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2013-11-28 20:06
Closing for the hopefully final time.  Anatoly, if you keep reopening this ticket you have to expect removal of tracker privileges.
msg204748 - (view) Author: Roundup Robot (python-dev) (Python triager) Date: 2013-11-29 18:26
New changeset 34cb64cdbf7b by Guido van Rossum in branch 'default':
Add brief explanation and web pointers to README.txt. Fixes issue 19822.
http://hg.python.org/peps/rev/34cb64cdbf7b
History
Date User Action Args
2013-12-01 02:16:18jceasetnosy: + jcea
2013-11-29 18:35:26gvanrossumsetresolution: rejected -> fixed
2013-11-29 18:26:59python-devsetnosy: + python-dev
messages: + msg204748
2013-11-28 20:06:20georg.brandlsetstatus: open -> closed

nosy: + georg.brandl
messages: + msg204696

resolution: postponed -> rejected
2013-11-28 18:03:55giampaolo.rodolasetnosy: + giampaolo.rodola
2013-11-28 17:41:17vstinnersetmessages: + msg204684
2013-11-28 17:19:30techtoniksetstatus: closed -> open
resolution: not a bug -> postponed
messages: + msg204679
2013-11-28 15:26:50lemburgsetmessages: + msg204671
2013-11-28 14:50:39christian.heimessetstatus: open -> closed
resolution: not a bug
messages: + msg204667
2013-11-28 14:45:05techtoniksetstatus: closed -> open
resolution: not a bug -> (no value)
messages: + msg204665
2013-11-28 14:34:12lemburgsetstatus: pending -> closed

nosy: + lemburg
messages: + msg204658

resolution: not a bug
2013-11-28 14:28:10techtoniksetstatus: closed -> pending
resolution: not a bug -> (no value)
messages: + msg204657
2013-11-28 14:06:59vstinnersetnosy: + vstinner
messages: + msg204655
2013-11-28 14:04:49christian.heimessetstatus: open -> closed

nosy: + christian.heimes
messages: + msg204654

resolution: not a bug
2013-11-28 13:59:29techtonikcreate