classification
Title: buildbot: test_asynchat and test_smtplib failures on Tiger: [Errno 9] Bad file descriptor
Type: Stage:
Components: Library (Lib), Tests Versions: Python 2.6
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: db3l, mark.dickinson, ned.deily, vstinner
Priority: normal Keywords:

Created on 2010-04-19 11:35 by vstinner, last changed 2010-08-11 15:30 by mark.dickinson. This issue is now closed.

Messages (5)
msg103579 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2010-04-19 11:35
http://www.python.org/dev/buildbot/builders/x86 Tiger 2.6/builds/9/steps/test/logs/stdio

test_asynchat
test test_asynchat produced unexpected output:
**********************************************************************
error: uncaptured python exception, closing channel <test.test_asynchat.echo_client at 0x45a04f8> (<class 'socket.error'>:[Errno 9] Bad file descriptor [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/asyncore.py|readwrite|107] [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/asyncore.py|handle_expt_event|441] [<string>|getsockopt|1] [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/socket.py|_dummy|165])
error: uncaptured python exception, closing channel <test.test_asynchat.echo_client at 0x45a0c38> (<class 'socket.error'>:[Errno 9] Bad file descriptor [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/asyncore.py|readwrite|107] [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/asyncore.py|handle_expt_event|441] [<string>|getsockopt|1] [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/socket.py|_dummy|165])
error: uncaptured python exception, closing channel <test.test_asynchat.echo_client at 0x45a09f8> (<class 'socket.error'>:[Errno 9] Bad file descriptor [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/asyncore.py|readwrite|107] [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/asyncore.py|handle_expt_event|441] [<string>|getsockopt|1] [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/socket.py|_dummy|165])
error: uncaptured python exception, closing channel <test.test_asynchat.echo_client at 0x45a0b78> (<class 'socket.error'>:[Errno 9] Bad file descriptor [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/asyncore.py|readwrite|107] [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/asyncore.py|handle_expt_event|441] [<string>|getsockopt|1] [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/socket.py|_dummy|165])
error: uncaptured python exception, closing channel <test.test_asynchat.echo_client at 0x45a07f8> (<class 'socket.error'>:[Errno 9] Bad file descriptor [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/asyncore.py|readwrite|107] [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/asyncore.py|handle_expt_event|441] [<string>|getsockopt|1] [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/socket.py|_dummy|165])
error: uncaptured python exception, closing channel <test.test_asynchat.echo_client at 0x45a0c38> (<class 'socket.error'>:[Errno 9] Bad file descriptor [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/asyncore.py|readwrite|107] [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/asyncore.py|handle_expt_event|441] [<string>|getsockopt|1] [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/socket.py|_dummy|165])
error: uncaptured python exception, closing channel <test.test_asynchat.echo_client at 0x45a09f8> (<class 'socket.error'>:[Errno 9] Bad file descriptor [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/asyncore.py|readwrite|107] [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/asyncore.py|handle_expt_event|441] [<string>|getsockopt|1] [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/socket.py|_dummy|165])
error: uncaptured python exception, closing channel <test.test_asynchat.echo_client at 0x45a0cf8> (<class 'socket.error'>:[Errno 9] Bad file descriptor [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/asyncore.py|readwrite|107] [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/asyncore.py|handle_expt_event|441] [<string>|getsockopt|1] [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/socket.py|_dummy|165])
error: uncaptured python exception, closing channel <test.test_asynchat.echo_client at 0x45a07f8> (<class 'socket.error'>:[Errno 9] Bad file descriptor [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/asyncore.py|readwrite|107] [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/asyncore.py|handle_expt_event|441] [<string>|getsockopt|1] [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/socket.py|_dummy|165])
error: uncaptured python exception, closing channel <test.test_asynchat.echo_client at 0x45a0c38> (<class 'socket.error'>:[Errno 9] Bad file descriptor [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/asyncore.py|readwrite|107] [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/asyncore.py|handle_expt_event|441] [<string>|getsockopt|1] [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/socket.py|_dummy|165])
error: uncaptured python exception, closing channel <test.test_asynchat.echo_client at 0x45a07b8> (<class 'socket.error'>:[Errno 9] Bad file descriptor [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/asyncore.py|readwrite|107] [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/asyncore.py|handle_expt_event|441] [<string>|getsockopt|1] [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/socket.py|_dummy|165])
error: uncaptured python exception, closing channel <test.test_asynchat.echo_client at 0x45a0cb8> (<class 'socket.error'>:[Errno 9] Bad file descriptor [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/asyncore.py|readwrite|107] [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/asyncore.py|handle_expt_event|441] [<string>|getsockopt|1] [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/socket.py|_dummy|165])
error: uncaptured python exception, closing channel <test.test_asynchat.echo_client at 0x45a04f8> (<class 'socket.error'>:[Errno 9] Bad file descriptor [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/asyncore.py|readwrite|107] [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/asyncore.py|handle_expt_event|441] [<string>|getsockopt|1] [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/socket.py|_dummy|165])
error: uncaptured python exception, closing channel <test.test_asynchat.echo_client at 0x45a0c38> (<class 'socket.error'>:[Errno 9] Bad file descriptor [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/asyncore.py|readwrite|107] [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/asyncore.py|handle_expt_event|441] [<string>|getsockopt|1] [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/socket.py|_dummy|165])
error: uncaptured python exception, closing channel <test.test_asynchat.echo_client at 0x45a07b8> (<class 'socket.error'>:[Errno 9] Bad file descriptor [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/asyncore.py|readwrite|107] [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/asyncore.py|handle_expt_event|441] [<string>|getsockopt|1] [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/socket.py|_dummy|165])
error: uncaptured python exception, closing channel <test.test_asynchat.echo_client at 0x45a0d78> (<class 'socket.error'>:[Errno 9] Bad file descriptor [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/asyncore.py|readwrite|107] [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/asyncore.py|handle_expt_event|441] [<string>|getsockopt|1] [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/socket.py|_dummy|165])

**********************************************************************

test_smtplib
test test_smtplib produced unexpected output:
**********************************************************************
error: uncaptured python exception, closing channel <test.test_smtplib.SimSMTPChannel 127.0.0.1:55603 at 0x4323cb8> (<class 'socket.error'>:[Errno 9] Bad file descriptor [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/asyncore.py|readwrite|107] [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/asyncore.py|handle_expt_event|441] [<string>|getsockopt|1] [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/socket.py|_dummy|165])
error: uncaptured python exception, closing channel <test.test_smtplib.SimSMTPChannel 127.0.0.1:55606 at 0x43236f8> (<class 'socket.error'>:[Errno 9] Bad file descriptor [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/asyncore.py|readwrite|107] [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/asyncore.py|handle_expt_event|441] [<string>|getsockopt|1] [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/socket.py|_dummy|165])
error: uncaptured python exception, closing channel <test.test_smtplib.SimSMTPChannel 127.0.0.1:55609 at 0x43152b8> (<class 'socket.error'>:[Errno 9] Bad file descriptor [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/asyncore.py|readwrite|107] [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/asyncore.py|handle_expt_event|441] [<string>|getsockopt|1] [/Users/db3l/buildarea/2.6.bolen-tiger/build/Lib/socket.py|_dummy|165])

**********************************************************************
msg103585 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2010-04-19 11:54
See also #8458.
msg103597 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2010-04-19 14:08
Duplicate of Issue7037 (test_asynchat) and Issue7040 (test_smtplib).
msg113603 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2010-08-11 15:28
As Mark has ported the fix for Issue5798 to 2.6, this can be closed, too.
msg113605 - (view) Author: Mark Dickinson (mark.dickinson) * (Python committer) Date: 2010-08-11 15:30
Thanks, Ned!
History
Date User Action Args
2010-08-11 15:30:31mark.dickinsonsetstatus: open -> closed
resolution: fixed
messages: + msg113605
2010-08-11 15:28:44ned.deilysetnosy: + mark.dickinson
messages: + msg113603
2010-04-19 14:08:14ned.deilysetnosy: + ned.deily
messages: + msg103597
2010-04-19 11:54:15vstinnersetmessages: + msg103585
2010-04-19 11:35:10vstinnercreate