classification
Title: test_asynchat fails on os x 10.6
Type: behavior Stage: needs patch
Components: Library (Lib), Tests Versions: Python 2.6
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: josiahcarlson Nosy List: barry, chuck, josiahcarlson, mark.dickinson, ned.deily
Priority: normal Keywords:

Created on 2009-10-02 20:15 by chuck, last changed 2010-08-11 15:31 by mark.dickinson. This issue is now closed.

Files
File name Uploaded Description Edit
test_asynchat.fail chuck, 2009-10-02 20:15
Messages (4)
msg93452 - (view) Author: Jan (chuck) * Date: 2009-10-02 20:15
Loads of outputs like
test_string_producer (test.test_asynchat.TestAsynchat_WithPoll) ... 
error: uncaptured python exception, closing channel 
<test.test_asynchat.echo_client at 0x3ca670> (<class 
'socket.error'>:[Errno 9] Bad file descriptor 
[/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/asyncor
e.py|readwrite|107] 
[/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/asyncor
e.py|handle_expt_event|441] [<string>|getsockopt|1] 
[/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/socket.
py|_dummy|165])

Test says it passes, though. Complete output is attached.
msg93460 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2009-10-02 23:36
This is a duplicate of Issue5798, the fix for which has not been 
backported to 2.6.  It is also not limited to OS X 10.6.
msg100750 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2010-03-09 20:43
Still failing as of 2.6.5rc1.
msg113602 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2010-08-11 15:27
As Mark has ported the fix for Issue5798 to 2.6 (thanks!), this can be closed, too.
History
Date User Action Args
2010-08-11 15:31:06mark.dickinsonsetstatus: open -> closed
resolution: fixed
2010-08-11 15:27:13ned.deilysetnosy: + mark.dickinson
messages: + msg113602
2010-03-09 20:43:22ned.deilysetnosy: + barry
messages: + msg100750
2009-10-02 23:36:16ned.deilysetnosy: + ned.deily
messages: + msg93460
2009-10-02 20:22:36pitrousetnosy: + josiahcarlson
priority: normal
assignee: josiahcarlson
components: + Library (Lib), Tests
type: behavior
stage: needs patch
2009-10-02 20:15:10chuckcreate