classification
Title: test_smtplib fails on os x 10.6
Type: behavior Stage:
Components: Library (Lib), Tests Versions: Python 2.6
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: Nosy List: barry, chuck, giampaolo.rodola, l0nwlf, ned.deily
Priority: normal Keywords:

Created on 2009-10-02 20:38 by chuck, last changed 2010-05-10 15:57 by giampaolo.rodola. This issue is now closed.

Files
File name Uploaded Description Edit
test_smtplib.fail chuck, 2009-10-02 20:38
Messages (4)
msg93455 - (view) Author: Jan (chuck) * Date: 2009-10-02 20:38
Output like:
testAUTH_PLAIN (test.test_smtplib.SMTPSimTests) ... error: uncaptured 
python exception, closing channel <test.test_smtplib.SimSMTPChannel 
127.0.0.1:54223 at 0x728468> (<class 'socket.error'>:[Errno 9] Bad file 
descriptor 
[/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/asyncor
e.py|readwrite|107] 
[/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/asyncor
e.py|handle_expt_event|441] [<string>|getsockopt|1] 
[/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/socket.
py|_dummy|165])

Probably related to #7037 . Complete output attached.
msg93465 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2009-10-03 00:42
Appears to be a duplicate of Issue3620.  It is also not limited to 10.6.
msg100751 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2010-03-09 20:44
Still failing as of 2.6.5rc1.
msg105445 - (view) Author: Giampaolo Rodola' (giampaolo.rodola) * (Python committer) Date: 2010-05-10 15:57
Closed as duplicate of issue7037.
History
Date User Action Args
2010-05-10 15:57:42giampaolo.rodolasetstatus: open -> closed

nosy: + giampaolo.rodola
messages: + msg105445

resolution: duplicate
2010-03-31 01:25:58l0nwlfsetnosy: + l0nwlf
2010-03-09 20:44:03ned.deilysetnosy: + barry
messages: + msg100751
2009-10-03 00:42:44ned.deilysetnosy: + ned.deily
messages: + msg93465
2009-10-02 20:38:31chuckcreate