classification
Title: Documentation job fails on CIs: duplicate token description of format_spec
Type: Stage: resolved
Components: Documentation Versions: Python 3.10, Python 3.9, Python 3.8
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: docs@python Nosy List: BTaskaya, cameron, corona10, docs@python, lukasz.langa, miss-islington, pablogsal, terry.reedy, vstinner
Priority: normal Keywords: patch

Created on 2020-09-11 10:45 by vstinner, last changed 2020-10-05 16:10 by lukasz.langa. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 22199 closed vstinner, 2020-09-11 11:50
PR 22281 merged vstinner, 2020-09-16 15:03
PR 22300 merged miss-islington, 2020-09-18 07:10
PR 22301 merged miss-islington, 2020-09-18 07:12
Messages (14)
msg376717 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2020-09-11 10:45
https://travis-ci.com/github/python/cpython/jobs/383579366

Warning, treated as error:

/home/travis/build/python/cpython/Doc/library/string.rst:311:duplicate token description of format_spec, other instance in reference/lexical_analysis
msg376718 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2020-09-11 10:49
There are two format_spec definitions:

"format_spec     ::=  [[fill]align][sign][#][0][width][grouping_option][.precision][type]"
https://docs.python.org/dev/library/string.html#format-specification-mini-language

"format_spec       ::=  (literal_char | NULL | replacement_field)*"
https://docs.python.org/dev/reference/lexical_analysis.html#formatted-string-literals
msg376722 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2020-09-11 11:16
I failed to reproduce the issue locally. I tried:

cd Doc
make clean
make venv PYTHON=../python 
./venv/bin/python -m pip install sphinx==2.2.0 blurb python-docs-theme
make check suspicious html SPHINXOPTS="-q -W -j4"
msg376726 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2020-09-11 12:07
Oh. It seems like the warning only occurs randomly!? It is gone on one of my PR.
msg376765 - (view) Author: Dong-hee Na (corona10) * (Python committer) Date: 2020-09-12 02:58
>>> sphinx.__version__
'3.2.1

I can reproduce this issue consistantly on my local machine with this environment.
msg376774 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2020-09-12 04:28
Two issues about Sphinx 3.2.1 failing with "duplicate token description"
(posted on both)
#41760 'sign', multiple people nosy, failed where?
#41762 'format_spec', on Travis, PR by Victor Stinner (2.2.0 okay)
msg376787 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2020-09-12 06:55
I closed bpo-41760 as a duplicate of this issue.
msg376788 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2020-09-12 06:55
> I closed bpo-41760 as a duplicate of this issue.

The error message was different but similar:

Warning, treated as error:
/<<PKGBUILDDIR>>/Doc/library/string.rst:311:duplicate token description of sign, other instance in library/functions
msg376999 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2020-09-16 14:43
".. productionlist::" markup is related to "Grammar production displays":
https://www.sphinx-doc.org/en/master/usage/restructuredtext/directives.html#grammar-production-displays

We can try to pass a different unique name to each ".. productionlist::" markup:

"The productionGroup argument to productionlist serves to distinguish different sets of production lists that belong to different grammars. Multiple production lists with the same productionGroup thus define rules in the same scope."
msg377089 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2020-09-18 07:10
New changeset 8af239eacfcf52e4e0e2b0223e7cea4672309483 by Victor Stinner in branch 'master':
bpo-41762: Fix usage of productionlist markup in the doc (GH-22281)
https://github.com/python/cpython/commit/8af239eacfcf52e4e0e2b0223e7cea4672309483
msg377091 - (view) Author: miss-islington (miss-islington) Date: 2020-09-18 07:27
New changeset c053402927d36f9f26160ded24999bf5109ea5eb by Miss Islington (bot) in branch '3.9':
bpo-41762: Fix usage of productionlist markup in the doc (GH-22281)
https://github.com/python/cpython/commit/c053402927d36f9f26160ded24999bf5109ea5eb
msg377095 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2020-09-18 08:31
New changeset c5cddc17b5c046bb22072c1cf58b898c7ab92e07 by Miss Islington (bot) in branch '3.8':
bpo-41762: Fix usage of productionlist markup in the doc (GH-22281) (GH-22300)
https://github.com/python/cpython/commit/c5cddc17b5c046bb22072c1cf58b898c7ab92e07
msg377096 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2020-09-18 08:32
I fixed the issue.

See bpo-35293 for deprecation warnings.
msg378058 - (view) Author: Łukasz Langa (lukasz.langa) * (Python committer) Date: 2020-10-05 16:10
New changeset e5cc5fd89cc8855ad644ce4ba5e7de766313e418 by Łukasz Langa (Miss Islington (bot)) in branch '3.9':
bpo-41762: Fix usage of productionlist markup in the doc (GH-22281)
https://github.com/python/cpython/commit/e5cc5fd89cc8855ad644ce4ba5e7de766313e418
History
Date User Action Args
2020-10-05 16:10:20lukasz.langasetnosy: + lukasz.langa
messages: + msg378058
2020-09-18 08:32:20vstinnersetstatus: open -> closed
versions: + Python 3.8, Python 3.9
messages: + msg377096

resolution: fixed
stage: patch review -> resolved
2020-09-18 08:31:32vstinnersetmessages: + msg377095
2020-09-18 07:27:31miss-islingtonsetmessages: + msg377091
2020-09-18 07:12:06miss-islingtonsetpull_requests: + pull_request21350
2020-09-18 07:10:32miss-islingtonsetnosy: + miss-islington
pull_requests: + pull_request21349
2020-09-18 07:10:24vstinnersetmessages: + msg377089
2020-09-16 15:03:09vstinnersetpull_requests: + pull_request21333
2020-09-16 14:43:41vstinnersetmessages: + msg376999
2020-09-16 00:47:34cameronsetnosy: + cameron
2020-09-12 06:55:55vstinnersetmessages: + msg376788
2020-09-12 06:55:11vstinnersetmessages: + msg376787
2020-09-12 06:54:53vstinnerlinkissue41760 superseder
2020-09-12 04:28:16terry.reedysetnosy: + terry.reedy
messages: + msg376774
2020-09-12 02:58:31corona10setnosy: + corona10
messages: + msg376765
2020-09-11 12:07:33vstinnersetmessages: + msg376726
2020-09-11 11:50:50vstinnersetkeywords: + patch
stage: patch review
pull_requests: + pull_request21258
2020-09-11 11:16:19vstinnersetmessages: + msg376722
2020-09-11 10:49:11vstinnersetnosy: + pablogsal, BTaskaya
messages: + msg376718
2020-09-11 10:45:24vstinnercreate