classification
Title: 3.8.6 rc1 documentation fails to build with sphinx 3.2.1
Type: Stage: resolved
Components: Build Versions: Python 3.8
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Documentation job fails on CIs: duplicate token description of format_spec
View: 41762
Assigned To: Nosy List: doko, lukasz.langa, ned.deily, terry.reedy, vstinner
Priority: normal Keywords:

Created on 2020-09-11 09:47 by doko, last changed 2020-09-12 06:54 by vstinner. This issue is now closed.

Messages (3)
msg376711 - (view) Author: Matthias Klose (doko) * (Python committer) Date: 2020-09-11 09:47
the 3.8.6 rc1 documentation fails to build with sphinx 3.2.1:

[...]
reading sources... [ 98%] whatsnew/3.1
reading sources... [ 98%] whatsnew/3.2
reading sources... [ 98%] whatsnew/3.3
reading sources... [ 98%] whatsnew/3.4
reading sources... [ 98%] whatsnew/3.5
reading sources... [ 99%] whatsnew/3.6
reading sources... [ 99%] whatsnew/3.7
reading sources... [ 99%] whatsnew/3.8
reading sources... [ 99%] whatsnew/changelog
reading sources... [100%] whatsnew/index

/<<PKGBUILDDIR>>/Doc/tools/extensions/pyspecific.py:245: RemovedInSphinx40Warning: PyModulelevel is deprecated. Please check the implementation of <class 'pyspecific.PyDecoratorFunction'>
  return PyModulelevel.run(self)
/<<PKGBUILDDIR>>/Doc/tools/extensions/pyspecific.py:277: RemovedInSphinx40Warning: PyClassmember is deprecated. Please check the implementation of <class 'pyspecific.PyCoroutineMethod'>
  return PyClassmember.run(self)
/<<PKGBUILDDIR>>/Doc/tools/extensions/pyspecific.py:289: RemovedInSphinx40Warning: PyClassmember is deprecated. Please check the implementation of <class 'pyspecific.PyAwaitableMethod'>
  return PyClassmember.run(self)
/<<PKGBUILDDIR>>/Doc/tools/extensions/pyspecific.py:271: RemovedInSphinx40Warning: PyModulelevel is deprecated. Please check the implementation of <class 'pyspecific.PyCoroutineFunction'>
  return PyModulelevel.run(self)
/<<PKGBUILDDIR>>/Doc/tools/extensions/pyspecific.py:283: RemovedInSphinx40Warning: PyClassmember is deprecated. Please check the implementation of <class 'pyspecific.PyAwaitableFunction'>
  return PyClassmember.run(self)
/<<PKGBUILDDIR>>/Doc/tools/extensions/pyspecific.py:302: RemovedInSphinx40Warning: PyClassmember is deprecated. Please check the implementation of <class 'pyspecific.PyAbstractMethod'>
  return PyClassmember.run(self)

Warning, treated as error:
/<<PKGBUILDDIR>>/Doc/library/string.rst:311:duplicate token description of sign, other instance in library/functions
make[1]: *** [Makefile:52: build] Error 2
msg376773 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2020-09-12 04:27
Two issues about Sphinx 3.2.1 failing with "duplicate token description"
(posted on both)
#41760 'sign', multiple people nosy, failed where?
#41762 'format_spec', on Travis, PR by Victor Stinner (2.2.0 okay)
msg376786 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2020-09-12 06:54
I close this issue as a duplicate of bpo-41762.
History
Date User Action Args
2020-09-12 06:54:53vstinnersetstatus: open -> closed
superseder: Documentation job fails on CIs: duplicate token description of format_spec
messages: + msg376786

resolution: duplicate
stage: resolved
2020-09-12 04:27:59terry.reedysetnosy: + terry.reedy
messages: + msg376773
2020-09-12 01:33:35terry.reedysetnosy: + vstinner
2020-09-11 11:09:55dokosetnosy: + lukasz.langa
2020-09-11 09:47:51dokosetnosy: + ned.deily
2020-09-11 09:47:08dokocreate