classification
Title: No run option available in python idle in version 3.8.2
Type: performance Stage: resolved
Components: IDLE Versions: Python 3.8
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: terry.reedy Nosy List: Murat_Turan, Raj_110, terry.reedy
Priority: normal Keywords:

Created on 2020-03-27 07:04 by Raj_110, last changed 2020-08-31 22:16 by terry.reedy. This issue is now closed.

Messages (8)
msg365137 - (view) Author: Rajesh R Naik (Raj_110) Date: 2020-03-27 07:04
i using pyhton 3.8.2 latest version in that there no run option available in python idle.
so please help
also iam using windows 10 home
msg365164 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2020-03-27 16:25
Run only appears on the main menu of editor windows, not Shell or Output windows.  If it does not appear, that would be a major bug.  But I have no problem with 3.8.2 on Win10 Pro.

If you do not have Run in an editor, or do but do not have Run Module or Run Customized on the Run menu, please supply much more detailed information.
1. How are you installing python?  From the python.org installer (which one)?  From the Window store?  From a 3rd party installer (which one)?
2. How do you start IDLE?
3. What does Help => About IDLE say about the tk version?
4. How do you get an editor window?  What do you see on the menu?  If Run appears, what happens when you click it?
5. Start IDLE from Command Prompt with "py -3.8 -m idlelib".  Do you ever see any error messages?
6. Have you touched any files in Lib/idlelib?
msg365569 - (view) Author: Rajesh R Naik (Raj_110) Date: 2020-04-02 05:18
i thought this issue is with windows home edition 
please confirm and resolve
msg365574 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2020-04-02 09:02
I cannot do anything until you answer all 6 question.  Perhaps you should post on python-list to get help doing so.
msg365676 - (view) Author: Rajesh R Naik (Raj_110) Date: 2020-04-03 07:11
1.How are you installing python?  From the python.org installer (which one)?  From the Window store?  From a 3rd party installer (which one)?
>> we installed form python.org not from windows store and not 3rd party
2.How do you start IDLE?
>> by searching python idle on start windows in laptop
3. What does Help => About IDLE say about the tk version?
>> We are using python 3.8.2 version
4.How do you get an editor window?  What do you see on the menu?  If Run appears, what happens when you click it?
>> after installed its shows the editor window in that not showing run option.
5.Start IDLE from Command Prompt with "py -3.8 -m idlelib".  Do you ever see any error messages?
>> no idea how to run py idel in command promot
6.Have you touched any files in Lib/idlelib?
>> I have touched the Lib/idlelib.
msg366790 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2020-04-19 17:03
3. You did not answer about the tcl/tk version.

4. When you start from the start menu, there is no Editor window, just the Shell window, which does not have the Run menu.  Again, how did you get an editor window?

5. Search the Web for an illustrated explanation or ask on python-list.

6. 'touch' was the wrong word.  I should have asked, "Have you changed any of the  files in Lib/idlelib?  If which ones, and how?"
msg376169 - (view) Author: Murat Turan (Murat_Turan) Date: 2020-08-31 21:28
There is a very simple solution for that. Open IDLE, if you dont see RUN tab, its opened in "Shell" mode. Go Options --> Configure IDLE, click to "General" tab and choose "Open Edit Window" option for start-up. That's it!
msg376171 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2020-08-31 22:16
I am assuming that Murat is correct that the only problem is confusion between 'Shell' (which is a subclass of the base editor window) and Editor Window (which is a different subclass).  For further help, please to to a general forum, such as python-list.
History
Date User Action Args
2020-08-31 22:16:17terry.reedysetstatus: open -> closed
resolution: not a bug
messages: + msg376171

stage: resolved
2020-08-31 21:28:53Murat_Turansetnosy: + Murat_Turan
messages: + msg376169
2020-04-19 17:03:32terry.reedysetmessages: + msg366790
2020-04-03 07:11:54Raj_110setmessages: + msg365676
2020-04-02 09:02:21terry.reedysetmessages: + msg365574
2020-04-02 05:18:30Raj_110setmessages: + msg365569
2020-03-27 16:25:11terry.reedysetnosy: - twouters
messages: + msg365164
2020-03-27 07:04:44Raj_110create