classification
Title: test__xxsubinterpreters: random failures on AMD64 FreeBSD CURRENT Shared 3.x
Type: Stage: resolved
Components: Tests Versions: Python 3.9
process
Status: closed Resolution: duplicate
Dependencies: Superseder: [subinterpreters] test__xxsubinterpreters fails randomly
View: 37224
Assigned To: Nosy List: aeros, eric.snow, nanjekyejoannah, vstinner
Priority: normal Keywords: patch

Created on 2019-09-13 09:50 by vstinner, last changed 2019-10-14 21:26 by vstinner. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 16293 closed aeros, 2019-09-20 08:08
Messages (5)
msg352271 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2019-09-13 09:50
It seems like test__xxsubinterpreters still has race conditions.

See also bpo-37224 and bpo-33356.

AMD64 FreeBSD CURRENT Shared 3.x:
https://buildbot.python.org/all/#/builders/168/builds/1428

FAIL: test_subinterpreter (test.test__xxsubinterpreters.IsRunningTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/home/buildbot/python/3.x.koobs-freebsd-current/build/Lib/test/test__xxsubinterpreters.py", line 492, in test_subinterpreter
    self.assertTrue(interpreters.is_running(interp))
AssertionError: False is not true

Later, when test__xxsubinterpreters is re-run in verbose mode:

FAIL: test_still_running (test.test__xxsubinterpreters.DestroyTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/home/buildbot/python/3.x.koobs-freebsd-current/build/Lib/test/test__xxsubinterpreters.py", line 765, in test_still_running
    interpreters.destroy(interp)
AssertionError: RuntimeError not raised
msg352520 - (view) Author: Kyle Stanley (aeros) * (Python committer) Date: 2019-09-16 07:09
I believe I found a potential fix, see https://bugs.python.org/issue37224?@ok_message=msg%20352516%20created%0Aissue%2037224%20message_count%2C%20messages%20edited%20ok&@template=item#msg352514. Should I attach the PR to that issue or this one?
msg352841 - (view) Author: Kyle Stanley (aeros) * (Python committer) Date: 2019-09-20 08:11
For an updated explanation of the PR, see https://bugs.python.org/msg352835 or the comments in the PR itself.
msg353546 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2019-09-30 06:59
https://buildbot.python.org/all/#/builders/286/builds/27

FAIL: test_subinterpreter (test.test__xxsubinterpreters.IsRunningTests)
msg354660 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2019-10-14 21:26
I close this issue as a duplicate of bpo-37224.
History
Date User Action Args
2019-10-14 21:26:24vstinnersetstatus: open -> closed
superseder: [subinterpreters] test__xxsubinterpreters fails randomly
messages: + msg354660

resolution: duplicate
stage: resolved
2019-09-30 06:59:03vstinnersetmessages: + msg353546
2019-09-20 08:11:07aerossetmessages: + msg352841
stage: patch review -> (no value)
2019-09-20 08:08:34aerossetkeywords: + patch
stage: patch review
pull_requests: + pull_request15879
2019-09-16 07:09:58aerossetnosy: + aeros
messages: + msg352520
2019-09-13 09:51:01vstinnersetnosy: + nanjekyejoannah
2019-09-13 09:50:39vstinnercreate