classification
Title: Windows 10 buildbot: test__xxsubinterpreters.test_already_running() fails randomly
Type: Stage: resolved
Components: Tests Versions: Python 3.8
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: Nosy List: eric.snow, pablogsal, vstinner
Priority: normal Keywords:

Created on 2018-04-25 14:26 by vstinner, last changed 2019-10-14 21:23 by vstinner. This issue is now closed.

Messages (5)
msg315737 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2018-04-25 14:26
Windows10 3.x: test_already_running() failed once, but passed when run again:

http://buildbot.python.org/all/#/builders/3/builds/817/steps/3/logs/stdio

======================================================================
FAIL: test_already_running (test.test__xxsubinterpreters.RunStringTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "D:\buildarea\3.x.bolen-windows10\build\lib\test\test__xxsubinterpreters.py", line 561, in test_already_running
    interpreters.run_string(self.id, 'print("spam")')
AssertionError: RuntimeError not raised

(...)
Re-running test 'test__xxsubinterpreters' in verbose mode
(...)
Ran 94 tests in 14.582s
OK (skipped=3)
msg318097 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2018-05-29 21:32
I didn't see this failure recently, I close the bug.
msg338973 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2019-03-27 16:06
The bug is still here. It looks like a race condition triggered on very slow buildbot like AMD64 FreeBSD 10-STABLE Non-Debug 3.x:

https://buildbot.python.org/all/#/builders/167/builds/728

0:18:13 load avg: 4.84 [405/420/1] test__xxsubinterpreters failed -- running: test_tools (6 min 1 sec)
spam
test_bad_id (test.test__xxsubinterpreters.ChannelIDTests) ... ok
(...)
test_initial (test.test__xxsubinterpreters.ListAllTests) ... ok
test_SystemExit (test.test__xxsubinterpreters.RunStringTests) ... ok
test_already_running (test.test__xxsubinterpreters.RunStringTests) ... FAIL
test_bad_id (test.test__xxsubinterpreters.RunStringTests) ... Exception in thread Thread-9:
Traceback (most recent call last):
  File "/usr/home/buildbot/python/3.x.koobs-freebsd10.nondebug/build/Lib/threading.py", line 917, in _bootstrap_inner
    self.run()
  File "/usr/home/buildbot/python/3.x.koobs-freebsd10.nondebug/build/Lib/threading.py", line 865, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/home/buildbot/python/3.x.koobs-freebsd10.nondebug/build/Lib/test/test__xxsubinterpreters.py", line 51, in run
    interpreters.run_string(interp, dedent(f"""
RuntimeError: interpreter already running

ok
test_bad_script (test.test__xxsubinterpreters.RunStringTests) ... ok
test_bytes_for_script (test.test__xxsubinterpreters.RunStringTests) ... ok
(...)

======================================================================
FAIL: test_already_running (test.test__xxsubinterpreters.RunStringTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/home/buildbot/python/3.x.koobs-freebsd10.nondebug/build/Lib/test/test__xxsubinterpreters.py", line 855, in test_already_running
    interpreters.run_string(self.id, 'print("spam")')
AssertionError: RuntimeError not raised

----------------------------------------------------------------------

Ran 112 tests in 12.936s

FAILED (failures=1, skipped=5)
test test__xxsubinterpreters failed
(...)
Re-running test 'test__xxsubinterpreters' in verbose mode
(...)
Ran 112 tests in 3.058s
OK (skipped=5)
msg339157 - (view) Author: Eric Snow (eric.snow) * (Python committer) Date: 2019-03-29 22:03
I'll take a look when I get a chance.
msg354657 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2019-10-14 21:23
I close this issue as a duplicate of bpo-37224.
History
Date User Action Args
2019-10-14 21:23:30vstinnersetstatus: open -> closed
resolution: duplicate
messages: + msg354657
2019-03-29 22:03:27eric.snowsetmessages: + msg339157
2019-03-27 16:06:17vstinnersetstatus: closed -> open

nosy: + pablogsal
messages: + msg338973

resolution: out of date -> (no value)
2018-05-29 21:32:52vstinnersetstatus: open -> closed
resolution: out of date
messages: + msg318097

stage: resolved
2018-04-25 14:26:40vstinnercreate