classification
Title: 3.4 cherry-pick: multiple changesets for asyncio
Type: Stage:
Components: Versions: Python 3.4
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: larry Nosy List: gvanrossum, larry, vajrasky, vstinner, yselivanov
Priority: release blocker Keywords:

Created on 2014-02-16 23:54 by vstinner, last changed 2014-03-04 10:22 by vstinner. This issue is now closed.

Messages (53)
msg211379 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2014-02-16 23:54
I consider that it's not too late to include these changes to Python 3.4 final because asyncio module is new in Python 3.4. Very few people outside asyncio developers are testing asyncio, so it's not surprising to see these changes only recently. asyncio received a lot of love recently, and it was even more improved.

Most recent to oldest.
----------------------------------------
changeset:   89183:3b0a1b3c0022
user:        Victor Stinner <victor.stinner@gmail.com>
date:        Thu Feb 13 10:46:05 2014 +0100
files:       Lib/test/test_asyncio/test_events.py
description:
Fix test_asyncio/test_events.py: skip IPv6 if IPv6 is disabled on the host


changeset:   89179:95de14f53cf5
user:        Victor Stinner <victor.stinner@gmail.com>
date:        Thu Feb 13 09:24:37 2014 +0100
files:       Doc/library/asyncio-eventloop.rst Lib/asyncio/base_events.py Lib/asyncio/proactor_events.py Lib
description:
ayncio, Tulip issue 129: BaseEventLoop.sock_connect() now raises an error if
the address is not resolved (hostname instead of an IP address) for AF_INET and
AF_INET6 address families.


changeset:   89176:6e04027ed53e
user:        Guido van Rossum <guido@python.org>
date:        Wed Feb 12 17:58:19 2014 -0800
files:       Lib/asyncio/tasks.py Lib/test/test_asyncio/test_tasks.py
description:
asyncio: Change as_completed() to use a Queue, to avoid O(N**2) behavior. Fixes issue #20566.


changeset:   89175:920304e1f36b
user:        Yury Selivanov <yselivanov@sprymix.com>
date:        Wed Feb 12 17:01:52 2014 -0500
files:       Lib/asyncio/events.py
description:
asyncio.events: Use __slots__ in Handle and TimerHandle


changeset:   89157:2ba583191550
user:        Victor Stinner <victor.stinner@gmail.com>
date:        Tue Feb 11 18:40:56 2014 +0100
files:       Lib/test/test_asyncio/test_events.py
description:
Issue #20495: Skip test_read_pty_output() of test_asyncio on FreeBSD older than
FreeBSD 8


changeset:   89147:15a6be05e970
user:        Victor Stinner <victor.stinner@gmail.com>
date:        Tue Feb 11 11:54:08 2014 +0100
files:       Lib/asyncio/tasks.py Lib/test/test_asyncio/test_tasks.py
description:
asyncio, Tulip issue 131: as_completed() and wait() now raises a TypeError if
the list of futures is not a list but a Future, Task or coroutine object


changeset:   89146:f729e9ee5dfc
user:        Victor Stinner <victor.stinner@gmail.com>
date:        Tue Feb 11 11:44:56 2014 +0100
files:       Lib/asyncio/base_events.py Lib/asyncio/subprocess.py Lib/test/test_asyncio/test_base_events.py
description:
asyncio, Tulip issue 130: Add more checks on subprocess_exec/subprocess_shell
parameters


changeset:   89145:3ba4742a6fde
user:        Victor Stinner <victor.stinner@gmail.com>
date:        Tue Feb 11 11:34:30 2014 +0100
files:       Lib/asyncio/base_events.py Lib/asyncio/test_utils.py Lib/test/test_asyncio/test_base_events.py 
description:
asyncio, Tulip issue 126: call_soon(), call_soon_threadsafe(), call_later(),
call_at() and run_in_executor() now raise a TypeError if the callback is a
coroutine function.
----------------------------------------

Changesets related to debug can be ignored (03cb6ddc7040, 9c1840e8d643, a631b01d1715, 360976a6d8b9).
msg211381 - (view) Author: Yury Selivanov (yselivanov) * (Python committer) Date: 2014-02-16 23:59
I think we should just ask Larry to merge all commits for asyncio in 3.4.
I.e. we won't commit anything that should not go in 3.4 anyways.
msg211382 - (view) Author: Guido van Rossum (gvanrossum) * (Python committer) Date: 2014-02-17 00:09
Right, that has been my understanding. Larry has said he'd give asyncio a
generous exception because it's all new in 3.4.

On Sunday, February 16, 2014, Yury Selivanov <report@bugs.python.org> wrote:

>
> Yury Selivanov added the comment:
>
> I think we should just ask Larry to merge all commits for asyncio in 3.4.
> I.e. we won't commit anything that should not go in 3.4 anyways.
>
> ----------
>
> _______________________________________
> Python tracker <report@bugs.python.org <javascript:;>>
> <http://bugs.python.org/issue20648>
> _______________________________________
>
msg211383 - (view) Author: Guido van Rossum (gvanrossum) * (Python committer) Date: 2014-02-17 00:11
Then again Larry might appreciate a full list of what to cherrypick.

On Sunday, February 16, 2014, Guido van Rossum <report@bugs.python.org>
wrote:

>
> Guido van Rossum added the comment:
>
> Right, that has been my understanding. Larry has said he'd give asyncio a
> generous exception because it's all new in 3.4.
>
> On Sunday, February 16, 2014, Yury Selivanov <report@bugs.python.org<javascript:;>>
> wrote:
>
> >
> > Yury Selivanov added the comment:
> >
> > I think we should just ask Larry to merge all commits for asyncio in 3.4.
> > I.e. we won't commit anything that should not go in 3.4 anyways.
> >
> > ----------
> >
> > _______________________________________
> > Python tracker <report@bugs.python.org <javascript:;> <javascript:;>>
> > <http://bugs.python.org/issue20648>
> > _______________________________________
> >
>
> ----------
>
> _______________________________________
> Python tracker <report@bugs.python.org <javascript:;>>
> <http://bugs.python.org/issue20648>
> _______________________________________
>
msg211404 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2014-02-17 09:56
changeset:   89231:ea4c74cc4da5
tag:         tip
user:        Victor Stinner <victor.stinner@gmail.com>
date:        Mon Feb 17 10:54:30 2014 +0100
files:       Doc/library/asyncio-task.rst
description:
Close #20652: asyncio doc: close the event loop in run_forever() example. Fix
also typo. Patch written by Vajrasky Kok.
msg211422 - (view) Author: Larry Hastings (larry) * (Python committer) Date: 2014-02-17 16:07
Yeah, I considered getting fussy about "you didn't follow instructions".  But this actually is better for me, as it means I can apply the patches in chronological order.

Like Guido said, I intend to be permissive when it comes to asyncio for 3.4.0.  I'm assuming that these patches don't touch anything outside asyncio (implementation and doc).  If that's all they touch, then yeah I'll accept them.  If any of them touch other files then we may need to discuss it.
msg211455 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2014-02-17 23:12
changeset:   89237:b3987d758e49
tag:         tip
user:        Victor Stinner <victor.stinner@gmail.com>
date:        Tue Feb 18 00:11:21 2014 +0100
files:       Lib/test/test_asyncio/tests.txt
description:
Issue #20655: Fix test_asyncio, run also subprocess tests. Patch written by
Vajrasky Kok.
msg211487 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2014-02-18 08:24
You may also cherry-pick d548829765cd and b2498889ad8d, skip tests on OpenBSD.

And:

changeset:   89246:6b09a2cf1744
tag:         tip
user:        Victor Stinner <victor.stinner@gmail.com>
date:        Tue Feb 18 09:22:00 2014 +0100
files:       Doc/library/asyncio-dev.rst
description:
Close #20649: Fix typo in asyncio doc. Patch written by Brett Cannon.
msg211492 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2014-02-18 08:38
New changeset 79e5bb0d9b8e by Victor Stinner in branch 'default':
Issue #20493: Document that asyncio should not exceed one day
http://hg.python.org/cpython/rev/79e5bb0d9b8e
msg211524 - (view) Author: Yury Selivanov (yselivanov) * (Python committer) Date: 2014-02-18 17:22
Two new cherry-picks:


changeset:   89253:d6c7d1f18915
tag:         tip
user:        Yury Selivanov <yselivanov@sprymix.com>
date:        Tue Feb 18 12:21:57 2014 -0500
files:       Misc/NEWS
description:
Misc/NEWS: Add a news item for UNIX Sockets support in asyncio. Cleanup WS.


changeset:   89252:c27728212fcd
user:        Yury Selivanov <yselivanov@sprymix.com>
date:        Tue Feb 18 12:15:06 2014 -0500
files:       Lib/asyncio/base_events.py Lib/asyncio/events.py Lib/asyncio/streams.py Lib/asyncio/test_u
description:
asyncio: Add support for UNIX Domain Sockets.
msg211537 - (view) Author: Guido van Rossum (gvanrossum) * (Python committer) Date: 2014-02-18 18:25
This one needs to be CP'ed together with Yuri's UNIX sockets one.

changeset:   89257:f81106f36656
tag:         tip
user:        Guido van Rossum <guido@python.org>
date:        Tue Feb 18 10:24:30 2014 -0800
summary:     asyncio: Make tests pass on Windows.
msg211568 - (view) Author: Yury Selivanov (yselivanov) * (Python committer) Date: 2014-02-18 23:03
changeset:   89262:7c1de1ebb894
tag:         tip
user:        Yury Selivanov <yselivanov@sprymix.com>
date:        Tue Feb 18 18:02:19 2014 -0500
files:       Lib/asyncio/base_events.py Lib/asyncio/events.py Lib/asyncio/futures.py Lib/asyncio/proactor_events.py Lib/asyncio/selector_events.py Lib/asyncio/test_utils.py Lib/asyncio/unix_events.py Lib/asyn
description:
asyncio: New error handling API. Issue #20681.
msg211570 - (view) Author: Yury Selivanov (yselivanov) * (Python committer) Date: 2014-02-18 23:43
http://hg.python.org/cpython/rev/72dba0d11235
changeset:   89263:72dba0d11235
user:        Yury Selivanov <yselivanov@sprymix.com>
date:        Tue Feb 18 18:41:13 2014 -0500
summary:
  asyncio.transports: Make _ProactorBasePipeTransport use _FlowControlMixin
msg211572 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2014-02-19 00:42
changeset:   89264:2406566d2c04
tag:         tip
user:        Victor Stinner <victor.stinner@gmail.com>
date:        Wed Feb 19 01:40:41 2014 +0100
files:       Lib/asyncio/proactor_events.py Lib/asyncio/selector_events.py Lib/asyncio/unix_events.py Lib/test/test_asyncio/test_proactor_events.py Lib/test/test_asyncio/test_s
description:
asyncio, Tulip issue 139: Improve error messages on "fatal errors"

Mention if the error was caused by a read or a write, and be more specific on
the object (ex: "pipe transport" instead of "transport").
msg211573 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2014-02-19 00:46
changeset:   89265:089ce5ddc147
tag:         tip
user:        Victor Stinner <victor.stinner@gmail.com>
date:        Wed Feb 19 01:45:59 2014 +0100
files:       Lib/asyncio/unix_events.py Lib/test/test_asyncio/test_unix_events.py
description:
asyncio, Tulip issue 143: UNIX domain methods, fix ResourceWarning and
DeprecationWarning warnings. create_unix_server() closes the socket on any
error, not only on OSError.
msg211597 - (view) Author: Yury Selivanov (yselivanov) * (Python committer) Date: 2014-02-19 03:29
Minor stuff:

changeset:   89267:2b0e65df8821
tag:         tip
user:        Yury Selivanov <yselivanov@sprymix.com>
date:        Tue Feb 18 22:27:48 2014 -0500
files:       Lib/asyncio/events.py Lib/asyncio/protocols.py Lib/asyncio/selector_events.p
description:
asyncio: Fix spelling and typos.

Thanks to Vajrasky Kok for discovering some of them.
msg211598 - (view) Author: Yury Selivanov (yselivanov) * (Python committer) Date: 2014-02-19 03:57
changeset:   89268:2e8a142dbccc
tag:         tip
user:        Yury Selivanov <yselivanov@sprymix.com>
date:        Tue Feb 18 22:56:15 2014 -0500
files:       Lib/asyncio/base_events.py Lib/asyncio/subprocess.py Lib/test/test_asyncio/t
description:
asyncio: pep8-ify the code.
msg211599 - (view) Author: Larry Hastings (larry) * (Python committer) Date: 2014-02-19 03:58
2e8a142dbccc just missed today's cherry-picking session.  I'll add it tomorrow.
msg211600 - (view) Author: Guido van Rossum (gvanrossum) * (Python committer) Date: 2014-02-19 04:22
TBH I don't think typos or pep8 cleanups ought to be CP'ed...

On Tuesday, February 18, 2014, Larry Hastings <report@bugs.python.org>
wrote:

>
> Larry Hastings added the comment:
>
> 2e8a142dbccc just missed today's cherry-picking session.  I'll add it
> tomorrow.
>
> ----------
>
> _______________________________________
> Python tracker <report@bugs.python.org <javascript:;>>
> <http://bugs.python.org/issue20648>
> _______________________________________
>
msg211601 - (view) Author: Larry Hastings (larry) * (Python committer) Date: 2014-02-19 04:29
Perhaps, but if they request cherry-picking for revisions after 2e8a142dbccc, skipping 2e8a142dbccc will make the cherry-picking a lot harder.

And I bet I haven't seen the last request for cherry-picking asyncio changes for 3.4.0.
msg211602 - (view) Author: Guido van Rossum (gvanrossum) * (Python committer) Date: 2014-02-19 04:33
Actually I am trying to quell the tide. :-). But nobody sent me a review
request for those...

On Tuesday, February 18, 2014, Larry Hastings <report@bugs.python.org>
wrote:

>
> Larry Hastings added the comment:
>
> Perhaps, but if they request cherry-picking for revisions after
> 2e8a142dbccc, skipping 2e8a142dbccc will make the cherry-picking a lot
> harder.
>
> And I bet I haven't seen the last request for cherry-picking asyncio
> changes for 3.4.0.
>
> ----------
>
> _______________________________________
> Python tracker <report@bugs.python.org <javascript:;>>
> <http://bugs.python.org/issue20648>
> _______________________________________
>
msg211603 - (view) Author: Yury Selivanov (yselivanov) * (Python committer) Date: 2014-02-19 04:34
> Perhaps, but if they request cherry-picking for revisions after 2e8a142dbccc, skipping 2e8a142dbccc will make the cherry-picking a lot harder.

Yes, it may make it harder, it's probably better to merge it (no functional changes in it).

I now think that pep8 commit was a bit too much, I clearly could do that after 3.4. Sorry, Larry, no more non-urgent commits/requests here.
msg211604 - (view) Author: Larry Hastings (larry) * (Python committer) Date: 2014-02-19 04:45
For what it's worth,

Lib/asyncio/*
Lib/test/test_asyncio/*
Doc/library/async*

are all exactly the same between default and the tarball I published this evening.  (Minus Yury's cleanup patch of course.)
msg211605 - (view) Author: Guido van Rossum (gvanrossum) * (Python committer) Date: 2014-02-19 04:46
Thanks for checking!

On Tuesday, February 18, 2014, Larry Hastings <report@bugs.python.org>
wrote:

>
> Larry Hastings added the comment:
>
> For what it's worth,
>
> Lib/asyncio/*
> Lib/test/test_asyncio/*
> Doc/library/async*
>
> are all exactly the same between default and the tarball I published this
> evening.  (Minus Yury's cleanup patch of course.)
>
> ----------
>
> _______________________________________
> Python tracker <report@bugs.python.org <javascript:;>>
> <http://bugs.python.org/issue20648>
> _______________________________________
>
msg211608 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2014-02-19 12:32
changeset:   89269:9cfb3d1cf0d1
tag:         tip
user:        Victor Stinner <victor.stinner@gmail.com>
date:        Wed Feb 19 13:32:34 2014 +0100
files:       Doc/library/asyncio-eventloop.rst
description:
asyncio: document new create_unix_connection() and create_unix_server() methods
of BaseEventLoop
msg211626 - (view) Author: Yury Selivanov (yselivanov) * (Python committer) Date: 2014-02-19 16:12
changeset:   89270:186f6f56f4bc
tag:         tip
user:        Yury Selivanov <yselivanov@sprymix.com>
date:        Wed Feb 19 11:10:52 2014 -0500
files:       Lib/asyncio/transports.py Lib/test/test_asyncio/test_transports.py
description:
asyncio: WriteTransport.set_write_buffer_size to call _maybe_pause_protocol
msg211666 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2014-02-19 22:18
changeset:   89288:dbf13a7d3987
tag:         tip
user:        Victor Stinner <victor.stinner@gmail.com>
date:        Wed Feb 19 23:15:02 2014 +0100
files:       Doc/library/asyncio-dev.rst Doc/library/asyncio-eventloop.rst Doc/using/cmdline.rst Lib/asyncio/bas
description:
asyncio, Tulip issue #136: Add get/set_debug() methods to BaseEventLoopTests.
Add also a PYTHONASYNCIODEBUG environment variable to debug coroutines since
Python startup, to be able to debug coroutines defined directly in the asyncio
module.
msg211669 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2014-02-19 22:25
changeset:   89283:07cdce316b1d
user:        Victor Stinner <victor.stinner@gmail.com>
date:        Wed Feb 19 18:32:03 2014 +0100
files:       Lib/test/test_asyncio/test_events.py
description:
Issue #20682: Oops, fix test_create_connection() of test_asyncio (fix my previous commit)


changeset:   89282:e6016fffc894
user:        Victor Stinner <victor.stinner@gmail.com>
date:        Wed Feb 19 18:10:32 2014 +0100
files:       Lib/test/test_asyncio/test_events.py
description:
Close #20682: Fix UNIX sockets tests of test_asyncio on Mac OS X Tiger

On Mac OS X Tiger (and older), getsockname() returns a zero-length address for
UNIX socket, and so 'sockname' extra info is None.
msg211678 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2014-02-20 00:45
changeset:   89290:549f451aa4c3
tag:         tip
user:        Victor Stinner <victor.stinner@gmail.com>
date:        Thu Feb 20 01:44:10 2014 +0100
files:       Doc/library/asyncio-dev.rst Doc/library/asyncio-eventloop.rst
description:
asyncio doc: remove reference to _DEBUG (now replaced with PYTHONASYNCIODEBUG
env var), document the default debug mode
msg211682 - (view) Author: Yury Selivanov (yselivanov) * (Python committer) Date: 2014-02-20 02:00
Some documentation.

changeset:   89291:58fd64e55b29
tag:         tip
user:        Yury Selivanov <yselivanov@sprymix.com>
date:        Wed Feb 19 20:58:44 2014 -0500
files:       Doc/library/asyncio-eventloop.rst
description:
asyncio.docs: Document Error Handling API and asyncio.Handle
msg211700 - (view) Author: Larry Hastings (larry) * (Python committer) Date: 2014-02-20 06:39
*sigh* okay.  Including 2e8a142dbccc from last night, that's eight new revisions to cherry-pick in one day.  I really hope this is slowing down.
msg211701 - (view) Author: Yury Selivanov (yselivanov) * (Python committer) Date: 2014-02-20 06:42
> *sigh* okay.  Including 2e8a142dbccc from last night, that's eight new revisions to cherry-pick in one day.  I really hope this is slowing down.

It is slowing down. I think we now only have some documentation updates left.
msg211703 - (view) Author: Vajrasky Kok (vajrasky) * Date: 2014-02-20 07:02
> It is slowing down. I think we now only have some documentation updates left.

What about this one? http://bugs.python.org/issue20668 (Remove dependency on tests.txt when running test_asyncio suite)

It has been lgtm-ed by Guido and asked by him to be added to this issue.
msg211705 - (view) Author: Guido van Rossum (gvanrossum) * (Python committer) Date: 2014-02-20 07:07
That one is not critical. It can go in sfter 3.4 is released.

On Wednesday, February 19, 2014, Vajrasky Kok <report@bugs.python.org>
wrote:

>
> Vajrasky Kok added the comment:
>
> > It is slowing down. I think we now only have some documentation updates
> left.
>
> What about this one? http://bugs.python.org/issue20668 (Remove dependency
> on tests.txt when running test_asyncio suite)
>
> It has been lgtm-ed by Guido and asked by him to be added to this issue.
>
> ----------
> nosy: +vajrasky
>
> _______________________________________
> Python tracker <report@bugs.python.org <javascript:;>>
> <http://bugs.python.org/issue20648>
> _______________________________________
>
msg211710 - (view) Author: Larry Hastings (larry) * (Python committer) Date: 2014-02-20 07:53
There are a few diffs on the asyncio files right now.  I went back and looked and discovered a whole bunch of asyncio revisions post-rc1 that you haven't asked to be cherry-picked yet:

20dc8d6430eb
75881b85695f
9c1840e8d643
a631b01d1715
360976a6d8b9
64ad965a2fd4

Should these be cherry-picked too?

(I wonder why there were no diffs on the files yesterday.  Maybe I screwed up the diff itself?)
msg211711 - (view) Author: Larry Hastings (larry) * (Python committer) Date: 2014-02-20 07:55
Also 6b850722849e
msg211712 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2014-02-20 08:06
> Should these be cherry-picked too?

We discuss with Guido and Yury to only include "critical" changes, so in short: yes, all commits related to asyncio should be cherrry-picked into RC2. It should also be easier for you to include all changes, to avoid conflicts. And the code should be the same in default and RC2 for asyncio.
msg211713 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2014-02-20 09:13
changeset:   89300:c3abdf016b18
tag:         tip
user:        Victor Stinner <victor.stinner@gmail.com>
date:        Thu Feb 20 10:12:59 2014 +0100
files:       Lib/asyncio/subprocess.py
description:
asyncio.subprocess: Fix a race condition in communicate()

Use self._loop instead of self._transport._loop, because transport._loop is set
to None at process exit.
msg211715 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2014-02-20 10:06
changeset:   89302:3e19634b396f
tag:         tip
user:        Victor Stinner <victor.stinner@gmail.com>
date:        Thu Feb 20 10:37:27 2014 +0100
files:       Lib/asyncio/events.py Lib/asyncio/futures.py Lib/asyncio/tasks.py Lib/asyncio/test_utils.py Lib/asyncio/unix_events.py Lib/a
description:
asyncio: remove unused imports and unused variables noticed by pyflakes


changeset:   89301:c412243b9d61
user:        Victor Stinner <victor.stinner@gmail.com>
date:        Thu Feb 20 10:33:01 2014 +0100
files:       Lib/asyncio/proactor_events.py
description:
asyncio: Fix _ProactorWritePipeTransport._pipe_closed()

The "exc" variable was not defined, pass a BrokenPipeError exception instead.
msg211716 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2014-02-20 10:09
Sorry, I found new bugs /o\

You may skip 3e19634b396f if the last commit to cherry-pick, it's just cleanup.
msg211717 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2014-02-20 10:14
> You may skip 3e19634b396f if the last commit to cherry-pick, it's just cleanup.

(Ooops, "if *it is* the last commit")
msg211731 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2014-02-20 15:53
changeset:   89303:d1f0ec5a9317
tag:         tip
user:        Victor Stinner <victor.stinner@gmail.com>
date:        Thu Feb 20 16:43:09 2014 +0100
files:       Lib/asyncio/base_events.py
description:
asyncio: Fix _check_resolved_address() for IPv6 address
msg211732 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2014-02-20 16:02
changeset:   89304:03b14690a9be
tag:         tip
user:        Victor Stinner <victor.stinner@gmail.com>
date:        Thu Feb 20 17:01:11 2014 +0100
files:       Lib/test/test_asyncio/test_events.py
description:
asyncio: ops, and now fix also the unit test for IPv6 address:
test_sock_connect_address()
msg211741 - (view) Author: Yury Selivanov (yselivanov) * (Python committer) Date: 2014-02-20 18:59
NEWS updates:

changeset:   89305:db749f0c6567
tag:         tip
user:        Yury Selivanov <yselivanov@sprymix.com>
date:        Thu Feb 20 13:59:14 2014 -0500
files:       Misc/NEWS
description:
Misc/NEWS: Add some missing news items re asyncio.
msg211745 - (view) Author: Yury Selivanov (yselivanov) * (Python committer) Date: 2014-02-20 19:11
Again, documentation update.

changeset:   89306:1c35d3114ea1
tag:         tip
user:        Yury Selivanov <yselivanov@sprymix.com>
date:        Thu Feb 20 14:10:02 2014 -0500
files:       Doc/library/asyncio-stream.rst
description:
asyncio.docs: Improve documentation of Streams. Issue #20696.
msg211749 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2014-02-20 21:00
changeset:   89307:96e078663083
tag:         tip
user:        Victor Stinner <victor.stinner@gmail.com>
date:        Thu Feb 20 21:59:38 2014 +0100
files:       Lib/asyncio/base_events.py Lib/test/test_asyncio/test_events.py
description:
asyncio: _check_resolved_address() must also accept IPv6 without flow_info and
scope_id: (host, port).
msg211750 - (view) Author: Larry Hastings (larry) * (Python committer) Date: 2014-02-20 21:08
I finished the second preview of rc2 just before you posted 96e078663083.  That'll go in the third preview.

Also, I found another revision you forgot about (something about improving debug info).  With that, and the other revisions I mentioned, asyncio in the rc2 preview now has no diffs against the equivalent default revision.

rc2 cherry-picks 58 revisions.  Thank god I spent a couple days automating the process.
msg211753 - (view) Author: Yury Selivanov (yselivanov) * (Python committer) Date: 2014-02-20 21:22
Hopefully, the last one from me ;) Again, some documentation updates.

Thank you, Larry, for accepting these last minute fixes.

changeset:   89308:cd23d0c3f850
tag:         tip
user:        Yury Selivanov <yselivanov@sprymix.com>
date:        Thu Feb 20 16:20:44 2014 -0500
files:       Doc/library/asyncio-eventloop.rst Doc/library/asyncio-stream.rst Doc/library/asyncio-sync.rst Doc/library/asyncio-task.rst
description:
asyncio.docs: Improve wordings; add a note to the Coroutines section. Issue #20706
msg211781 - (view) Author: Yury Selivanov (yselivanov) * (Python committer) Date: 2014-02-21 01:12
Last bit of documentation from me.

I, personally, don't have any more changes in mind, so this one is probably the last from me on the asyncio front in this thread.

changeset:   89312:ec3a70ef759d
tag:         tip
user:        Yury Selivanov <yselivanov@sprymix.com>
date:        Thu Feb 20 20:10:28 2014 -0500
files:       Doc/library/asyncio-eventloop.rst
description:
asyncio.docs: Document subprocess_exec and subprocess_shell. Issue #20694.
msg211822 - (view) Author: Larry Hastings (larry) * (Python committer) Date: 2014-02-21 08:15
I just put the third preview up.  There are no diffs between that asyncio and the one in default.

Is this torrent coming to a close?  We really should keep the changes from rc2 to final to a bare minimum.
msg211823 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2014-02-21 08:21
> Is this torrent coming to a close?  We really should keep the changes from rc2 to final to a bare minimum.

I agree.

We may improve the documentation, but such commits doesn't need to be cherry-picked. Many people read the documentation online (docs.python.org).
msg211941 - (view) Author: Larry Hastings (larry) * (Python committer) Date: 2014-02-22 19:12
Can I close this issue now?
msg212699 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2014-03-04 10:22
> Can I close this issue now?

Yes. If something really critical appears, a new issue can be opened.
History
Date User Action Args
2014-03-04 10:22:12vstinnersetstatus: open -> closed
resolution: fixed
messages: + msg212699
2014-02-22 19:12:00larrysetmessages: + msg211941
2014-02-21 08:21:33vstinnersetmessages: + msg211823
2014-02-21 08:15:55larrysetmessages: + msg211822
2014-02-21 01:12:22yselivanovsetmessages: + msg211781
2014-02-20 21:22:49yselivanovsetmessages: + msg211753
2014-02-20 21:08:22larrysetmessages: + msg211750
2014-02-20 21:00:55vstinnersetmessages: + msg211749
2014-02-20 19:11:31yselivanovsetmessages: + msg211745
2014-02-20 18:59:55yselivanovsetmessages: + msg211741
2014-02-20 16:02:08vstinnersetmessages: + msg211732
2014-02-20 15:53:34vstinnersetmessages: + msg211731
2014-02-20 10:14:09vstinnersetmessages: + msg211717
2014-02-20 10:09:32vstinnersetmessages: + msg211716
2014-02-20 10:06:15vstinnersetmessages: + msg211715
2014-02-20 09:13:20vstinnersetmessages: + msg211713
2014-02-20 08:06:33vstinnersetmessages: + msg211712
2014-02-20 07:55:45larrysetmessages: + msg211711
2014-02-20 07:53:10larrysetmessages: + msg211710
2014-02-20 07:07:40gvanrossumsetmessages: + msg211705
2014-02-20 07:02:22vajraskysetnosy: + vajrasky
messages: + msg211703
2014-02-20 06:42:55yselivanovsetmessages: + msg211701
2014-02-20 06:39:33larrysetmessages: + msg211700
2014-02-20 02:00:35yselivanovsetmessages: + msg211682
2014-02-20 00:45:33vstinnersetmessages: + msg211678
2014-02-19 22:25:20vstinnersetmessages: + msg211669
2014-02-19 22:18:02vstinnersetmessages: + msg211666
2014-02-19 16:12:36yselivanovsetmessages: + msg211626
2014-02-19 12:32:55vstinnersetmessages: + msg211608
2014-02-19 04:46:36gvanrossumsetmessages: + msg211605
2014-02-19 04:45:44larrysetmessages: + msg211604
2014-02-19 04:34:08yselivanovsetmessages: + msg211603
2014-02-19 04:33:53gvanrossumsetmessages: + msg211602
2014-02-19 04:29:50larrysetmessages: + msg211601
2014-02-19 04:22:07gvanrossumsetmessages: + msg211600
2014-02-19 03:58:57larrysetmessages: + msg211599
2014-02-19 03:57:16yselivanovsetmessages: + msg211598
2014-02-19 03:29:31yselivanovsetmessages: + msg211597
2014-02-19 00:46:41vstinnersetmessages: + msg211573
2014-02-19 00:42:41vstinnersetmessages: + msg211572
2014-02-18 23:43:23yselivanovsetmessages: + msg211570
2014-02-18 23:03:37yselivanovsetmessages: + msg211568
2014-02-18 18:25:49gvanrossumsetmessages: + msg211537
2014-02-18 17:22:39yselivanovsetmessages: + msg211524
2014-02-18 08:38:38vstinnersetmessages: + msg211492
2014-02-18 08:24:32vstinnersetmessages: + msg211487
2014-02-17 23:12:34vstinnersetmessages: + msg211455
2014-02-17 16:07:50larrysetmessages: + msg211422
2014-02-17 09:56:43vstinnersetmessages: + msg211404
2014-02-17 00:11:15gvanrossumsetmessages: + msg211383
2014-02-17 00:09:56gvanrossumsetmessages: + msg211382
2014-02-16 23:59:46yselivanovsetmessages: + msg211381
2014-02-16 23:54:54vstinnersetpriority: normal -> release blocker
2014-02-16 23:54:20vstinnercreate