classification
Title: [RFC] Remove leftover use of Carbon module from Lib/binhex.py
Type: Stage:
Components: Library (Lib) Versions: Python 3.1, Python 3.2
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Remove carbon-specific code from binhex
View: 2715
Assigned To: Nosy List: mark.dickinson, vincele
Priority: normal Keywords: patch

Created on 2009-08-01 22:22 by vincele, last changed 2009-08-02 18:47 by mark.dickinson. This issue is now closed.

Files
File name Uploaded Description Edit
py3k-binhex.py-remove-carbon-module-use.patch vincele, 2009-08-01 22:22 remove carbon use in binhex module
Messages (5)
msg91174 - (view) Author: Vincent Legoll (vincele) Date: 2009-08-01 22:22
The binhex module still has uses of the deprecated and now now removed
Carbon module.

The attached patch 'fix' this by removing the code, something else may
be required, but I don't know what.

So this is only a RFC to start discussion
msg91190 - (view) Author: Mark Dickinson (mark.dickinson) * (Python committer) Date: 2009-08-02 17:54
As far as I can tell, it looks safe to just remove these two blocks.  
There's a third block that should be removed as well (the second "if 
os.name == 'mac': ..." in the hexbin function.
msg91191 - (view) Author: Mark Dickinson (mark.dickinson) * (Python committer) Date: 2009-08-02 17:55
This should be fixed in the 3.1 maintenance branch as well.
msg91192 - (view) Author: Mark Dickinson (mark.dickinson) * (Python committer) Date: 2009-08-02 18:17
See also issue 2715.
msg91194 - (view) Author: Mark Dickinson (mark.dickinson) * (Python committer) Date: 2009-08-02 18:47
Closing as a duplicate of issue 2715.
History
Date User Action Args
2009-08-02 18:47:20mark.dickinsonsetstatus: open -> closed
resolution: duplicate
superseder: Remove carbon-specific code from binhex
messages: + msg91194
2009-08-02 18:17:24mark.dickinsonsetmessages: + msg91192
2009-08-02 17:55:31mark.dickinsonsetmessages: + msg91191
versions: + Python 3.1
2009-08-02 17:54:53mark.dickinsonsetnosy: + mark.dickinson
messages: + msg91190
2009-08-01 22:22:05vincelecreate