classification
Title: test_xmlrpc_net fails when the ISP returns "302 Found"
Type: behavior Stage: resolved
Components: Tests Versions: Python 3.1, Python 3.2, Python 2.7
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: Nosy List: ezio.melotti, kristjan.jonsson, loewis, pitrou, r.david.murray
Priority: low Keywords:

Created on 2009-05-15 01:34 by ezio.melotti, last changed 2012-09-26 16:42 by ezio.melotti. This issue is now closed.

Messages (5)
msg87785 - (view) Author: Ezio Melotti (ezio.melotti) * (Python committer) Date: 2009-05-15 01:34
./python -m test.regrtest -uall -v test_xmlrpc_net
Could not find '/home/wolf/py3k/Lib/test' in sys.path to remove it
test_xmlrpc_net
test_current_time (test.test_xmlrpc_net.CurrentTimeTest) ... ERROR
 
======================================================================
ERROR: test_current_time (test.test_xmlrpc_net.CurrentTimeTest)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/wolf/py3k/Lib/test/test_xmlrpc_net.py", line 18, in
test_current_time
    t0 = server.currentTime.getCurrentTime()
  File "/home/wolf/py3k/Lib/xmlrpc/client.py", line 1091, in __call__
    return self.__send(self.__name, args)
  File "/home/wolf/py3k/Lib/xmlrpc/client.py", line 1333, in __request
    verbose=self.__verbose
  File "/home/wolf/py3k/Lib/xmlrpc/client.py", line 1127, in request
    dict(resp.getheaders())
xmlrpc.client.ProtocolError: <ProtocolError for time.xmlrpc.com/RPC2:
302 Found>
 
----------------------------------------------------------------------
Ran 1 test in 0.148s
 
FAILED (errors=1)
test test_xmlrpc_net failed -- Traceback (most recent call last):
  File "/home/wolf/py3k/Lib/test/test_xmlrpc_net.py", line 18, in
test_current_time
    t0 = server.currentTime.getCurrentTime()
  File "/home/wolf/py3k/Lib/xmlrpc/client.py", line 1091, in __call__
    return self.__send(self.__name, args)
  File "/home/wolf/py3k/Lib/xmlrpc/client.py", line 1333, in __request
    verbose=self.__verbose
  File "/home/wolf/py3k/Lib/xmlrpc/client.py", line 1127, in request
    dict(resp.getheaders())
xmlrpc.client.ProtocolError: <ProtocolError for time.xmlrpc.com/RPC2:
302 Found>
 
1 test failed:
    test_xmlrpc_net


Apparently the error was raised because:
1) time.xmlrpc.com wasn't reachable
2) the ISP (not the browser) returned a "302 Found" and an error page
3) the test expected something else and failed

This is somewhat related to #3583.
msg124677 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2010-12-26 19:42
IMO there's no way to fix this.  I suggest closing it as invalid, since the problem is a buggy ISP DNS server, and the problem only occurs when time.xmlrpc.com is down.

The canonical fix to problems like this is to remove dependency on the external service, but that would presumably defeat the entire purpose of test_xmlrpc_net.  So one "fix" would be to delete this test entirely.  Which if we have mock-server xmlrpc tests, might not be out of the question as a solution.  Note that the second test in that file tests against the xmlrpc interface of our buildbot master, and that support has been formally removed by upstream and only restored by us...presumably at some point we'll drop support for it too, when it breaks too badly to be easily forward ported.

Since there was, if I remember correctly, an extended period when xmlrpc.com's time service was down, simply deleting this test file may in fact be the best move.
msg124805 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2010-12-28 17:16
+1 on simply removing this test. *.xmlrpc.com look(s) totally unmaintained.
msg124813 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2010-12-28 19:08
See also issue 6533.
msg171345 - (view) Author: Ezio Melotti (ezio.melotti) * (Python committer) Date: 2012-09-26 16:42
da148f0d86bd added a skip to the test (see #13434).  Also xmlrpc.com now redirects to xmlrpc.scripting.com.
History
Date User Action Args
2012-09-26 16:42:52ezio.melottisetstatus: open -> closed
resolution: out of date
messages: + msg171345

stage: resolved
2010-12-28 19:08:38r.david.murraysetnosy: loewis, pitrou, kristjan.jonsson, ezio.melotti, r.david.murray
messages: + msg124813
2010-12-28 17:16:11pitrousetnosy: + pitrou
messages: + msg124805
2010-12-26 19:42:16r.david.murraysetnosy: + r.david.murray

messages: + msg124677
versions: + Python 2.7, Python 3.2
2009-10-11 15:45:06ezio.melottisetpriority: low
nosy: + loewis, kristjan.jonsson
2009-05-15 01:34:25ezio.melotticreate