classification
Title: No shell prompt when a graphics window that was started from IDLE is closed
Type: behavior Stage:
Components: IDLE Versions: Python 2.6
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: chessweb, roger.serwy
Priority: normal Keywords:

Created on 2009-05-13 22:01 by chessweb, last changed 2010-10-16 04:16 by ned.deily. This issue is now closed.

Messages (3)
msg87715 - (view) Author: Ralf Seliger (chessweb) Date: 2009-05-13 22:01
Platform: Ubuntu 8.10

Affected versions: Python 2.6.2, IDLE 2.6.2 and Python 2.5.4, IDLE 1.2.4

From IDLE I run a program that opens a graphics window (e.g. using the
Natural Language Toolkit: >>> import nltk followed by >>> nltk.download()). 

When I close the graphics window, I expect to be able to continue
working with the Python shell.

What happens instead is this: The graphics window closes, but the shell
prompt (>>>) does not appear. It seems the subprocess responsible for
the graphics window is still running even though the window is no more. 

All I can do is close IDLE upon which it complains about a program that
is still running.

I am not sure whether this is an IDLE-bug, a graphics package bug or a
nltk-bug,
msg109893 - (view) Author: Mark Lawrence (BreamoreBoy) * Date: 2010-07-10 17:05
Surely a graphics program should be run from a command prompt, not from IDLE or anything similar?  Hence can this be closed?
msg118848 - (view) Author: Roger Serwy (roger.serwy) * (Python committer) Date: 2010-10-15 23:56
This issue can be closed.

The natural language toolkit uses Tk for its GUI, the same as IDLE. Under Ubuntu 8.10, IDLE is launched from the menu without a subprocess. Running nltk as described without a subprocess causes this problem.

Try launching IDLE without "-n".
History
Date User Action Args
2010-10-16 04:16:02ned.deilysetstatus: open -> closed
nosy: - BreamoreBoy
resolution: not a bug
2010-10-15 23:56:45roger.serwysetnosy: + roger.serwy
messages: + msg118848
2010-07-10 17:05:07BreamoreBoysetnosy: + BreamoreBoy
messages: + msg109893
2009-05-13 22:02:56chesswebsettitle: No shell prompt when a graphics that was started from IDLE is closed -> No shell prompt when a graphics window that was started from IDLE is closed
2009-05-13 22:01:23chesswebcreate