classification
Title: Mac/scripts/BuildApplet.py reset of sys.executable during install can cause it to use wrong modules
Type: compile error Stage: resolved
Components: Installation, macOS Versions: Python 2.7
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: ronaldoussoren Nosy List: blb, ned.deily, ronaldoussoren
Priority: normal Keywords:

Created on 2009-04-16 00:12 by blb, last changed 2012-09-12 07:55 by ned.deily. This issue is now closed.

Files
File name Uploaded Description Edit
python262_error.txt blb, 2009-04-16 00:12 Error output from BuildApplet.py
Messages (4)
msg86009 - (view) Author: Bryan Blackburn (blb) Date: 2009-04-16 00:12
With Python 2.6.1 currently installed and attempting to install 2.6.2 into 
a DESTDIR location, and having a different configuration for the new one 
(2.6.1 built with default Unicode settings, 2.6.2 with UCS4), 
BuildApplet.py fails because of symbol not found.

Full output (building with MacPorts, hence the sometimes-funky paths) 
attached as a text file.
msg86054 - (view) Author: Bryan Blackburn (blb) Date: 2009-04-17 05:58
FYI, I'm able to avoid this by using "PYTHONHOME=$(DESTDIR)$(prefix)" 
before $(RUNSHARED) when running BuildApplet.py and $(BUNDLEBULDER) in 
Mac/Makefile.in, Mac/IDLE/Makefile.in, and Mac/PythonLauncher/Makefile.in.
msg87983 - (view) Author: Ronald Oussoren (ronaldoussoren) * (Python committer) Date: 2009-05-17 10:39
I haven't looked in this particular problem yet, but please note that the 
Mac-specific libraries do not work with an UCS4 build of python.
msg170359 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2012-09-12 07:55
This problem was caused by a conflict between the expat parser included with Python and the expat parser included with the MacPorts ports of the obsolete pyxml package.  The MacPorts project has subsequently deleted the py*-xml ports. A solution for this issue is to remove the obsolete port, something like:

    sudo port uninstall py26-xml

See https://trac.macports.org/ticket/32090 for a similar case and its resolution.
History
Date User Action Args
2012-09-12 07:55:28ned.deilysetstatus: open -> closed

nosy: + ned.deily
messages: + msg170359

resolution: out of date
stage: resolved
2012-09-11 22:41:32ezio.melottisetversions: + Python 2.7, - Python 2.6
2010-05-16 10:29:12ronaldoussorensetassignee: ronaldoussoren
2009-05-17 10:39:05ronaldoussorensetnosy: + ronaldoussoren
messages: + msg87983
2009-04-17 05:59:19blbsetmessages: + msg86054
2009-04-16 00:12:16blbcreate