classification
Title: Item 'Python x.x.x' in Add/Remove Programs list still lacks an icon
Type: Stage:
Components: Versions: Python 3.0, Python 3.1, Python 2.7, Python 2.6
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: Retro, amaury.forgeotdarc, georg.brandl, loewis
Priority: low Keywords:

Created on 2009-02-28 07:26 by Retro, last changed 2009-06-28 09:43 by loewis. This issue is now closed.

Files
File name Uploaded Description Edit
arp.jpg loewis, 2009-02-28 10:04
arpvista.jpg loewis, 2009-03-01 19:14
my_arpvista.jpg Retro, 2009-03-01 20:53
arpvista_surprise.jpg Retro, 2009-03-04 12:04
python26.rar Retro, 2009-03-04 12:08 Python 2.6.1 installing log
Messages (20)
msg82890 - (view) Author: Boštjan Mejak (Retro) Date: 2009-02-28 07:26
I am reporting a bug which was not fixed in the closed issue #4389.
Martin v. Löwis, the fix you've made didn't fix the issue. Please open
your Add/Remove Programs list (hopefully your running Windows and have
Python installed there) and check whether your Python interpreters in
this list use Python's icon. Your fix was made before Python 2.5.4,
Python 2.6.1, and Python 3.0.1 were out. I don't know why these new
interpreters (installed on my Windows Vista Business 64-bit machine)
don't show Python's icon in the Add/Remove Programs list. Is this an
issue on my side or on Python's side?
msg82891 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2009-02-28 07:32
What version specifically did you notice this in?
msg82893 - (view) Author: Boštjan Mejak (Retro) Date: 2009-02-28 09:29
I noticed this by installing the Python 2.5.4 and Python 2.6.1 and
Python 3.0.1 binaries. Please fix these issues if you can.
msg82894 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2009-02-28 10:04
I did not backport the fix to 2.5.4, so that release doesn't have it
fixed. Since the 2.5 branch is now closed, no changes will be made to it.

For 2.6.1 and 3.0.1, it works fine for me. See the attached screenshot.
msg82956 - (view) Author: Boštjan Mejak (Retro) Date: 2009-03-01 11:29
Strange thing. I presume you are running Windows XP. There the Python
icons are shown in the Add/Remove Programs list for the Python interpreters.

I must inform you, though, that the Python icons are not shown in the
Add/Remove Programs list under Widnows Vista. I don't know why but it is
an issue we ought to look at and solve. If anyone has knowledge how to
fix this, please provide information on how to fix this bug. Thank you
in advance.
msg82977 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2009-03-01 19:14
> I must inform you, though, that the Python icons are not shown in the
> Add/Remove Programs list under Widnows Vista. 

I can't reproduce this. It works fine for me. See the attached
screenshot.
msg82988 - (view) Author: Boštjan Mejak (Retro) Date: 2009-03-01 20:53
Please see the attached screenshot where there are no icons in the
Add/Remove Programs list of the Python intepreters on my Windows Vista
machine.
msg82989 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2009-03-01 21:21
Using regedit, find out which of the keys

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{9cc89170-000b-457d-91f1-53691f85b224}
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{de2f2d9c-53e2-40ee-8209-74da63cb060f}
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall\{9cc89170-000b-457d-91f1-53691f85b223}
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall\{de2f2d9c-53e2-40ee-8209-74da63cb060e}

are present on your system. For each key, report the values of the
properties

DisplayName
DisplayIcon
msg83070 - (view) Author: Boštjan Mejak (Retro) Date: 2009-03-03 11:32
In my Windows Vista registry I only have the second two keys present

1)
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall\{9cc89170-000b-457d-91f1-53691f85b223}
2)
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall\{de2f2d9c-53e2-40ee-8209-74da63cb060e}

for which the value of the property DisplayName is

1) DisplayName    Python 2.6.1
2) DisplayName    Python 3.0.1

I don't have the property DisplayIcon for any of those two keys.

I did a complete removal and a reinstall of both the interpreters now,
but I have the same issue and the registry contains the very same two
keys and each of the keys contain only the property DisplayName as before.
msg83104 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2009-03-03 21:35
Ok. Now run the installation (of, say, 2.6) with

msiexec /i python-xy.msi /l*v python26.log

and compress and attach the resulting log file.
msg83105 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2009-03-03 21:36
Also, what version of Vista *precisely* are you using?
msg83120 - (view) Author: Boštjan Mejak (Retro) Date: 2009-03-04 12:04
A strange thing now happened. Now the Python 2.6.1 interpreter has an
icon in the Add/Remove Programs list. I completely removed Python 2.6.1
and reinstalled it with the command

msiexec /i python-2.6.1.msi /l*v python26.log

and it now has an icon in the Add/Remove Programs list. Please see the
attached screenshot.

My Windows Vista is Business Edition, Service Pack 1. I got it by buying
my laptop and then upgraded it to the Service Pack 1 version and I have
the very latest updates installed on it, too. I don't know what do you
mean by specific version. I hope I answered your question.
msg83121 - (view) Author: Boštjan Mejak (Retro) Date: 2009-03-04 12:08
And now I'm attaching the installing log of Python 2.6.1 for you. I hope
you have enough information to work on the solution. If you need more
information, just ask.
msg83129 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2009-03-04 19:05
I'm closing this as "works for me". The error is not reproducible.
msg83188 - (view) Author: Boštjan Mejak (Retro) Date: 2009-03-05 10:55
I figured out why the installer didn't create an icon for the Python
interpreters in the Add/Remove Programs list. If I deselect the option
'Register Extensions' at installation time, I don't get an icon in the
Add/Remove Programs list. But if I leave the option 'Register
Extensions' be selected, I get an icon in the Add/Remove Programs list.

Please make the icon be registered in the registry even if the option
'Register Extensions' isn't selected at installation time.
msg83220 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2009-03-05 21:35
I give this low priority, i.e. might not work on it for several months
(or ever). Contributions are welcome.
msg84420 - (view) Author: Boštjan Mejak (Retro) Date: 2009-03-29 18:09
I think this is an easy fix. Please try to fix this issue. Thank you.
msg85517 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2009-04-05 15:20
It is also completely low-priority, and so it is perfectly
understandable that Martin wants to fix more important problems.
msg89741 - (view) Author: Amaury Forgeot d'Arc (amaury.forgeotdarc) * (Python committer) Date: 2009-06-26 20:32
I found the cause: in msi.py, the DisplayIcon registry variable is attached to 
"REGISTRY.def" i.e the "Register extensions" feature.
The following patch attaches it to the parent group.

Index: msi.py
===================================================================
--- msi.py	(revision 73575)
+++ msi.py	(working copy)
@@ -1258,7 +1258,7 @@
                "", r"[TARGETDIR]Python.exe", "REGISTRY.def"),
               ("DisplayIcon", -1,
                r"Software\Microsoft\Windows\CurrentVersion\Uninstall\%s" % 
product_code,
-               "DisplayIcon", "[TARGETDIR]python.exe", "REGISTRY.def")
+               "DisplayIcon", "[TARGETDIR]python.exe", "REGISTRY")
               ])
     # Shortcuts, see "Shortcut Table"
     add_data(db, "Directory",
msg89770 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2009-06-28 09:43
Thanks for the analysis and the patch. Fixed in r73599, r73600, r73601,
r73602.
History
Date User Action Args
2009-06-28 09:43:29loewissetstatus: open -> closed
resolution: fixed
messages: + msg89770
2009-06-26 20:32:18amaury.forgeotdarcsetnosy: + amaury.forgeotdarc
messages: + msg89741
2009-04-05 15:20:56georg.brandlsetpriority: low
nosy: + georg.brandl
messages: + msg85517

2009-03-30 14:24:29loewissetversions: - Python 2.5, Python 2.4
2009-03-30 10:49:40Retrosetversions: + Python 2.6, Python 2.5, Python 2.4, Python 3.0
2009-03-29 18:09:26Retrosetmessages: + msg84420
versions: - Python 2.6, Python 3.0
2009-03-05 21:35:11loewissetmessages: + msg83220
2009-03-05 21:34:33loewissetstatus: closed -> open
resolution: works for me -> (no value)
2009-03-05 10:55:11Retrosetmessages: + msg83188
2009-03-04 19:05:23loewissetstatus: open -> closed
resolution: works for me
messages: + msg83129
2009-03-04 12:08:40Retrosetfiles: + python26.rar
messages: + msg83121
2009-03-04 12:04:58Retrosetfiles: + arpvista_surprise.jpg
messages: + msg83120
2009-03-03 21:36:07loewissetmessages: + msg83105
2009-03-03 21:35:39loewissetmessages: + msg83104
2009-03-03 11:32:19Retrosetmessages: + msg83070
2009-03-01 21:21:07loewissetmessages: + msg82989
2009-03-01 20:53:22Retrosetfiles: + my_arpvista.jpg
messages: + msg82988
2009-03-01 19:14:48loewissetfiles: + arpvista.jpg
messages: + msg82977
2009-03-01 11:29:31Retrosetmessages: + msg82956
2009-02-28 10:04:34loewissetfiles: + arp.jpg
messages: + msg82894
2009-02-28 09:29:17Retrosetmessages: + msg82893
2009-02-28 07:32:09loewissetmessages: + msg82891
versions: - Python 2.5, Python 2.4, 3rd party
2009-02-28 07:26:53Retrocreate