classification
Title: Uninstaller Lacks an Icon
Type: Stage:
Components: None Versions: Python 3.0, Python 3.1, Python 2.7
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: loewis Nosy List: Retro, lemburg, loewis
Priority: normal Keywords:

Created on 2008-11-22 14:17 by Retro, last changed 2008-12-01 09:06 by lemburg. This issue is now closed.

Messages (9)
msg76246 - (view) Author: Boštjan Mejak (Retro) Date: 2008-11-22 14:17
The uninstaller program of the Python interpreter lacks an icon. This
looks ackward in the Add/Remove Programs list on the Windows platform.
Please add an icon for the uninstaller.
msg76247 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2008-11-22 14:22
What specific release are you referring to?
msg76250 - (view) Author: Boštjan Mejak (Retro) Date: 2008-11-22 15:20
As far as I know, the uninstaller has never had an icon, but it
certainly needs one. The upcoming versions of Python could be equipped
with a neat little icon. Are you willing to implement it? That would be
very nice.
msg76251 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2008-11-22 15:57
I can't quite reproduce the problem. Both on "Uninstall Python" in the
start menu, and in "Add and remove programs", Windows displays an icon,
showing a computer and a cdrom, atleast on Windows XP. So where are you
missing the icon?
msg76256 - (view) Author: Boštjan Mejak (Retro) Date: 2008-11-22 19:14
Oh, I guess I should have been more informative, sorry. My OS is Windows
Vista Business (64 bit) onto which I have installed the 32 bit
interpreter. And now when this 32 bit interpreter is installed on my 64
bit OS platform, I don't see the two-snakes-kind-of-like icon in the
Add/Remove Programs list; instead I see the default icon -- you know,
that squared box. The files python.exe and pythonw.exe both have that
two-snakes-kind-of-like icon, and even pressing Alt+Tab (when the
interpreter is running) displays the two-snakes-kind-of-like icon, but
this two-snakes-kind-of-like icon is not displayed in the Add/Remove
Programs list. So I find that a strange thing to be.

Anyway, this is a bug so I reported it. I really don't know why this bug
exists. This could be because of a 64 bit OS and a 32 bit interpreter
mix issue, but I doubt it.

This is probably an easy fix for you guys. I keep my fingers crossed for
this bug to be fixed. Oh, and I can make screenshots if you like.
msg76266 - (view) Author: Boštjan Mejak (Retro) Date: 2008-11-23 10:42
So are you willing to fix this issue?
msg76541 - (view) Author: Marc-Andre Lemburg (lemburg) * (Python committer) Date: 2008-11-28 17:13
Would be nice if the same icon could also be the default for bdist_msi.

"Retro" could you point us to some documentation on how to fix this ?
msg76636 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2008-11-30 11:14
Thanks again for the report. This is now fixed in r67449, r67450, r67451.

Marc-Andre, if you want request a change to bdist_msi, please submit a
separate report. I'm skeptical though that bdist_msi packages should use
the Python icon in ARP.
msg76681 - (view) Author: Marc-Andre Lemburg (lemburg) * (Python committer) Date: 2008-12-01 09:06
I opened #4480 for the distutils commands.
History
Date User Action Args
2008-12-01 09:06:49lemburgsetmessages: + msg76681
2008-11-30 11:14:17loewissetstatus: open -> closed
resolution: fixed
messages: + msg76636
2008-11-28 17:13:39lemburgsetnosy: + lemburg
messages: + msg76541
2008-11-23 10:42:23Retrosetmessages: + msg76266
2008-11-22 19:14:16Retrosetmessages: + msg76256
2008-11-22 15:57:07loewissetmessages: + msg76251
2008-11-22 15:20:30Retrosetmessages: + msg76250
2008-11-22 14:22:41loewissetmessages: + msg76247
2008-11-22 14:21:39amaury.forgeotdarcsetassignee: loewis
nosy: + loewis
2008-11-22 14:17:51Retrocreate