classification
Title: Make python.org Windows and macOS installers use Tk 8.6.12
Type: Stage: resolved
Components: Build, macOS, Windows Versions: Python 3.11, Python 3.10, Python 3.9
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: aivarannamaa, ned.deily, paul.moore, ronaldoussoren, steve.dower, terry.reedy, tim.golden, zach.ware
Priority: normal Keywords: patch

Created on 2021-11-05 23:15 by ned.deily, last changed 2021-12-06 07:48 by ned.deily. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 29477 merged steve.dower, 2021-11-08 21:56
PR 29493 merged steve.dower, 2021-11-09 16:49
PR 29496 merged steve.dower, 2021-11-09 17:54
PR 29931 merged ned.deily, 2021-12-06 07:22
PR 29932 merged ned.deily, 2021-12-06 07:24
PR 29933 merged ned.deily, 2021-12-06 07:26
Messages (11)
msg405834 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2021-11-05 23:15
https://sourceforge.net/p/tcl/mailman/message/37380142/
msg405974 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2021-11-08 17:26
I guess I've actually got to fix my build process now :)
msg406029 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2021-11-09 16:47
New changeset bcc4e46832010469bb35a97c1d1e962a82ee7fd9 by Steve Dower in branch 'main':
bpo-45732: Update bundled Tcl/Tk on Windows to 8.6.12 (GH-29477)
https://github.com/python/cpython/commit/bcc4e46832010469bb35a97c1d1e962a82ee7fd9
msg406035 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2021-11-09 17:48
New changeset 340ecafdf3bfb1377a1b8584addbb8e7bb423459 by Steve Dower in branch '3.10':
bpo-45732: Update bundled Tcl/Tk on Windows to 8.6.12 (GH-29477)
https://github.com/python/cpython/commit/340ecafdf3bfb1377a1b8584addbb8e7bb423459
msg406040 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2021-11-09 19:13
New changeset 4d1cdd7006def053c815c354bd6f266b4850bd97 by Steve Dower in branch '3.9':
bpo-45732: Update bundled Tcl/Tk on Windows to 8.6.12 (GH-29477)
https://github.com/python/cpython/commit/4d1cdd7006def053c815c354bd6f266b4850bd97
msg406414 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2021-11-16 16:27
Steve, thank you for patching all current versions.  Previous policy has been to freeze tcl/tk x.y.z in python x.y because tk x.y.z may include a few enhancements among the bug fixes and hence indirectly add new features to tkinter in python x.y.z.  However ...

E.Paine's report for this bugfix
"2021-09-21 (bug)[033886] Win: hang in font loading (e-paine,vogel)"
was the result of #45103, based on an IDLE user's SO question about IDLE's config dialog hanging.  It turned out that adding a particular font (Phaistos) to Windows was the cause, and the fix was to remove it. Ned's link specifically  says they fixed " - Windows loading of the Phaistos font.", so I can now close our #45103.

Fine with me if we continue to update tcl/tk 8.6.z as possible on Windows as well as Mac.  Switching to 8.7, when released, would likely have to wait for discussion and a new Python version, which now is never too far away.
msg407360 - (view) Author: Aivar Annamaa (aivarannamaa) Date: 2021-11-30 11:25
Do I understand properly, that the macOS build hasn't been updated yet?

It would be really great if Python 3.10.1 for macOS would come with Tcl/Tk 8.6.12, as it is supposed to fix a nasty crash with Spanish keyboard.
msg407378 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2021-11-30 15:14
> It would be really great if Python 3.10.1 for macOS would come with Tcl/Tk 8.6.12, as it is supposed to fix a nasty crash with Spanish keyboard.

Not to worry, the Tk for the macOS 3.10.1 will be updated. I need to do some more testing first. (BTW, I assume you are referring to this Tk issue: https://core.tcl-lang.org/tk/tktview/1626ed65b879bd76db99. The most recent 3.11.0 alpha preview has a pre-release of 8.6.12 and I can confirm that the Cmd-` with the Spanish keyboard no longer crashes with it.)
msg407770 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2021-12-06 07:39
New changeset 20801982fa696a01ad2c116925bddf2fda106338 by Ned Deily in branch '3.10':
bpo-45732: Update python.org macOS installer to use Tcl/Tk 8.6.12. (GH-29932)
https://github.com/python/cpython/commit/20801982fa696a01ad2c116925bddf2fda106338
msg407771 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2021-12-06 07:40
New changeset 7accb4fdb3dc1b4140089edee290998aff496fe2 by Ned Deily in branch '3.9':
bpo-45732: Update python.org macOS installer to use Tcl/Tk 8.6.12. (GH-29933)
https://github.com/python/cpython/commit/7accb4fdb3dc1b4140089edee290998aff496fe2
msg407772 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2021-12-06 07:44
New changeset f34d181fa15e1f082140a4e4a8fa3b77118f8e98 by Ned Deily in branch 'main':
bpo-45732: Update python.org macOS installer to use Tcl/Tk 8.6.12. (GH-29931)
https://github.com/python/cpython/commit/f34d181fa15e1f082140a4e4a8fa3b77118f8e98
History
Date User Action Args
2021-12-06 07:48:20ned.deilysetstatus: open -> closed
resolution: fixed
stage: patch review -> resolved
2021-12-06 07:44:20ned.deilysetmessages: + msg407772
2021-12-06 07:40:00ned.deilysetmessages: + msg407771
2021-12-06 07:39:15ned.deilysetmessages: + msg407770
2021-12-06 07:26:42ned.deilysetpull_requests: + pull_request28157
2021-12-06 07:24:10ned.deilysetpull_requests: + pull_request28156
2021-12-06 07:22:18ned.deilysetpull_requests: + pull_request28155
2021-11-30 15:14:43ned.deilysetmessages: + msg407378
2021-11-30 11:25:04aivarannamaasetmessages: + msg407360
2021-11-16 16:27:41terry.reedysetnosy: + terry.reedy
messages: + msg406414
2021-11-16 15:54:52terry.reedylinkissue45817 superseder
2021-11-16 15:24:37aivarannamaasetnosy: + aivarannamaa
2021-11-12 21:26:31terry.reedysettitle: Update python.org Windows and macOS installers to use Tk 8.6.12 -> Make python.org Windows and macOS installers use Tk 8.6.12
2021-11-09 19:13:01steve.dowersetmessages: + msg406040
2021-11-09 17:54:29steve.dowersetpull_requests: + pull_request27746
2021-11-09 17:48:57steve.dowersetmessages: + msg406035
2021-11-09 16:49:16steve.dowersetpull_requests: + pull_request27742
2021-11-09 16:47:35steve.dowersetmessages: + msg406029
2021-11-08 21:56:39steve.dowersetkeywords: + patch
stage: patch review
pull_requests: + pull_request27727
2021-11-08 17:26:45steve.dowersetmessages: + msg405974
2021-11-05 23:15:21ned.deilycreate