classification
Title: IDLE string problem in Run/Run Module
Type: Stage:
Components: IDLE Versions: Python 3.0
process
Status: closed Resolution: duplicate
Dependencies: Superseder: IDLE: checksyntax() doesn't support Unicode?
View: 4008
Assigned To: Nosy List: andre, loewis
Priority: normal Keywords:

Created on 2008-11-24 18:16 by andre, last changed 2008-12-29 19:42 by loewis. This issue is now closed.

Messages (2)
msg76353 - (view) Author: André (andre) Date: 2008-11-24 18:16
Python 3.0 rc3 on Windows (Server 2003 US English)

The code with a string including a non ascii character:

s = 'abçd'
print (s)

is returning correct result in console mode and when it's typed in the 
IDLE Python Shell

But when executed from an IDLE editor window with Run/Run Module
it prints 5 characters instead of 4.

With more details, the code:

s = 'abçd'
print (s)

for i in range(len(s)):
    print(hex(ord(s[i])),end=' ')
    
  
gives  in console mode:

abçd
0x61 0x62 0xe7 0x64

but with Run/Run Module:

abçd
0x61 0x62 0xc3 0xa7 0x64
msg78478 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2008-12-29 19:42
This is a duplicate of issue 4008
History
Date User Action Args
2008-12-29 19:42:25loewissetstatus: open -> closed
resolution: duplicate
superseder: IDLE: checksyntax() doesn't support Unicode?
messages: + msg78478
nosy: + loewis
2008-11-24 18:16:49andrecreate