classification
Title: The comments have invalid license information (broken Python 2.4 URL for Python 3)
Type: Stage: resolved
Components: Documentation Versions: Python 3.7
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: docs@python Nosy List: docs@python, gregory.p.smith, kamilturek, lemburg, poikilos
Priority: normal Keywords: patch

Created on 2021-03-03 19:59 by poikilos, last changed 2021-03-06 12:24 by lemburg. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 24736 merged kamilturek, 2021-03-03 22:35
Messages (4)
msg388049 - (view) Author: Jake Gustafson (poikilos) Date: 2021-03-03 19:59
Steps to reproduce the issue:
- Run Python 3.7.3 (or later, possibly) with the following code:

    import subprocess
    import inspect
    with open("subprocess-py3.py", 'w') as outs:
        outs.write(inspect.getsource(subprocess).replace("\\n","\n"))

The resulting ./subprocess-py3.py contains the source code for subprocess including:

# Copyright (c) 2003-2005 by Peter Astrand <astrand@lysator.liu.se>
#
# Licensed to PSF under a Contributor Agreement.
# See http://www.python.org/2.4/license for licensing details.

However, the URL is broken, and whatever code Peter Astrand developed may be long gone--I'll leave it up to the devs to determine the correct license, but the link is broken and the code is significantly different even than Python 2.4's.
msg388050 - (view) Author: Jake Gustafson (poikilos) Date: 2021-03-03 20:00
*significantly different even than Python 2.7.16's.
msg388054 - (view) Author: Marc-Andre Lemburg (lemburg) * (Python committer) Date: 2021-03-03 20:17
https://www.python.org/download/releases/2.4/license/ is the correct link for the Python 2.4 license.

Note that the contributor agreement allows the PSF to distribute the code under a different OSS license and so the current Python license applies for whatever version of Python you are using applies.

Peter Astrand still owns the copyright to the code he contributed and so the notice may not be removed until everything he contributed is gone. Even then, it's a courtesy to the author to leave an authorship notice in the code, since the original contribution motivated the API, which mostly still is in place. In fact, the contrib agreement probably doesn't even allow removing it at all, since it requires:

"""
Contributor shall identify each Contribution by placing the following notice in its source code adjacent to Contributor's valid copyright notice: "Licensed to PSF under a Contributor Agreement." 
"""

This is the original file which was added:

https://github.com/python/cpython/blob/5b3687df2e6dce2c09662ec9287e8f23075c4f1d/Lib/subprocess.py

At that time we did not have contributor agreements in place, AFAIR. The contrib agreement came later and allowed the removal of the verbatim 3-clause BSD license.

It's probably good idea to remove the reference to Python 2.4 from the doc-string.
msg388117 - (view) Author: Gregory P. Smith (gregory.p.smith) * (Python committer) Date: 2021-03-04 18:25
New changeset b225d91f0a92d657d9a1b62daa53ab239c8191e3 by Kamil Turek in branch 'master':
bpo-43391: Remove the broken Python 2.4 link from the comment (GH-24736)
https://github.com/python/cpython/commit/b225d91f0a92d657d9a1b62daa53ab239c8191e3
History
Date User Action Args
2021-03-06 12:24:04lemburgsetstatus: open -> closed
resolution: fixed
stage: patch review -> resolved
2021-03-04 18:25:02gregory.p.smithsetnosy: + gregory.p.smith
messages: + msg388117
2021-03-03 22:35:35kamiltureksetkeywords: + patch
stage: patch review
pull_requests: + pull_request23507
2021-03-03 21:56:18kamiltureksetnosy: + kamilturek
2021-03-03 20:17:20lemburgsetnosy: + lemburg
messages: + msg388054
2021-03-03 20:00:56poikilossetmessages: + msg388050
2021-03-03 19:59:50poikiloscreate