classification
Title: build.yml workflow not testing on pushes
Type: behavior Stage: resolved
Components: Build Versions: Python 3.10, Python 3.9, Python 3.8, Python 3.7
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: FFY00, Mariatta, ammar2, miss-islington, vstinner
Priority: normal Keywords: patch

Created on 2020-12-28 22:31 by ammar2, last changed 2021-02-04 19:57 by ammar2. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 24004 merged FFY00, 2020-12-29 21:59
PR 24010 closed miss-islington, 2020-12-30 19:14
PR 24011 closed miss-islington, 2020-12-30 19:14
PR 24437 merged miss-islington, 2021-02-03 23:16
PR 24438 merged miss-islington, 2021-02-03 23:16
Messages (9)
msg383935 - (view) Author: Ammar Askar (ammar2) * (Python committer) Date: 2020-12-28 22:31
It looks like on pushes to Github, we currently aren't running tests. (Though this isn't too big of a concern since they get run on pull requests).

Here's an example of a recent run https://github.com/python/cpython/runs/1609911031

```
fatal: ambiguous argument 'origin/..': unknown revision or path not in the working tree.
Use '--' to separate paths from revisions, like this:
'git <command> [<revision>...] -- [<file>...]'
```
msg383937 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2020-12-28 23:38
> build.yml workflow not testing on pushes

What does it mean: "on pushes"?
msg383941 - (view) Author: Ammar Askar (ammar2) * (Python committer) Date: 2020-12-29 00:31
Any commit that gets to pushed to the master, 3.9, 3.8 and 3.7 branches.

e.g all the commits here https://github.com/python/cpython/commits/master, they end up failing the "Check for source changes" step and skipping even when there's non-documentation changes.
msg384030 - (view) Author: Filipe Laíns (FFY00) * (Python triager) Date: 2020-12-29 22:00
This is due to a typo, I commented on the original PR and opened a PR fixing it. Cheers :)
msg384067 - (view) Author: miss-islington (miss-islington) Date: 2020-12-30 14:54
New changeset 4ac923f2756f835f512339ee181348cc535ab07f by Filipe Laíns in branch 'master':
bpo-42773: fix tests not being run on pushes (GH-24004)
https://github.com/python/cpython/commit/4ac923f2756f835f512339ee181348cc535ab07f
msg384074 - (view) Author: Filipe Laíns (FFY00) * (Python triager) Date: 2020-12-30 17:41
Ammar, could you confirm the issue is now solved?
msg384077 - (view) Author: Ammar Askar (ammar2) * (Python committer) Date: 2020-12-30 17:44
Thank you Filipe and Mariatta, the fix looks good to me. I think it needs a backport to the 3.9 branch though.
msg386467 - (view) Author: miss-islington (miss-islington) Date: 2021-02-03 23:34
New changeset d29dbb122d8b8ee22b2d826af4d234a2c2cf7ba2 by Miss Islington (bot) in branch '3.8':
bpo-42773: fix tests not being run on pushes (GH-24004)
https://github.com/python/cpython/commit/d29dbb122d8b8ee22b2d826af4d234a2c2cf7ba2
msg386468 - (view) Author: miss-islington (miss-islington) Date: 2021-02-03 23:39
New changeset 0898dcb3a0400d3c93e27f9feb4c2207eb1a996d by Miss Islington (bot) in branch '3.9':
bpo-42773: fix tests not being run on pushes (GH-24004)
https://github.com/python/cpython/commit/0898dcb3a0400d3c93e27f9feb4c2207eb1a996d
History
Date User Action Args
2021-02-04 19:57:06ammar2setstatus: open -> closed
resolution: fixed
stage: patch review -> resolved
2021-02-03 23:39:02miss-islingtonsetmessages: + msg386468
2021-02-03 23:34:24miss-islingtonsetmessages: + msg386467
2021-02-03 23:16:26miss-islingtonsetpull_requests: + pull_request23246
2021-02-03 23:16:16miss-islingtonsetpull_requests: + pull_request23245
2020-12-30 19:14:26miss-islingtonsetpull_requests: + pull_request22853
2020-12-30 19:14:16miss-islingtonsetpull_requests: + pull_request22852
2020-12-30 17:44:48ammar2setmessages: + msg384077
2020-12-30 17:41:30FFY00setmessages: + msg384074
2020-12-30 14:54:10miss-islingtonsetnosy: + miss-islington
messages: + msg384067
2020-12-29 22:00:51FFY00setmessages: + msg384030
2020-12-29 21:59:46FFY00setkeywords: + patch
stage: patch review
pull_requests: + pull_request22846
2020-12-29 00:31:43ammar2setmessages: + msg383941
versions: + Python 3.7, Python 3.8
2020-12-28 23:38:16vstinnersetmessages: + msg383937
2020-12-28 22:31:27ammar2create