classification
Title: Port ssl module to heap types and module state (PEP 573)
Type: enhancement Stage: resolved
Components: Versions: Python 3.10
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: christian.heimes, shihai1991, vstinner, wingel71
Priority: normal Keywords: patch

Created on 2020-11-12 17:19 by christian.heimes, last changed 2021-04-22 09:41 by wingel71. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 23253 merged christian.heimes, 2020-11-12 17:22
PR 23392 merged christian.heimes, 2020-11-19 08:51
PR 25255 wingel71, 2021-04-22 09:41
Messages (5)
msg380837 - (view) Author: Christian Heimes (christian.heimes) * (Python committer) Date: 2020-11-12 17:19
Move all objects to module state. Convert all types and extensions to heap types.
msg380856 - (view) Author: Christian Heimes (christian.heimes) * (Python committer) Date: 2020-11-12 22:39
I underestimated the effort but it's done:

   +567 −446
   1,013 lines changed

I even got rid of PyState_FindModule().
msg381419 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2020-11-19 14:04
I marked bpo-15670 as duplicate of this issue.
msg381467 - (view) Author: Christian Heimes (christian.heimes) * (Python committer) Date: 2020-11-20 08:40
New changeset 5c36da78d738d0e5fdb539a758cc15abc47c843b by Christian Heimes in branch 'master':
bpo-42333: Port _ssl extension module to heap types (GH-23392)
https://github.com/python/cpython/commit/5c36da78d738d0e5fdb539a758cc15abc47c843b
msg391293 - (view) Author: Christian Heimes (christian.heimes) * (Python committer) Date: 2021-04-17 18:06
New changeset 7f1305ef9ea7234e1a5aacbea17490232e9b7dc2 by Christian Heimes in branch 'master':
bpo-42333: Port _ssl extension to multiphase initialization (PEP 489) (GH-23253)
https://github.com/python/cpython/commit/7f1305ef9ea7234e1a5aacbea17490232e9b7dc2
History
Date User Action Args
2021-04-22 09:41:31wingel71setnosy: + wingel71

pull_requests: + pull_request24239
2021-04-17 18:08:05christian.heimessetstatus: open -> closed
resolution: fixed
stage: patch review -> resolved
2021-04-17 18:06:41christian.heimessetmessages: + msg391293
2020-11-20 08:40:15christian.heimessetmessages: + msg381467
2020-11-19 14:04:27vstinnersetnosy: + vstinner
messages: + msg381419
2020-11-19 14:04:14vstinnerlinkissue15670 superseder
2020-11-19 08:51:38christian.heimessetpull_requests: + pull_request22284
2020-11-12 22:39:53christian.heimessetmessages: + msg380856
2020-11-12 18:19:34shihai1991setnosy: + shihai1991
2020-11-12 17:22:18christian.heimessetkeywords: + patch
pull_requests: + pull_request22149
2020-11-12 17:19:18christian.heimescreate