classification
Title: Doctest: directives
Type: enhancement Stage: resolved
Components: Documentation Versions: Python 3.8
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Doctest directives and comments missing from code samples
View: 36675
Assigned To: docs@python Nosy List: docs@python, konrad.schwarz, mdk, xtreak
Priority: normal Keywords:

Created on 2020-11-11 11:57 by konrad.schwarz, last changed 2020-12-02 23:15 by mdk. This issue is now closed.

Messages (4)
msg380752 - (view) Author: Konrad Schwarz (konrad.schwarz) Date: 2020-11-11 11:57
In both PDF and HTML, the examples for Doctest directives don't actually show the directives themselves, perhaps because they syntactically start with a #.
msg380753 - (view) Author: Karthikeyan Singaravelan (xtreak) * (Python committer) Date: 2020-11-11 12:06
Is this similar to https://bugs.python.org/issue36675 ?
msg380787 - (view) Author: Konrad Schwarz (konrad.schwarz) Date: 2020-11-11 18:42
Yes it is.

On Wed, Nov 11, 2020 at 1:06 PM Karthikeyan Singaravelan <
report@bugs.python.org> wrote:

>
> Karthikeyan Singaravelan <tir.karthi@gmail.com> added the comment:
>
> Is this similar to https://bugs.python.org/issue36675 ?
>
> ----------
> nosy: +xtreak
>
> _______________________________________
> Python tracker <report@bugs.python.org>
> <https://bugs.python.org/issue42324>
> _______________________________________
>

-- 
Mit freundlichen Grüßen

Konrad Schwarz
msg382355 - (view) Author: Julien Palard (mdk) * (Python committer) Date: 2020-12-02 23:15
Thanks for reporting!

This will be fixed soon: https://github.com/python/cpython/pull/23620

I'm marking issue42324 as duplicate of issue36675.
History
Date User Action Args
2020-12-02 23:15:42mdksetstatus: open -> closed

superseder: Doctest directives and comments missing from code samples

nosy: + mdk
messages: + msg382355
resolution: duplicate
stage: resolved
2020-11-11 18:42:59konrad.schwarzsetmessages: + msg380787
2020-11-11 12:06:00xtreaksetnosy: + xtreak
messages: + msg380753
2020-11-11 11:57:50konrad.schwarzcreate