classification
Title: FAIL test_asyncio test_sendfile_close_peer_in_the_middle_of_receiving
Type: behavior Stage: resolved
Components: asyncio, Tests Versions: Python 3.10
process
Status: closed Resolution: duplicate
Dependencies: Superseder: [Windows] test_asyncio: Proactor test_sendfile_close_peer_in_the_middle_of_receiving failure
View: 41682
Assigned To: Nosy List: asvetlov, terry.reedy, vstinner, yselivanov
Priority: normal Keywords: patch

Created on 2020-10-23 02:34 by terry.reedy, last changed 2021-04-15 12:52 by vstinner. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 25400 vstinner, 2021-04-15 12:51
Messages (2)
msg379397 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2020-10-23 02:34
======================================================================
FAIL: test_sendfile_close_peer_in_the_middle_of_receiving (test.test_asyncio.test_sendfile.ProactorEventLoopTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "D:\a\1\s\lib\test\test_asyncio\test_sendfile.py", line 458, in test_sendfile_close_peer_in_the_middle_of_receiving
    self.run_loop(
AssertionError: ConnectionError not raised
msg391132 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2021-04-15 12:52
Duplicate of bpo-41682.
History
Date User Action Args
2021-04-15 12:52:37vstinnersetstatus: open -> closed
superseder: [Windows] test_asyncio: Proactor test_sendfile_close_peer_in_the_middle_of_receiving failure
messages: + msg391132

resolution: duplicate
stage: patch review -> resolved
2021-04-15 12:51:33vstinnersetkeywords: + patch
nosy: + vstinner

pull_requests: + pull_request24156
stage: needs patch -> patch review
2020-10-23 02:34:27terry.reedycreate