classification
Title: Document addition of `mock.call_args.args` and `mock.call_args.kwargs` in 3.8
Type: Stage: resolved
Components: Documentation Versions: Python 3.10, Python 3.9, Python 3.8
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: docs@python Nosy List: docs@python, miss-islington, uspike, xtreak
Priority: normal Keywords: patch

Created on 2020-07-17 17:10 by uspike, last changed 2020-07-18 13:19 by xtreak. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 21525 merged uspike, 2020-07-17 17:29
PR 21530 merged miss-islington, 2020-07-18 13:06
PR 21531 merged miss-islington, 2020-07-18 13:06
Messages (6)
msg373839 - (view) Author: Jordan Speicher (uspike) * Date: 2020-07-17 17:10
`args` and `kwargs` were added to unittest `mock.call_args` in https://bugs.python.org/issue21269 however documentation was not updated to state that this was added in python 3.8
msg373898 - (view) Author: Karthikeyan Singaravelan (xtreak) * (Python committer) Date: 2020-07-18 12:58
This is a duplicate of https://bugs.python.org/issue40820 . But this PR has cla signed so I am inclined towards merging this instead.
msg373899 - (view) Author: Karthikeyan Singaravelan (xtreak) * (Python committer) Date: 2020-07-18 13:05
New changeset 9b01c598ca2576a1056816e85dd84bf5f9c74688 by Jordan Speicher in branch 'master':
bpo-41325: Add version note for args and kwargs property in call object (GH-21525)
https://github.com/python/cpython/commit/9b01c598ca2576a1056816e85dd84bf5f9c74688
msg373901 - (view) Author: miss-islington (miss-islington) Date: 2020-07-18 13:13
New changeset 7734738d71c052779d3cb189e5ba0759beb8d620 by Miss Islington (bot) in branch '3.8':
bpo-41325: Add version note for args and kwargs property in call object (GH-21525)
https://github.com/python/cpython/commit/7734738d71c052779d3cb189e5ba0759beb8d620
msg373902 - (view) Author: miss-islington (miss-islington) Date: 2020-07-18 13:14
New changeset f92544483fc724b7e9ac11b2ee86b38e069cc70f by Miss Islington (bot) in branch '3.9':
bpo-41325: Add version note for args and kwargs property in call object (GH-21525)
https://github.com/python/cpython/commit/f92544483fc724b7e9ac11b2ee86b38e069cc70f
msg373903 - (view) Author: Karthikeyan Singaravelan (xtreak) * (Python committer) Date: 2020-07-18 13:19
Thanks Jordan for the report and patch.
History
Date User Action Args
2020-07-18 13:19:43xtreaksetstatus: open -> closed
resolution: fixed
messages: + msg373903

stage: patch review -> resolved
2020-07-18 13:14:35miss-islingtonsetmessages: + msg373902
2020-07-18 13:13:26miss-islingtonsetmessages: + msg373901
2020-07-18 13:08:34xtreaklinkissue40820 superseder
2020-07-18 13:06:26miss-islingtonsetpull_requests: + pull_request20667
2020-07-18 13:06:07miss-islingtonsetnosy: + miss-islington
pull_requests: + pull_request20666
2020-07-18 13:05:47xtreaksetmessages: + msg373899
2020-07-18 12:58:44xtreaksetnosy: + xtreak
messages: + msg373898
2020-07-17 17:29:09uspikesetkeywords: + patch
stage: patch review
pull_requests: + pull_request20662
2020-07-17 17:10:26uspikecreate