classification
Title: Documentation still mentions 'u' string formatting option
Type: behavior Stage: resolved
Components: Documentation Versions: Python 3.10, Python 3.9, Python 3.8, Python 3.7, Python 3.6, Python 3.5
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: docs@python Nosy List: alexandre.vassalotti, benjamin.peterson, berker.peksag, christian.heimes, docs@python, eli.bendersky, ezio.melotti, georg.brandl, gphemsley, martin.panter, ncoghlan, petr.viktorin, rhettinger, shubh07
Priority: normal Keywords: easy

Created on 2020-06-13 23:47 by gphemsley, last changed 2020-06-30 12:25 by petr.viktorin. This issue is now closed.

Messages (4)
msg371474 - (view) Author: Gordon P. Hemsley (gphemsley) * Date: 2020-06-13 23:47
https://docs.python.org/3/library/stdtypes.html#old-string-formatting still lists the 'u' string formatting option, described as "Obsolete type – it is identical to 'd'." and linking to PEP 237.

However, testing indicates that Python 3 does not support a 'u' option and my archaeology suggests that such support was removed in Python 2.4. It seems this has flown under the radar for quite some time.
msg371666 - (view) Author: Shubham Upreti (shubh07) * Date: 2020-06-16 15:06
Should i take this issue?
msg372675 - (view) Author: Petr Viktorin (petr.viktorin) * (Python committer) Date: 2020-06-30 09:33
AFAICS, Python 3 suports '%u' for printf-style formatting:

Python 3.8.3 (default, May 29 2020, 00:00:00) 
[GCC 10.1.1 20200507 (Red Hat 10.1.1-1)] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> '%u' % 6
'6'


What am I missing?
msg372685 - (view) Author: Petr Viktorin (petr.viktorin) * (Python committer) Date: 2020-06-30 12:25
I'm closing the issue. Please comment or reopen if I missed something.
History
Date User Action Args
2020-06-30 12:25:50petr.viktorinsetstatus: open -> closed
resolution: not a bug
messages: + msg372685

stage: needs patch -> resolved
2020-06-30 09:33:37petr.viktorinsetnosy: + petr.viktorin
messages: + msg372675
2020-06-16 15:06:32shubh07setnosy: + shubh07
messages: + msg371666
2020-06-15 23:28:34benjamin.petersonsetkeywords: + easy
stage: needs patch
2020-06-13 23:47:49gphemsleycreate