classification
Title: Doc: Parallel build break audit table
Type: Stage: resolved
Components: Documentation Versions: Python 3.10, Python 3.9
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: docs@python Nosy List: docs@python, mdk, xtreak
Priority: normal Keywords: patch

Created on 2020-05-23 10:56 by mdk, last changed 2020-07-06 20:28 by mdk. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 21237 merged mdk, 2020-06-30 15:59
Messages (2)
msg369712 - (view) Author: Julien Palard (mdk) * (Python committer) Date: 2020-05-23 10:56
Currently we can't build the doc using sphinx parallel builds, like: `sphinx-build -j auto`, because the audit-events table [1] is not generated in this case.

[1]: https://docs.python.org/3/library/audit_events.html

To reproduce:

    make -C Doc SPHINXOPTS='-j auto' autobuild-dev-html
    see build/html/library/audit_events.html

see also: https://mail.python.org/archives/list/python-dev@python.org/thread/POWT35ULU2CPELWQ6BRTLTU5H3YKHQZW/
msg373171 - (view) Author: Julien Palard (mdk) * (Python committer) Date: 2020-07-06 20:28
New changeset a103e73ce8d34e3af5f556ee9090ce89249d565e by Julien Palard in branch 'master':
bpo-40742: Doc: fix parallel build. (GH-21237)
https://github.com/python/cpython/commit/a103e73ce8d34e3af5f556ee9090ce89249d565e
History
Date User Action Args
2020-07-06 20:28:40mdksetstatus: open -> closed
resolution: fixed
stage: patch review -> resolved
2020-07-06 20:28:22mdksetmessages: + msg373171
2020-06-30 15:59:17mdksetkeywords: + patch
stage: patch review
pull_requests: + pull_request20389
2020-05-23 10:56:47mdkcreate