classification
Title: Link to "Python Packaging User Guide: Creating and using virtual environments" is broken
Type: Stage: resolved
Components: Documentation Versions: Python 3.8
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: docs@python Nosy List: Mariatta, Ognyan Moore, ammar2, angelcervera, docs@python, miss-islington, nanjekyejoannah, willingc
Priority: normal Keywords: newcomer friendly, patch

Created on 2020-01-22 09:32 by angelcervera, last changed 2020-07-07 23:47 by miss-islington. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 18432 merged python-dev, 2020-02-10 19:53
PR 21383 merged miss-islington, 2020-07-07 23:39
Messages (10)
msg360454 - (view) Author: Angel Cervera Claudio (angelcervera) Date: 2020-01-22 09:32
The link "See also: Python Packaging User Guide: Creating and using virtual environments" Is broken.

The problem is in line 30 of https://github.com/python/cpython/blob/3.8/Doc/library/venv.rst

I don't know the right link, so I can not fix it.

I any one provive me the right link, I can create a PR.
msg360455 - (view) Author: Ammar Askar (ammar2) * (Python triager) Date: 2020-01-22 09:35
Hi Angel, thank you for the report! The file that corresponds to that documentation is here https://github.com/python/cpython/blob/master/Doc/library/venv.rst and we'd be happy to have you make a PR for it :)
msg360456 - (view) Author: Ammar Askar (ammar2) * (Python triager) Date: 2020-01-22 09:37
Oh and I think the new link should point here: https://packaging.python.org/guides/installing-using-pip-and-virtual-environments/#creating-a-virtual-environment
msg361713 - (view) Author: Ognyan Moore (Ognyan Moore) * Date: 2020-02-10 19:43
Hi, I'm at pycascades cpython sprint, I can tackle this issue.
msg361714 - (view) Author: Ognyan Moore (Ognyan Moore) * Date: 2020-02-10 20:00
Submitted PR 18432 to reflect this fix
msg361754 - (view) Author: Carol Willing (willingc) * (Python committer) Date: 2020-02-10 23:51
New changeset c4a65ed7fe342bd18b5a5b0eea3470dc4fc31160 by Ogi Moore in branch 'master':
bpo-39417: Fix broken link to guide to building venvs (GH-18432)
https://github.com/python/cpython/commit/c4a65ed7fe342bd18b5a5b0eea3470dc4fc31160
msg361822 - (view) Author: Angel Cervera Claudio (angelcervera) Date: 2020-02-11 16:26
Thanks for handling this. I'm sorry   I didn't have a chance to create the
pr. :(

On Mon 10 Feb 2020, 23:51 Carol Willing, <report@bugs.python.org> wrote:

>
> Carol Willing <willingc@gmail.com> added the comment:
>
>
> New changeset c4a65ed7fe342bd18b5a5b0eea3470dc4fc31160 by Ogi Moore in
> branch 'master':
> bpo-39417: Fix broken link to guide to building venvs (GH-18432)
>
> https://github.com/python/cpython/commit/c4a65ed7fe342bd18b5a5b0eea3470dc4fc31160
>
>
> ----------
> nosy: +willingc
>
> _______________________________________
> Python tracker <report@bugs.python.org>
> <https://bugs.python.org/issue39417>
> _______________________________________
>
msg373243 - (view) Author: Joannah Nanjekye (nanjekyejoannah) * (Python committer) Date: 2020-07-07 20:09
Looks like this should be closed as the submitted PR was merged. Just following up for consesus.
msg373266 - (view) Author: Mariatta (Mariatta) * (Python committer) Date: 2020-07-07 23:41
Just needed a backport to 3.8 (which is in flight) so this is good to be closed.
Thanks.
msg373268 - (view) Author: miss-islington (miss-islington) Date: 2020-07-07 23:47
New changeset 730bce3a80819e0b7fa6bfa1e1afcd4c837b62c1 by Miss Islington (bot) in branch '3.8':
bpo-39417: Fix broken link to guide to building venvs (GH-18432)
https://github.com/python/cpython/commit/730bce3a80819e0b7fa6bfa1e1afcd4c837b62c1
History
Date User Action Args
2020-07-07 23:47:12miss-islingtonsetmessages: + msg373268
2020-07-07 23:41:23Mariattasetstatus: open -> closed

nosy: + Mariatta
messages: + msg373266

resolution: fixed
stage: patch review -> resolved
2020-07-07 23:39:48miss-islingtonsetnosy: + miss-islington
pull_requests: + pull_request20528
2020-07-07 20:09:13nanjekyejoannahsetnosy: + nanjekyejoannah
messages: + msg373243
2020-02-11 16:26:30angelcerverasetmessages: + msg361822
2020-02-10 23:51:05willingcsetnosy: + willingc
messages: + msg361754
2020-02-10 20:13:26ammar2setkeywords: + newcomer friendly
2020-02-10 20:00:49Ognyan Mooresetmessages: + msg361714
2020-02-10 19:53:20python-devsetkeywords: + patch
stage: patch review
pull_requests: + pull_request17806
2020-02-10 19:43:29Ognyan Mooresetnosy: + Ognyan Moore
messages: + msg361713
2020-01-22 09:37:42ammar2setmessages: + msg360456
2020-01-22 09:35:38ammar2setnosy: + ammar2
messages: + msg360455
2020-01-22 09:32:01angelcerveracreate