classification
Title: Update bundled pip to 20.1.1
Type: enhancement Stage: resolved
Components: Library (Lib) Versions: Python 3.10, Python 3.9, Python 3.8, Python 3.7
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: The Compiler, Xavier Fernandez, miss-islington, ned.deily, vstinner
Priority: normal Keywords: patch

Created on 2019-10-15 21:19 by Xavier Fernandez, last changed 2020-06-15 23:05 by ned.deily. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 16782 merged Xavier Fernandez, 2019-10-15 21:19
PR 20484 merged vstinner, 2020-05-28 13:31
PR 20491 merged Xavier Fernandez, 2020-05-28 14:54
PR 20898 merged miss-islington, 2020-06-15 20:10
PR 20900 merged ned.deily, 2020-06-15 20:52
PR 20902 merged miss-islington, 2020-06-15 21:42
Messages (9)
msg370204 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2020-05-28 13:25
> Various buildbots which run the tests with an installed python, fail with: (...)

It's the "chmod" step which fails. I guess that only "Install" buildbot workers are affected. I failed to reproduce the issue with commands:
---
./configure --prefix $PWD/target --with-pydebug
make && make install
chmod -R -w target/
---

I get these permissions:
---
$ ls -l target/lib/python3.10/site-packages/setuptools-46.1.3.dist-info/RECORD
-r--r--r--. 1 vstinner vstinner 14560 28 mai   03:40 target/lib/python3.10/site-packages/setuptools-46.1.3.dist-info/RECORD
---
msg370210 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2020-05-28 13:56
commit feb0846c3a28b05b4cfbc6ab34c764957f3eff55
Author: Xavier Fernandez <xav.fernandez@gmail.com>
Date:   Wed May 27 12:49:34 2020 +0200

    Upgrade bundled versions of pip & setuptools (#16782)
msg370211 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2020-05-28 13:56
This commit introduced another regression, bpo-40808: test_venv fails with HOME=/ on AMD64 FreeBSD Non-Debug 3.x.
msg370213 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2020-05-28 14:01
The change broke multiple buildbots. Since nobody is available to investigate the two regressions (install buildbots and test_venv), I reverted the change following this policy:
https://pythondev.readthedocs.io/ci.html#revert-on-fail

Buildbot failures were reported directly the on PR, see:
https://github.com/python/cpython/pull/16782#issuecomment-634640005

The revert is an opportunity to have more time to investigate the issue and write a proper fix, rather than working on urgency.

commit 4fd4963ccce5c12f742303dab6e43818b1133c7e (HEAD -> master, upstream/master)
Author: Victor Stinner <vstinner@python.org>
Date:   Thu May 28 15:57:49 2020 +0200

    Revert "Upgrade bundled versions of pip & setuptools (#16782)" (GH-20484)
    
    This reverts commit feb0846c3a28b05b4cfbc6ab34c764957f3eff55.
msg371587 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2020-06-15 19:16
New changeset 5f79f46612c351bde78a41c5264c42db21008868 by Xavier Fernandez in branch 'master':
bpo-38488: Upgrade bundled versions of pip & setuptools (GH-20491)
https://github.com/python/cpython/commit/5f79f46612c351bde78a41c5264c42db21008868
msg371596 - (view) Author: miss-islington (miss-islington) Date: 2020-06-15 20:39
New changeset bc996c67b7ba73886bb6edfd637ef3f874ddc9d4 by Miss Islington (bot) in branch '3.9':
bpo-38488: Upgrade bundled versions of pip & setuptools (GH-20491)
https://github.com/python/cpython/commit/bc996c67b7ba73886bb6edfd637ef3f874ddc9d4
msg371598 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2020-06-15 21:42
New changeset e63cc2f64668bd1d4581f8efa7089af7e08863b8 by Ned Deily in branch '3.8':
bpo-38488: Upgrade bundled versions of pip & setuptools (GH-20491) (GH-20900)
https://github.com/python/cpython/commit/e63cc2f64668bd1d4581f8efa7089af7e08863b8
msg371599 - (view) Author: miss-islington (miss-islington) Date: 2020-06-15 22:01
New changeset 678ffc42813c9fcf36324ba378632b8a3fc18fb6 by Miss Islington (bot) in branch '3.7':
bpo-38488: Upgrade bundled versions of pip & setuptools (GH-20491) (GH-20900)
https://github.com/python/cpython/commit/678ffc42813c9fcf36324ba378632b8a3fc18fb6
msg371603 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2020-06-15 23:05
Thanks, Xavier, for the original PR and for the various requested updates!  And thanks everyone else for the reviews and follow-ups. Merged for release in 3.9.0, 3.8.4, and 3.7.8.
History
Date User Action Args
2020-06-15 23:05:58ned.deilysetstatus: open -> closed
versions: + Python 3.7, Python 3.8, Python 3.9, Python 3.10
title: Update bundled pip to 19.3 -> Update bundled pip to 20.1.1
messages: + msg371603

resolution: fixed
stage: patch review -> resolved
2020-06-15 22:01:27miss-islingtonsetmessages: + msg371599
2020-06-15 21:42:47miss-islingtonsetpull_requests: + pull_request20085
2020-06-15 21:42:30ned.deilysetmessages: + msg371598
2020-06-15 20:52:31ned.deilysetpull_requests: + pull_request20083
2020-06-15 20:39:59miss-islingtonsetmessages: + msg371596
2020-06-15 20:10:04miss-islingtonsetnosy: + miss-islington
pull_requests: + pull_request20081
2020-06-15 19:33:33ned.deilylinkissue40808 superseder
2020-06-15 19:30:18ned.deilylinkissue40119 superseder
2020-06-15 19:16:56ned.deilysetnosy: + ned.deily
messages: + msg371587
2020-05-28 14:54:13Xavier Fernandezsetpull_requests: + pull_request19740
2020-05-28 14:06:46The Compilersetnosy: + The Compiler
2020-05-28 14:01:04vstinnersetmessages: + msg370213
2020-05-28 13:56:58vstinnersetmessages: + msg370211
2020-05-28 13:56:29vstinnersetmessages: + msg370210
2020-05-28 13:31:17vstinnersetkeywords: + patch
stage: patch review
pull_requests: + pull_request19733
2020-05-28 13:25:28vstinnersetnosy: + vstinner
messages: + msg370204
2019-10-15 21:19:42Xavier Fernandezcreate