classification
Title: add force_shared Library option to create shared lib even with use_stub=False
Type: enhancement Stage:
Components: Distutils Versions: 3rd party
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: pje, python-dev, vajda, vstinner
Priority: normal Keywords:

Created on 2008-09-11 02:30 by vajda, last changed 2019-10-01 11:54 by vstinner. This issue is now closed.

Files
File name Uploaded Description Edit
patch.st vajda, 2008-09-11 02:30 patch against setuptools 0.6 svn branch
Pull Requests
URL Status Linked Edit
PR 16518 merged vstinner, 2019-10-01 11:50
Messages (4)
msg73002 - (view) Author: vajda (vajda) Date: 2008-09-11 02:30
setuptools is growing the capability to build regular shared libraries
(as opposed to python extensions). JCC
(http://svn.osafoundation.org/pylucene/trunk/jcc/jcc) uses this
capability to build the JCC runtime into a regular shared library shared
by all python extensions it builds and by programs embedding python
(such as a Java VM when running JCC-built eggs from Apache Tomcat).

This bug is about adding another option to the setuptools Library class
called force_shared which forces setuptools to create a shared library
from a Library instance even though the dl module may not be present to
generate stubs. This is important on Linux. Note that using this flag
then implies that the library itself is responsible for calling        
dlopen(buf, RTLD_NOW | RTLD_GLOBAL) on the relevant libpython.so before
initializing the python runtime is initialized.

A patch against the setuptools 0.6 branch svn is attached.
The idea for this patch came from a conversation on IRC:
http://chandlerproject.org/script/getIrcTranscript.cgi?channel=chandler&date=20080910&startTime=1729
msg73004 - (view) Author: vajda (vajda) Date: 2008-09-11 05:46
This bug can be closed. It moved to the setuptools issue tracker as
issue 43.
msg353681 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2019-10-01 11:52
New changeset bfe1f74e39d0049a829962050e86a6a2d2a2781e by Victor Stinner in branch '3.8':
[3.8] bpo-3832: Fix compiler warnings (GH-16518)
https://github.com/python/cpython/commit/bfe1f74e39d0049a829962050e86a6a2d2a2781e
msg353682 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2019-10-01 11:54
Oops, the previous comment should be for bpo-38321.
History
Date User Action Args
2019-10-01 11:54:21vstinnersetmessages: + msg353682
2019-10-01 11:52:03vstinnersetnosy: + vstinner
messages: + msg353681
2019-10-01 11:50:02vstinnersetpull_requests: + pull_request16111
2014-10-12 09:37:43terry.reedysetmessages: - msg228637
2014-10-06 04:14:21python-devsetnosy: + python-dev
messages: + msg228637
2008-09-11 06:15:38loewissetstatus: open -> closed
resolution: not a bug
versions: + 3rd party
2008-09-11 05:46:20vajdasetmessages: + msg73004
2008-09-11 02:30:13vajdacreate