classification
Title: Sphinx (Travis doc build) is blocking merging
Type: behavior Stage: resolved
Components: Tests Versions: Python 3.9, Python 3.8
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: ammar2, mdk, miss-islington, ned.deily, terry.reedy, vstinner, zach.ware
Priority: critical Keywords: 3.8regression, patch

Created on 2019-07-21 16:48 by terry.reedy, last changed 2019-07-21 18:39 by terry.reedy. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 14885 merged ned.deily, 2019-07-21 17:56
PR 14886 merged miss-islington, 2019-07-21 18:02
PR 14887 closed terry.reedy, 2019-07-21 18:24
Messages (5)
msg348253 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2019-07-21 16:48
One of the required CI tests is a Travis doc build, even if a PR does not touch any doc file.  The following failure appears to be deterministic on master and 3.8.  A 3.7 backport passed.  It has happened multiple times on multiple PRs today.  Example:
https://travis-ci.org/python/cpython/jobs/561700698
The failure is
'''
Warning, treated as error:
[distutils/examples:267] "`" found in "This is the description of the ``foobar`` package."
'''
I have no idea why this is seen as suspicious.

I have 4 PRs blocked by this.
https://github.com/python/cpython/pull/14872
https://github.com/python/cpython/pull/14879
https://github.com/python/cpython/pull/14883
https://github.com/python/cpython/pull/14881
The last one is the 3.8 backport of a PR that passed CI maybe 12 hours ago.  Its 3.7 backport passed and is merged.

If nothing else, can warnings not be treated as errors?
msg348254 - (view) Author: Ammar Askar (ammar2) * (Python committer) Date: 2019-07-21 17:14
This particular error used to be covered here: https://github.com/python/cpython/blob/master/Doc/tools/susp-ignored.csv but looks like a line number change has broken it.
msg348256 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2019-07-21 18:01
New changeset 22f0483d44b13140f6ea9927f0cf088c493e875a by Ned Deily in branch 'master':
Bpo-37644: update suspicious.csv for distutils/examples (GH-14885)
https://github.com/python/cpython/commit/22f0483d44b13140f6ea9927f0cf088c493e875a
msg348258 - (view) Author: miss-islington (miss-islington) Date: 2019-07-21 18:09
New changeset 8f501647ca1fba32204c0c1a705e06b4e43c69b1 by Miss Islington (bot) in branch '3.8':
Bpo-37644: update suspicious.csv for distutils/examples (GH-14885)
https://github.com/python/cpython/commit/8f501647ca1fba32204c0c1a705e06b4e43c69b1
msg348260 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2019-07-21 18:39
Although the error message says line 267, the suspicious line is on 273 for the copies in my repository on windows.  If 267 does not work, I will revise and merge my overlapping PR that removes the number.  Most of the entries in susp-ignored.csv do not have line numbers, which seems less fragile. I don't think that this entry needs one either.  The prefix "This is the description of the" does not appear elsewhere in the file, is unlikely to, and if the sentence were repeated, it would likely not be an issue anyway.
History
Date User Action Args
2019-07-21 18:39:04terry.reedysetmessages: + msg348260
2019-07-21 18:24:04terry.reedysetpull_requests: + pull_request14672
2019-07-21 18:12:31ned.deilysetstatus: open -> closed
resolution: fixed
stage: patch review -> resolved
2019-07-21 18:09:00miss-islingtonsetnosy: + miss-islington
messages: + msg348258
2019-07-21 18:02:17miss-islingtonsetpull_requests: + pull_request14671
2019-07-21 18:01:59ned.deilysetnosy: + ned.deily
messages: + msg348256
2019-07-21 17:56:00ned.deilysetkeywords: + patch
stage: needs patch -> patch review
pull_requests: + pull_request14670
2019-07-21 17:14:38ammar2setnosy: + ammar2
messages: + msg348254
2019-07-21 16:48:55terry.reedycreate