classification
Title: Add os.RWF_APPEND flag for os.pwritev
Type: enhancement Stage: resolved
Components: Library (Lib) Versions: Python 3.10
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: YoSTEALTH, bezoka, cheryl.sabella, gregory.p.smith, pablogsal, terry.reedy, vstinner
Priority: normal Keywords: patch

Created on 2019-06-01 21:51 by bezoka, last changed 2020-05-28 00:16 by vstinner. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 13735 closed bezoka, 2019-06-01 21:52
PR 20335 closed YoSTEALTH, 2020-05-23 22:14
PR 20336 merged YoSTEALTH, 2020-05-23 22:35
Messages (7)
msg345000 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2019-06-07 18:58
Issues need a more complete title and at least *some* explanation.
msg345193 - (view) Author: Gregory P. Smith (gregory.p.smith) * (Python committer) Date: 2019-06-11 06:30
This is just adding a missing constant (when defined at CPython compile time) to the os module.  I suggest landing this in 3.8 as well assuming we're still in the beta cycles when the PR is ready.  It isn't a functional change.
msg369670 - (view) Author: Cheryl Sabella (cheryl.sabella) * (Python committer) Date: 2020-05-23 00:03
The PR for this issue has been closed, but the issue is now open for someone else to make a PR for it.  Please credit the original author in the new PR.
msg369690 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2020-05-23 02:53
YoSTEALTH, are you both allowed and willing to do so? The patch is not completely trivial and you seem to have the needed knowledge.  (I don't.)
msg369754 - (view) Author: (YoSTEALTH) * Date: 2020-05-23 22:41
terry.reedy ok, recreated the patch.
msg370139 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2020-05-27 21:32
New changeset 76ef255bde772005bbd0761399b274c2240e61d3 by YoSTEALTH in branch 'master':
bpo-37129: Add os.RWF_APPEND flag for os.pwritev() (GH-20336)
https://github.com/python/cpython/commit/76ef255bde772005bbd0761399b274c2240e61d3
msg370156 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2020-05-28 00:16
Thanks YoSTEALTH.
History
Date User Action Args
2020-05-28 00:16:52vstinnersetstatus: open -> closed
resolution: fixed
messages: + msg370156

stage: patch review -> resolved
2020-05-27 21:32:26vstinnersetmessages: + msg370139
2020-05-23 22:41:35YoSTEALTHsetmessages: + msg369754
2020-05-23 22:35:16YoSTEALTHsetpull_requests: + pull_request19604
2020-05-23 22:14:44YoSTEALTHsetkeywords: + patch
stage: needs patch -> patch review
pull_requests: + pull_request19603
2020-05-23 02:53:14terry.reedysetversions: - Python 3.9
2020-05-23 02:53:03terry.reedysetmessages: + msg369690
2020-05-23 00:03:55cheryl.sabellasetversions: + Python 3.10, - Python 3.8
nosy: + cheryl.sabella

messages: + msg369670

keywords: - patch
stage: patch review -> needs patch
2019-06-11 06:30:02gregory.p.smithsetnosy: + gregory.p.smith

messages: + msg345193
versions: + Python 3.8
2019-06-07 18:58:45terry.reedysetnosy: + terry.reedy
title: Add RWF_APPEND flag -> Add os.RWF_APPEND flag for os.pwritev
messages: + msg345000

versions: + Python 3.9, - Python 3.8
2019-06-05 20:35:01YoSTEALTHsetnosy: + YoSTEALTH
2019-06-01 21:52:32bezokasetkeywords: + patch
stage: patch review
pull_requests: + pull_request13618
2019-06-01 21:51:52bezokacreate