classification
Title: Cleanup some non-consistent API callings
Type: enhancement Stage: resolved
Components: Windows Versions: Python 3.8
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: Minmin.Gong, miss-islington, paul.moore, steve.dower, tim.golden, zach.ware
Priority: normal Keywords: patch, patch, patch

Created on 2019-02-02 22:08 by Minmin.Gong, last changed 2020-05-18 22:24 by steve.dower. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 11742 merged Minmin.Gong, 2019-02-02 22:09
PR 11742 merged Minmin.Gong, 2019-02-02 22:09
PR 11742 merged Minmin.Gong, 2019-02-02 22:09
PR 10286 erikjanss, 2019-05-19 09:09
PR 19974 merged Minmin.Gong, 2020-05-16 23:16
PR 20189 merged miss-islington, 2020-05-18 16:50
PR 20190 merged steve.dower, 2020-05-18 16:57
Messages (7)
msg334771 - (view) Author: Minmin Gong (Minmin.Gong) * Date: 2019-02-02 22:08
1. Unicode version of Windows APIs are used in places, but not for GetVersionEx in Python/sysmodule.c
2. The wcstok_s is called on Windows in Modules/main.c and PC/launcher.c, but not in Python/pathconfig.c
msg334784 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2019-02-03 04:26
New changeset 8ebc6451f36fa213130c316199dbec5ad8a02163 by Steve Dower (Minmin Gong) in branch 'master':
bpo-35890 : Fix some API calling consistency (GH-11742)
https://github.com/python/cpython/commit/8ebc6451f36fa213130c316199dbec5ad8a02163
msg334785 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2019-02-03 04:27
Thanks for the contribution!
msg369268 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2020-05-18 16:27
Thanks for the additional cleanup. In future, we'd still like a separate issue for new changes (that aren't fixing up something caused by the earlier change).
msg369275 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2020-05-18 16:50
New changeset 98e42d1f882b9b59f587d538c562dbc7d11c64c3 by Minmin Gong in branch 'master':
bpo-35890: Use RegQueryInfoKeyW and CryptAcquireContextW explicitly (GH-19974)
https://github.com/python/cpython/commit/98e42d1f882b9b59f587d538c562dbc7d11c64c3
msg369276 - (view) Author: miss-islington (miss-islington) Date: 2020-05-18 17:10
New changeset 460eac20a625d5dcef409dadc120a26d272a8013 by Miss Islington (bot) in branch '3.8':
bpo-35890: Use RegQueryInfoKeyW and CryptAcquireContextW explicitly (GH-19974)
https://github.com/python/cpython/commit/460eac20a625d5dcef409dadc120a26d272a8013
msg369302 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2020-05-18 22:24
New changeset 930badd414dd2376b1875e1775cb40855a87e180 by Steve Dower in branch '3.7':
bpo-35890: Use RegQueryInfoKeyW and CryptAcquireContextW explicitly (GH-19974)
https://github.com/python/cpython/commit/930badd414dd2376b1875e1775cb40855a87e180
History
Date User Action Args
2020-05-18 22:24:44steve.dowersetmessages: + msg369302
2020-05-18 17:10:02miss-islingtonsetmessages: + msg369276
2020-05-18 16:57:18steve.dowersetpull_requests: + pull_request19491
2020-05-18 16:50:20miss-islingtonsetnosy: + miss-islington

pull_requests: + pull_request19490
2020-05-18 16:50:11steve.dowersetmessages: + msg369275
2020-05-18 16:27:12steve.dowersetkeywords: patch, patch, patch

messages: + msg369268
2020-05-16 23:16:40Minmin.Gongsetpull_requests: + pull_request19442
2019-05-19 09:09:04erikjansssetpull_requests: + pull_request13328
2019-02-03 04:27:23steve.dowersetstatus: open -> closed
messages: + msg334785

keywords: patch, patch, patch
resolution: fixed
stage: patch review -> resolved
2019-02-03 04:26:58steve.dowersetmessages: + msg334784
2019-02-02 22:10:03Minmin.Gongsetkeywords: + patch
stage: patch review
pull_requests: + pull_request11660
2019-02-02 22:09:54Minmin.Gongsetkeywords: + patch
stage: (no value)
pull_requests: + pull_request11659
2019-02-02 22:09:45Minmin.Gongsetkeywords: + patch
stage: (no value)
pull_requests: + pull_request11658
2019-02-02 22:08:35Minmin.Gongcreate