classification
Title: can't open python368rc1.chm and python372rc1.chm
Type: Stage: resolved
Components: Documentation, Windows Versions: Python 3.8, Python 3.7, Python 3.6
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: docs@python Nosy List: Ma Lin, docs@python, miss-islington, ned.deily, paul.moore, serhiy.storchaka, steve.dower, tim.golden, zach.ware
Priority: release blocker Keywords: patch

Created on 2018-12-13 14:34 by Ma Lin, last changed 2018-12-24 16:32 by ned.deily. This issue is now closed.

Files
File name Uploaded Description Edit
371_chm_files.png Ma Lin, 2018-12-13 14:34
372rc1_chm_files.png Ma Lin, 2018-12-13 14:34
371_compile_progress.png Ma Lin, 2018-12-13 14:34
372rc1_compile_progress.png Ma Lin, 2018-12-13 14:34
Pull Requests
URL Status Linked Edit
PR 11206 closed serhiy.storchaka, 2018-12-18 10:51
PR 11224 open steve.dower, 2018-12-18 22:16
PR 11250 merged miss-islington, 2018-12-20 17:27
PR 11251 merged steve.dower, 2018-12-20 19:07
Messages (16)
msg331761 - (view) Author: Ma Lin (Ma Lin) * Date: 2018-12-13 14:34
python372rc1.chm can't be opened, it seems the compiling is not successful.

Compare to python371.chm, the file size reduced a lot:
python371.chm      8,534,435 bytes
python372rc1.chm   5,766,102 bytes

Some files in chm are missing, see attached pictures:
371_chm_files.png
372rc1_chm_files.png

After switch "Display compile progress" to Yes in .hhp file, the output is abnormal, see attached pictures:
371_compile_progress.png
372rc1_compile_progress.png
msg331880 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2018-12-14 22:57
You're right, this is doing something weird on master as well.

I'll take a look when I get a chance, but if anyone else wants to dive in feel free.

In both cases, the doc file cannot be opened. Marking this as a release blocker and adding RM to the bug for awareness.
msg331886 - (view) Author: Ma Lin (Ma Lin) * Date: 2018-12-15 04:28
python368rc1.chm has the same problem.

I did a git bisect.
On 3.6 branch, e825b4e1a9bbe1d4c561f4cbbe6857653ef13a15 is the first bad commit
On 3.7 branch, 9a75b8470a2e0de5406edcabba140f023c99c6a9 is the first bad commit
msg331887 - (view) Author: Ma Lin (Ma Lin) * Date: 2018-12-15 04:43
These first bad commits come from issue35054
msg332031 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2018-12-18 00:31
I did a quick look and couldn't find anything obvious in logs while building, so I guess the next step is to try taking out those new index entries to figure out which one causes the problem.

(Adding Serhiy for awareness, not necessarily trying to nominate him to do the work unless he wants to.)
msg332041 - (view) Author: Ma Lin (Ma Lin) * Date: 2018-12-18 06:05
> I guess the next step is to try taking out those new index entries to figure out which one causes the problem.

Very big amount of work..., I would suggest to revert them.
chm is a successful product, but it out of support, and no replacement yet, it's regrettable.
msg332048 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2018-12-18 10:54
The breakage was caused by the index entry for ''' (triple single quote). After removing it a correct CHM file is created.
msg332049 - (view) Author: Ma Lin (Ma Lin) * Date: 2018-12-18 11:06
amazing, you did find it.
msg332083 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2018-12-18 21:47
It looks like generally the ' entity does not work in the CHM index - there should be b' and u' entries as well, but they show up as b and u (whereas b" and u" are fine).

Substituting ' seems to work fine, but I had to do that manually in the hhk file and then rebuild the hhp directly. I'm not sure the best way to integrate it into our entire build process is.
msg332090 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2018-12-18 22:04
I think this is a Sphinx bug. It should work around limitations of the CHM compiler.
msg332091 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2018-12-18 22:15
I've got an alternate PR to do the fixup in an extension, as well as fixing two other minor build problems for docs (on Windows).
msg332108 - (view) Author: Ma Lin (Ma Lin) * Date: 2018-12-19 03:00
' comes from html.escape(s, quote=True)
https://github.com/python/cpython/blob/4a9ee26750aa8cb37b5072b2bb4dd328819febb4/Lib/html/__init__.py#L24
Of course, it's not a bug.

It would be better to patch in Sphinx, I will do it at some point.
msg332241 - (view) Author: miss-islington (miss-islington) Date: 2018-12-20 17:27
New changeset aae2e85af772a409bf8904bddc17efe9bf809174 by Miss Islington (bot) in branch '3.7':
bpo-35482: Fixes HTML escaping in CHM index and build location of NEWS file (GH-11224)
https://github.com/python/cpython/commit/aae2e85af772a409bf8904bddc17efe9bf809174
msg332246 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2018-12-20 19:09
The 3.6 PR is blocked from merging, so looking to Ned to resolve.
msg332247 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2018-12-20 19:11
New changeset 789b0ee023f14385a2fd635272768c3b55a99773 by Ned Deily (Steve Dower) in branch '3.6':
bpo-35482: Fixes HTML escaping in CHM index and build location of NEWS file (GH-11224) (GH-11251)
https://github.com/python/cpython/commit/789b0ee023f14385a2fd635272768c3b55a99773
msg332489 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2018-12-24 16:32
New changeset 4db9a3fffa232e88fcc2ad3b5ce35e9f8657bbe5 by Ned Deily (Miss Islington (bot)) in branch '3.7':
bpo-35482: Fixes HTML escaping in CHM index and build location of NEWS file (GH-11224)
https://github.com/python/cpython/commit/4db9a3fffa232e88fcc2ad3b5ce35e9f8657bbe5
History
Date User Action Args
2018-12-24 16:32:43ned.deilysetmessages: + msg332489
2018-12-20 20:48:16steve.dowersetstatus: open -> closed
resolution: fixed
stage: patch review -> resolved
2018-12-20 19:11:53ned.deilysetmessages: + msg332247
2018-12-20 19:09:27steve.dowersetmessages: + msg332246
2018-12-20 19:07:15steve.dowersetpull_requests: + pull_request10501
2018-12-20 17:27:18miss-islingtonsetnosy: + miss-islington
messages: + msg332241
2018-12-20 17:27:14miss-islingtonsetpull_requests: + pull_request10499
2018-12-19 03:00:54Ma Linsetmessages: + msg332108
2018-12-18 22:16:17steve.dowersetpull_requests: + pull_request10459
2018-12-18 22:15:46steve.dowersetmessages: + msg332091
2018-12-18 22:04:03serhiy.storchakasetmessages: + msg332090
2018-12-18 21:47:20steve.dowersetmessages: + msg332083
2018-12-18 11:06:17Ma Linsetmessages: + msg332049
2018-12-18 10:54:38serhiy.storchakasetmessages: + msg332048
2018-12-18 10:51:11serhiy.storchakasetkeywords: + patch
stage: patch review
pull_requests: + pull_request10443
2018-12-18 06:05:24Ma Linsetmessages: + msg332041
2018-12-18 00:31:46steve.dowersetnosy: + serhiy.storchaka
messages: + msg332031
2018-12-15 04:43:48Ma Linsetmessages: + msg331887
2018-12-15 04:28:32Ma Linsetversions: + Python 3.6
messages: + msg331886
title: python372rc1.chm is ill -> can't open python368rc1.chm and python372rc1.chm
2018-12-14 22:57:20steve.dowersetpriority: normal -> release blocker
versions: + Python 3.8
nosy: + ned.deily

messages: + msg331880
2018-12-14 21:49:51terry.reedysetnosy: + paul.moore, tim.golden, zach.ware, steve.dower
components: + Windows
2018-12-13 14:34:40Ma Linsetfiles: + 372rc1_compile_progress.png
2018-12-13 14:34:28Ma Linsetfiles: + 371_compile_progress.png
2018-12-13 14:34:16Ma Linsetfiles: + 372rc1_chm_files.png
2018-12-13 14:34:02Ma Lincreate