classification
Title: Upgrade macOS and Windows installers to Tcl 8.6.9 and Tk 8.6.9.1
Type: Stage: resolved
Components: macOS, Windows Versions: Python 3.8, Python 3.7, Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: tkinter windows turn black while resized using Tk 8.6.9.1 on macOS
View: 35485
Assigned To: Nosy List: miss-islington, ned.deily, paul.moore, ronaldoussoren, serhiy.storchaka, steve.dower, terry.reedy, tim.golden, zach.ware
Priority: normal Keywords: patch

Created on 2018-12-04 07:22 by ned.deily, last changed 2018-12-28 00:50 by ned.deily. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 11101 merged ned.deily, 2018-12-11 05:44
PR 11102 merged miss-islington, 2018-12-11 06:07
PR 11103 merged miss-islington, 2018-12-11 06:07
PR 11104 merged miss-islington, 2018-12-11 06:07
PR 11146 merged steve.dower, 2018-12-13 22:53
PR 11163 merged miss-islington, 2018-12-14 17:13
PR 11332 merged ned.deily, 2018-12-27 20:48
Messages (21)
msg331011 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2018-12-04 07:22
Tcl/Tk 8.6.9 (followed by Tk 8.6.9.1) was released recently.  Among other things, they contain fixes for various issues on macOS, some of which have been seen by macOS users of IDLE and other tkinter apps, so the macOS installer should definitely be updated for 3.7.2, 3.6.8, and 2.7.16.
msg331360 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2018-12-07 22:32
... and master.

I believe for Windows the policy has been to stick with one tcl/tk version for a Python version.  But I don't know that this is written on stone.  If not too much trouble, I would like master updated occasionally during the a1 period rather than just once around b1.  I am not sure about backports.
msg331578 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2018-12-11 06:07
New changeset 7cf3d8e25174c8871883e42f3240fd7f01efd3a8 by Ned Deily in branch 'master':
bpo-35402: Update macOS installer to use Tcl 8.6.9 / Tk 8.6.9.1 (GH-11101)
https://github.com/python/cpython/commit/7cf3d8e25174c8871883e42f3240fd7f01efd3a8
msg331581 - (view) Author: miss-islington (miss-islington) Date: 2018-12-11 06:28
New changeset 3b9a0186c44d0c3e477c38fdc00203ec99aec912 by Miss Islington (bot) in branch '3.7':
bpo-35402: Update macOS installer to use Tcl 8.6.9 / Tk 8.6.9.1 (GH-11101)
https://github.com/python/cpython/commit/3b9a0186c44d0c3e477c38fdc00203ec99aec912
msg331582 - (view) Author: miss-islington (miss-islington) Date: 2018-12-11 06:29
New changeset 37607f26697351751165a042f91f04530ce333f7 by Miss Islington (bot) in branch '3.6':
bpo-35402: Update macOS installer to use Tcl 8.6.9 / Tk 8.6.9.1 (GH-11101)
https://github.com/python/cpython/commit/37607f26697351751165a042f91f04530ce333f7
msg331586 - (view) Author: miss-islington (miss-islington) Date: 2018-12-11 06:39
New changeset aa580508431d231677cfaa13ac9b6aa37538b9ef by Miss Islington (bot) in branch '2.7':
bpo-35402: Update macOS installer to use Tcl 8.6.9 / Tk 8.6.9.1 (GH-11101)
https://github.com/python/cpython/commit/aa580508431d231677cfaa13ac9b6aa37538b9ef
msg331587 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2018-12-11 06:54
The macOS installers will use Tcl 8.6.9 and Tk 8.6.9.1 starting with 3.7.2rc1 and 3.6.8rc1.  Due to time constraints, the Windows builds will get updated later.
msg331643 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2018-12-11 18:34
I pushed the raw Tcl and Tk sources for 8.6.9.0 to cpython-source-deps, but it looks like we need some patches to be able to build on Windows (the X11 headers #define some names that the Windows headers want to use as struct members).

So far I've needed to #undef and redefine None and ControlMask around #include <Windows.h> in winmain.c and tkWin.h, but I think that will be enough.
msg331656 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2018-12-11 22:17
Looks like Tix needs similar updates, since it imports the Tk headers. Perhaps it'll be easier to undef immediately after the X11\X.h include? Assuming the values aren't actually being used anywhere.
msg331657 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2018-12-11 22:20
Should the problems be reported upstream?
msg331667 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2018-12-11 23:26
Probably. I'm 99% sure it's a problem with the latest build tools, and nothing to do with Python. Though I haven't checked out whether we're injecting any compile time flags that may be causing extra things to be included - I have no idea why X11 is necessary, for example.
msg331771 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2018-12-13 21:45
Setting DefaultWindowsSdkVersion to 10.0.15063.0 seems to work for the Python 3.7 and 3.8 builds.

Unless there's a security reason (which I don't believe there is), there's no need to worry about 3.6.
msg331842 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2018-12-14 17:13
New changeset f8e9bd568adf85c1e4aea1dda542a96b027797e2 by Steve Dower in branch 'master':
bpo-35402: Update Windows build to use Tcl and Tk 8.6.9 (GH-11146)
https://github.com/python/cpython/commit/f8e9bd568adf85c1e4aea1dda542a96b027797e2
msg331844 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2018-12-14 17:49
New changeset 77824ef6e50e8a47a0b57df2d9f3b48bffd414ac by Steve Dower (Miss Islington (bot)) in branch '3.7':
bpo-35402: Update Windows build to use Tcl and Tk 8.6.9 (GH-11146)
https://github.com/python/cpython/commit/77824ef6e50e8a47a0b57df2d9f3b48bffd414ac
msg331884 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2018-12-15 03:05
Thank you both for the updates.  After I wrote my previous message, I realized that there is a difference between updating tcl/tk to take advantage of bug fixes (after testing for regressions), and enhancing tkinter to give directly access to new tk features from Python.  The latter can still be deferred to the next version.
msg332482 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2018-12-24 16:28
New changeset e5fdab2a8053d4c24d8ddb21362e17f0f636a5d0 by Ned Deily in branch '3.6':
Revert "bpo-35402: Update macOS installer to use Tcl 8.6.9 / Tk 8.6.9.1 (GH-11101)"
https://github.com/python/cpython/commit/e5fdab2a8053d4c24d8ddb21362e17f0f636a5d0
msg332483 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2018-12-24 16:31
New changeset e5fdab2a8053d4c24d8ddb21362e17f0f636a5d0 by Ned Deily in branch '3.6':
Revert "bpo-35402: Update macOS installer to use Tcl 8.6.9 / Tk 8.6.9.1 (GH-11101)"
https://github.com/python/cpython/commit/e5fdab2a8053d4c24d8ddb21362e17f0f636a5d0
msg332487 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2018-12-24 16:32
New changeset 986a9ab09d9564ea884d3dc3f0cedb68b861ddf3 by Ned Deily in branch '3.7':
Revert "bpo-35402: Update macOS installer to use Tcl 8.6.9 / Tk 8.6.9.1 (GH-11101)"
https://github.com/python/cpython/commit/986a9ab09d9564ea884d3dc3f0cedb68b861ddf3
msg332613 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2018-12-27 20:23
New changeset c540c4ec611246da0c1900fe11a807a54f5c2a0c by Ned Deily in branch '2.7':
Revert "bpo-35402: Update macOS installer to use Tcl 8.6.9 / Tk 8.6.9.1 (GH-11101)"
https://github.com/python/cpython/commit/c540c4ec611246da0c1900fe11a807a54f5c2a0c
msg332620 - (view) Author: miss-islington (miss-islington) Date: 2018-12-27 21:13
New changeset a936639b22ca548c00690de6a2964f223f6787cb by Miss Islington (bot) (Ned Deily) in branch 'master':
Revert "bpo-35402: Update macOS installer to use Tcl 8.6.9 / Tk 8.6.9.1 (GH-11101)" (GH-11332)
https://github.com/python/cpython/commit/a936639b22ca548c00690de6a2964f223f6787cb
msg332629 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2018-12-28 00:50
See discussion in Issue35485. Regressions were found on macOS with Tk 8.6.9.1 and with the more recent Tk 8.6 maintenance branch top of trunk.  So for python.org macOS installers, we have reverted to Tcl/Tk 8.6.8.  Windows builds will continue to use 8.6.9 unless problems are found.
History
Date User Action Args
2018-12-28 00:50:33ned.deilysetstatus: open -> closed
superseder: tkinter windows turn black while resized using Tk 8.6.9.1 on macOS
messages: + msg332629

resolution: duplicate
stage: patch review -> resolved
2018-12-27 21:13:35miss-islingtonsetmessages: + msg332620
2018-12-27 20:48:41ned.deilysetpull_requests: + pull_request10603
2018-12-27 20:23:21ned.deilysetmessages: + msg332613
2018-12-24 16:32:17ned.deilysetmessages: + msg332487
2018-12-24 16:31:09ned.deilysetmessages: + msg332483
2018-12-24 16:28:24ned.deilysetmessages: + msg332482
2018-12-15 03:05:05terry.reedysetmessages: + msg331884
2018-12-14 17:49:13steve.dowersetmessages: + msg331844
2018-12-14 17:13:39miss-islingtonsetpull_requests: + pull_request10399
2018-12-14 17:13:18steve.dowersetmessages: + msg331842
2018-12-13 22:53:36steve.dowersetpull_requests: + pull_request10377
2018-12-13 21:45:01steve.dowersetmessages: + msg331771
versions: - Python 3.6
2018-12-11 23:26:11steve.dowersetmessages: + msg331667
2018-12-11 22:20:17ned.deilysetmessages: + msg331657
2018-12-11 22:17:37steve.dowersetmessages: + msg331656
2018-12-11 18:34:31steve.dowersetmessages: + msg331643
2018-12-11 06:54:10ned.deilysetmessages: + msg331587
title: Upgrade macOS (and Windows?) installer to Tcl/Tk 8.6.9.1 -> Upgrade macOS and Windows installers to Tcl 8.6.9 and Tk 8.6.9.1
2018-12-11 06:39:36miss-islingtonsetmessages: + msg331586
2018-12-11 06:29:47miss-islingtonsetmessages: + msg331582
2018-12-11 06:28:51miss-islingtonsetnosy: + miss-islington
messages: + msg331581
2018-12-11 06:07:24miss-islingtonsetpull_requests: + pull_request10333
2018-12-11 06:07:17miss-islingtonsetpull_requests: + pull_request10332
2018-12-11 06:07:09miss-islingtonsetpull_requests: + pull_request10331
2018-12-11 06:07:00ned.deilysetmessages: + msg331578
2018-12-11 05:44:13ned.deilysetkeywords: + patch
stage: patch review
pull_requests: + pull_request10330
2018-12-07 22:32:58terry.reedysetnosy: + terry.reedy, serhiy.storchaka
messages: + msg331360
2018-12-04 07:22:40ned.deilycreate