classification
Title: for loop range bug
Type: Stage: resolved
Components: Windows Versions: Python 3.7, Python 3.6, Python 3.5
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: darmentr, paul.moore, steve.dower, steven.daprano, tim.golden, zach.ware
Priority: normal Keywords:

Created on 2018-11-06 13:56 by darmentr, last changed 2018-11-06 14:23 by darmentr. This issue is now closed.

Messages (3)
msg329357 - (view) Author: Dan Armentrout (darmentr) Date: 2018-11-06 13:56
If you run the following code:

x=[3,4,5]
a=x
for i in range(0,len(a)):
    a[i]=0

All x values are changed to equal a.
msg329358 - (view) Author: Steven D'Aprano (steven.daprano) * (Python committer) Date: 2018-11-06 14:04
This is not a bug, this is standard behaviour, working as designed.

'a' is not a copy of the list 'x', 'a' is another name for the same list as 'x'. Any in-place modifications you make to 'a' happens to the object itself, the list, which is visible regardless of which name you refer to it by.

If you are a C programmer, you can think of this as being similar to pointers: think of 'x' as a pointer to the list, and 'a' as a pointer to the same list. (That's more or less what happens under the hood.) From the Python level, we say that both names 'a' and 'x' refer to the same object.

If you want a copy, you can use the copy module, or for lists, you can take a slice: a = x[:] makes a copy of the list.

For immutable objects like strings, you don't need a copy, because you cannot modify them in place: any operation on a string always creates a new string, leaving the old one untouched.
msg329360 - (view) Author: Dan Armentrout (darmentr) Date: 2018-11-06 14:23
Thank you for your quick explanation of this to me.

Dan

On Tue, Nov 6, 2018 at 8:04 AM Steven D'Aprano <report@bugs.python.org>
wrote:

>
> Steven D'Aprano <steve+python@pearwood.info> added the comment:
>
> This is not a bug, this is standard behaviour, working as designed.
>
> 'a' is not a copy of the list 'x', 'a' is another name for the same list
> as 'x'. Any in-place modifications you make to 'a' happens to the object
> itself, the list, which is visible regardless of which name you refer to it
> by.
>
> If you are a C programmer, you can think of this as being similar to
> pointers: think of 'x' as a pointer to the list, and 'a' as a pointer to
> the same list. (That's more or less what happens under the hood.) From the
> Python level, we say that both names 'a' and 'x' refer to the same object.
>
> If you want a copy, you can use the copy module, or for lists, you can
> take a slice: a = x[:] makes a copy of the list.
>
> For immutable objects like strings, you don't need a copy, because you
> cannot modify them in place: any operation on a string always creates a new
> string, leaving the old one untouched.
>
> ----------
> nosy: +steven.daprano
> resolution:  -> not a bug
> stage:  -> resolved
> status: open -> closed
>
> _______________________________________
> Python tracker <report@bugs.python.org>
> <https://bugs.python.org/issue35176>
> _______________________________________
>
History
Date User Action Args
2018-11-06 14:23:25darmentrsetmessages: + msg329360
2018-11-06 14:04:03steven.dapranosetstatus: open -> closed

nosy: + steven.daprano
messages: + msg329358

resolution: not a bug
stage: resolved
2018-11-06 13:56:41darmentrcreate