classification
Title: test_multiprocessing hangs without this patch on win2k
Type: Stage:
Components: Extension Modules Versions: Python 2.6
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: Nosy List: ocean-city
Priority: normal Keywords: patch

Created on 2008-08-07 05:32 by ocean-city, last changed 2008-08-07 14:34 by ocean-city. This issue is now closed.

Files
File name Uploaded Description Edit
workaround.patch ocean-city, 2008-08-07 05:32
Messages (2)
msg70814 - (view) Author: Hirokazu Yamamoto (ocean-city) * (Python committer) Date: 2008-08-07 05:32
Hello. I'm not familiar with socket, but I found workaround for this
problem. socket.getfqdn("127.0.0.1") returns computer name, but with this
test_multiprocess doesn't work. With 'localhost' test works.

Maybe win2003 community buildbot hangs with same reason?
http://www.python.org/dev/buildbot/community/trunk/x86%20Windows%202003%20trunk/builds/13/step-test/0
msg70829 - (view) Author: Hirokazu Yamamoto (ocean-city) * (Python committer) Date: 2008-08-07 14:34
I'll close this entry because this seems to be duplicate of issue3270.
History
Date User Action Args
2008-08-07 14:34:38ocean-citysetstatus: open -> closed
resolution: duplicate
messages: + msg70829
2008-08-07 05:32:54ocean-citycreate