classification
Title: No Backslash (\) in IDLE 1.2.2
Type: behavior Stage: resolved
Components: IDLE, macOS Versions: Python 3.2, Python 2.7
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: ned.deily Nosy List: Marc67, Peter.Nielsen, funnyfrancois, gpolo, mounty, ned.deily, roger.serwy, ronaldoussoren
Priority: normal Keywords:

Created on 2008-08-02 19:03 by Marc67, last changed 2012-04-15 10:03 by ned.deily. This issue is now closed.

Messages (12)
msg70637 - (view) Author: Marc Rambert (Marc67) Date: 2008-08-02 19:03
With my MacBook, on IDLE application, I can't type any character like this 
one \.
msg70914 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2008-08-08 21:33
\ works fine for me and I suspect almost everyone else.
Please bring this up on comp.lang.python or python-list or
gmane.comp.python.general to see if any other Macbook users have this
problems or any ideas on what might be wrong with your particular
installation.
msg71742 - (view) Author: (mounty) Date: 2008-08-22 12:37
@ Terry J. Reedy

If it is working for you it doesn't necessarily mean that it is working
for mankind in general.

I traced down the problem to the OS X- implementation of Idle in general
and submitted an inquiry to the general python list as you suggested.
The feedback was null- nada- niente. But in the meantime I received a
nice bunch of Spam instead.

http://mail.python.org/pipermail/python-list/2008-August/504330.html

I believe the original poster has a French keyboard and seems to have 
similar problems. The problem is that Idle seems to ignore the
international local keyboard setting. And as we do have two significant
letters ("#" and "'") at the keyboard position where you have the "\"
Idle seems to filter the entry of a backslash.

@ marc 67
HTH

Cheers
Ulf
msg86367 - (view) Author: Guilherme Polo (gpolo) * (Python committer) Date: 2009-04-23 13:11
Can you verify if it is possible to type '\' in a standard Tkinter.Text ?
msg91141 - (view) Author: Fran├žois HOUNDONOUGBO (funnyfrancois) Date: 2009-07-31 18:41
Same probleme here with Idle 2.6.2, with a french keyboard.
I finally thought that it was due to a default binding recorded as 
<Option><Slash> or <Option><Shift>:, something like that, which is 
identical to the binding of Backslash character on my keyboard.
So I modified the binding "expand word" (can't remember why this one), 
recorded it under a new key set and applied it. After that, the 
backslash combination worked perfectly!!

But ... the bug now is that if I come back to the default OSX key set, 
it still works ...

(Another detail is that with the Logitech keyboard configuration (usb PC 
keyboard), it works at first try...)

Maybe this workaround will save your afternoon ...
msg121186 - (view) Author: Peter Nielsen (Peter.Nielsen) Date: 2010-11-14 11:20
I have the same problem with a danish keyboard and OSX snowleopard..
I can use \ in both the command editor and pretty everywhere else but not in Idle.
msg130704 - (view) Author: Ronald Oussoren (ronaldoussoren) * (Python committer) Date: 2011-03-12 23:00
Do I understand it correctly when I write that you normally use "Option+Slash" to enter a backslash on your keyboard?

That would explain why updating the keyboard bindings makes it possible to type a backslash.

I'm not sure how we could fix this issue in a way that wouldn't break existing bindings for folks with an english keyboard (as just updating the default keybindings would likely upset those people).
msg130725 - (view) Author: Peter Nielsen (Peter.Nielsen) Date: 2011-03-13 06:09
Yes, that is correct .

Well, thanks for replying, anyway. I guess I'll have to use linux instead.

On Sun, Mar 13, 2011 at 12:00 AM, Ronald Oussoren <report@bugs.python.org>wrote:

>
> Ronald Oussoren <ronaldoussoren@mac.com> added the comment:
>
> Do I understand it correctly when I write that you normally use
> "Option+Slash" to enter a backslash on your keyboard?
>
> That would explain why updating the keyboard bindings makes it possible to
> type a backslash.
>
> I'm not sure how we could fix this issue in a way that wouldn't break
> existing bindings for folks with an english keyboard (as just updating the
> default keybindings would likely upset those people).
>
> ----------
>
> _______________________________________
> Python tracker <report@bugs.python.org>
> <http://bugs.python.org/issue3493>
> _______________________________________
>
msg158294 - (view) Author: Roger Serwy (roger.serwy) * (Python committer) Date: 2012-04-14 22:41
Is this still an issue with the latest version of IDLE?
msg158299 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2012-04-14 23:20
The problem of not honoring alternate input methods should no longer be a problem when using a current ActiveState Tcl/Tk 8.5.x on Mac OS X and a Python that is built to link with it, such as the current Python 2.7.x and 3.2.x installers from python.org.  At the moment, there are no released Apple-supplied Tcl/Tks (and Pythons) that have all the necessary fixes.  See http://www.python.org/download/mac/tcltk/ for more details about recommended Python and Tcl/Tk versions on OS X.
msg158314 - (view) Author: Peter Nielsen (Peter.Nielsen) Date: 2012-04-15 09:25
Hello there

Yes, I am afraid the problem persists.
I have downloaded version 3.2.3 of python 32 bit.
In terminal in OSX 10.7.3, you can use the keys ALT + SHIFT and 7 to get
the \ but in the Idle application there is no way to do that.

Kind Regards / Med venlig hilsen

Peter Nielsen

On Sun, Apr 15, 2012 at 12:41 AM, Roger Serwy <report@bugs.python.org>wrote:

>
> Roger Serwy <roger.serwy@gmail.com> added the comment:
>
> Is this still an issue with the latest version of IDLE?
>
> ----------
> nosy: +serwy
>
> _______________________________________
> Python tracker <report@bugs.python.org>
> <http://bugs.python.org/issue3493>
> _______________________________________
>
msg158316 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2012-04-15 10:03
Peter: I'm sorry that I didn't make it clearer in my reply that you need to use the 64-bit/32-bit python.org installers (available for OS X 10.6 and above), not the 32-bit-only installers.  The 32-bit-only-installers are linked with Tcl/Tk 8.4 since there is no version of Apple- or ActiveState- Tcl/Tk 8.5 available for all platforms supported by the 32-bit-only installers (10.3+, Intel and PPC).  The input method support is only in the Cocoa Tcl/Tk 8.5.
History
Date User Action Args
2012-04-15 10:03:22ned.deilysetmessages: + msg158316
2012-04-15 09:25:32Peter.Nielsensetmessages: + msg158314
2012-04-14 23:20:13ned.deilysetstatus: open -> closed

assignee: ronaldoussoren -> ned.deily
versions: + Python 2.7, Python 3.2, - Python 2.6, Python 3.1
nosy: + ned.deily

messages: + msg158299
resolution: out of date
stage: resolved
2012-04-14 22:41:22roger.serwysetnosy: + roger.serwy
messages: + msg158294
2011-03-13 08:24:34ned.deilysetfiles: - unnamed
nosy: ronaldoussoren, gpolo, Marc67, mounty, funnyfrancois, Peter.Nielsen
2011-03-13 06:09:01Peter.Nielsensetfiles: + unnamed

messages: + msg130725
nosy: ronaldoussoren, gpolo, Marc67, mounty, funnyfrancois, Peter.Nielsen
2011-03-12 23:00:08ronaldoussorensetnosy: ronaldoussoren, gpolo, Marc67, mounty, funnyfrancois, Peter.Nielsen
messages: + msg130704
2010-11-14 11:20:13Peter.Nielsensetnosy: + Peter.Nielsen

messages: + msg121186
versions: + Python 2.6, Python 3.1, - Python 2.7
2010-08-03 21:28:55terry.reedysetversions: + Python 2.7, - Python 2.5
nosy: + ronaldoussoren

assignee: ronaldoussoren
components: + macOS
type: behavior
2009-07-31 18:41:52funnyfrancoissetnosy: + funnyfrancois
messages: + msg91141
2009-04-23 18:34:54terry.reedysetnosy: - terry.reedy
2009-04-23 13:11:18gpolosettype: enhancement -> (no value)

messages: + msg86367
nosy: + gpolo
2008-08-22 12:37:30mountysetnosy: + mounty
messages: + msg71742
2008-08-08 21:33:33terry.reedysetnosy: + terry.reedy
messages: + msg70914
2008-08-02 19:05:25Marc67settype: enhancement
2008-08-02 19:03:47Marc67create