classification
Title: Crash caused by pasting πŒˆπŒ– into IDLE on Windows
Type: crash Stage: resolved
Components: IDLE, Unicode Versions: Python 3.8, Python 3.7, Python 3.6
process
Status: closed Resolution: duplicate
Dependencies: Superseder: IDLE 3.x on Windows exits when pasting non-BMP unicode
View: 13153
Assigned To: terry.reedy Nosy List: ezio.melotti, romaji, serhiy.storchaka, terry.reedy, vstinner, zach.ware
Priority: normal Keywords:

Created on 2018-06-06 15:55 by romaji, last changed 2018-06-06 21:38 by terry.reedy. This issue is now closed.

Messages (9)
msg318839 - (view) Author: Romaji Milton Amulo (romaji) Date: 2018-06-06 15:55
On Windows 10, 64 bit, "Python 3.6.1 (v3.6.1:69c0db5, Mar 21 2017, 18:41:36) [MSC v.1900 64 bit (AMD64)] on win32" crashes if πŒˆπŒ– is pasted into the interpreter window, closing the window immediately.
Also πŒ†πŒ€πŒ‹ crashes it too, suggesting the bug might be in text processing of Etruscan runes.
msg318840 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2018-06-06 15:56
Are you using cmd.exe, PowerShell or IDLE?
msg318842 - (view) Author: Romaji Milton Amulo (romaji) Date: 2018-06-06 15:58
IDLE

On Wed, Jun 6, 2018, 11:56 STINNER Victor <report@bugs.python.org> wrote:

>
> STINNER Victor <vstinner@redhat.com> added the comment:
>
> Are you using cmd.exe, PowerShell or IDLE?
>
> ----------
>
> _______________________________________
> Python tracker <report@bugs.python.org>
> <https://bugs.python.org/issue33785>
> _______________________________________
>
msg318844 - (view) Author: Zachary Ware (zach.ware) * (Python committer) Date: 2018-06-06 16:23
I suspect this is the old issue of Tcl/Tk's lack of support for Unicode characters outside the BMP.  If I'm correct, there's nothing we can do about it.
msg318845 - (view) Author: Romaji Milton Amulo (romaji) Date: 2018-06-06 16:31
Would running it in Powershell avoid the issue?
What is the BMP, by the way?
msg318846 - (view) Author: Matthew Barnett (mrabarnett) * (Python triager) Date: 2018-06-06 16:57
For clarity, the first is '\U00010308\U00010316' and the second is '\U00010306\U00010300\U0001030B'.

The BMP is the Basic Multilingual Plane, which covers the codepoints in the range U+0000 to U+FFFF. Some software has a problem dealing with codepoints outside the BMP.
msg318847 - (view) Author: Zachary Ware (zach.ware) * (Python committer) Date: 2018-06-06 16:58
Depending on PowerShell's support for Unicode (I'm not familiar with it :)), yes; running python from PowerShell would probably be fine in this case.

The BMP: https://en.wikipedia.org/wiki/Plane_(Unicode)#Basic_Multilingual_Plane
msg318850 - (view) Author: Romaji Milton Amulo (romaji) Date: 2018-06-06 17:05
It doesn't crash in Powershell, only shows up as the ? in a box character
The issue must be with IDLE, most likely the BMP lack of support
msg318861 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2018-06-06 21:38
This is a duplicate of the remaining part of #13153.  The error message displayed in a console used to start IDLE is the same, ending with "UnicodeDecodeError: 'utf-8' codec can't decode byte 0xed in position 0: invalid continuation byte"  In the previous issue, Ezio explained the message and Serhiy submitted patches at yet untested.  So I am closing this.
History
Date User Action Args
2018-06-06 21:38:44terry.reedysetstatus: open -> closed
versions: + Python 3.7, Python 3.8
superseder: IDLE 3.x on Windows exits when pasting non-BMP unicode
messages: + msg318861

resolution: duplicate
stage: resolved
2018-06-06 17:07:38vstinnersettitle: Crash caused by pasting πŒˆπŒ– into python -> Crash caused by pasting πŒˆπŒ– into IDLE on Windows
2018-06-06 17:05:20romajisetmessages: + msg318850
2018-06-06 16:58:19zach.waresetnosy: - mrabarnett
messages: + msg318847
2018-06-06 16:57:26mrabarnettsetnosy: + mrabarnett
messages: + msg318846
2018-06-06 16:31:15romajisetmessages: + msg318845
2018-06-06 16:23:16zach.waresetnosy: + terry.reedy, serhiy.storchaka, zach.ware
messages: + msg318844

assignee: terry.reedy
components: + IDLE
2018-06-06 15:58:21romajisetmessages: + msg318842
2018-06-06 15:56:31vstinnersetmessages: + msg318840
2018-06-06 15:55:54romajicreate