classification
Title: test test_webbrowser failed
Type: behavior Stage: resolved
Components: Build Versions: Python 3.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: webbrowser._synthesize uses outdated calling signature for webbrowser.register
View: 31014
Assigned To: Nosy List: Greg Walters, martin.panter, vstinner
Priority: normal Keywords:

Created on 2018-05-30 10:59 by Greg Walters, last changed 2018-05-30 12:30 by ncoghlan. This issue is now closed.

Messages (5)
msg318163 - (view) Author: Greg Walters (Greg Walters) Date: 2018-05-30 10:59
Python 3.70b4
Linux Mint 18.3
Dell Latitude-E5500
While running make test got the following error...
======================================================================
ERROR: test_get (test.test_webbrowser.ImportTest)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/greg/Downloads/Python-3.7.0b4/Lib/test/test_webbrowser.py", line 290, in test_get
    webbrowser.get('fakebrowser')
  File "/home/greg/Downloads/Python-3.7.0b4/Lib/webbrowser.py", line 42, in get
    register_standard_browsers()
  File "/home/greg/Downloads/Python-3.7.0b4/Lib/webbrowser.py", line 567, in register_standard_browsers
    cmd = _synthesize(cmdline, -1)
  File "/home/greg/Downloads/Python-3.7.0b4/Lib/webbrowser.py", line 116, in _synthesize
    register(browser, None, controller, update_tryorder)
TypeError: register() takes from 2 to 3 positional arguments but 4 were given

======================================================================
ERROR: test_register (test.test_webbrowser.ImportTest)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/greg/Downloads/Python-3.7.0b4/Lib/test/test_webbrowser.py", line 277, in test_register
    webbrowser.register('Example1', ExampleBrowser)
  File "/home/greg/Downloads/Python-3.7.0b4/Lib/webbrowser.py", line 26, in register
    register_standard_browsers()
  File "/home/greg/Downloads/Python-3.7.0b4/Lib/webbrowser.py", line 567, in register_standard_browsers
    cmd = _synthesize(cmdline, -1)
  File "/home/greg/Downloads/Python-3.7.0b4/Lib/webbrowser.py", line 116, in _synthesize
    register(browser, None, controller, update_tryorder)
TypeError: register() takes from 2 to 3 positional arguments but 4 were given

----------------------------------------------------------------------
Ran 31 tests in 0.073s

FAILED (errors=2)
test test_webbrowser failed
1 test failed again:
    test_webbrowser

Total duration: 10 min 50 sec
Tests result: FAILURE
Makefile:1066: recipe for target 'test' failed
make: *** [test] Error 2


Did not try to go any further.
msg318166 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2018-05-30 11:22
It seems to be a regression caused by bpo-24241.
msg318168 - (view) Author: Greg Walters (Greg Walters) Date: 2018-05-30 11:24
Thank you.

On Wed, May 30, 2018 at 6:22 AM, STINNER Victor <report@bugs.python.org>
wrote:

>
> STINNER Victor <vstinner@redhat.com> added the comment:
>
> It seems to be a regression caused by bpo-24241.
>
> ----------
> nosy: +vstinner
>
> _______________________________________
> Python tracker <report@bugs.python.org>
> <https://bugs.python.org/issue33693>
> _______________________________________
>

-- 
Greg Walters

Heard from a Klingon Programmer: "Klingon programs don't *do* accountancy.
For that, you need a Farengi programmer."
msg318170 - (view) Author: Martin Panter (martin.panter) * (Python committer) Date: 2018-05-30 11:28
This sounds like the existing bug Issue 31014
msg318171 - (view) Author: Greg Walters (Greg Walters) Date: 2018-05-30 11:40
Thank you

On Wed, May 30, 2018, 6:28 AM Martin Panter <report@bugs.python.org> wrote:

>
> Martin Panter <vadmium+py@gmail.com> added the comment:
>
> This sounds like the existing bug Issue 31014
>
> ----------
> nosy: +martin.panter
> superseder:  -> webbrowser._synthesize uses outdated calling signature for
> webbrowser.register
>
> _______________________________________
> Python tracker <report@bugs.python.org>
> <https://bugs.python.org/issue33693>
> _______________________________________
>
History
Date User Action Args
2018-05-30 12:30:48ncoghlansetstatus: open -> closed
type: compile error -> behavior
resolution: duplicate
stage: resolved
2018-05-30 11:40:07Greg Walterssetmessages: + msg318171
2018-05-30 11:28:43martin.pantersetsuperseder: webbrowser._synthesize uses outdated calling signature for webbrowser.register

messages: + msg318170
nosy: + martin.panter
2018-05-30 11:24:34Greg Walterssetmessages: + msg318168
2018-05-30 11:22:38vstinnersetnosy: + vstinner
messages: + msg318166
2018-05-30 10:59:34Greg Walterscreate