classification
Title: Enable CI builds on Visual Studio Team Services
Type: Stage: resolved
Components: Build, Tests Versions: Python 3.8, Python 3.7, Python 3.6, Python 2.7
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: steve.dower Nosy List: ammar2, brett.cannon, gregory.p.smith, matrixise, pitrou, steve.dower
Priority: normal Keywords: patch

Created on 2018-05-15 16:15 by steve.dower, last changed 2018-05-18 20:16 by steve.dower. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 6865 merged steve.dower, 2018-05-15 16:15
PR 6923 closed miss-islington, 2018-05-16 21:51
PR 6925 merged steve.dower, 2018-05-16 22:07
PR 6926 merged miss-islington, 2018-05-16 22:21
Messages (14)
msg316677 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2018-05-15 16:15
We have been provided with https://python.visualstudio.com/cpython and a measure of build machines to help us run continuous integration builds. The benefits are more reliable builds (especially Mac and Windows) and higher parallelism than our current services.

My PR adds the build definition files and fixes some test bugs to ensure we can successfully test on this platform. There are a few more manual steps to make it work against our repo, which we will do immediately after merging the changes.
msg316732 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2018-05-15 21:32
Can you explain what Visual Studio Team Services is?
msg316817 - (view) Author: Brett Cannon (brett.cannon) * (Python committer) Date: 2018-05-16 15:15
https://www.visualstudio.com/team-services/

It's Microsoft's GitHub hosting, issue tracking, and CI/CD platform.
msg316873 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2018-05-16 21:50
New changeset e5f41d2f1e0b8b8e61d5fa427c19bd1ea90fd9a3 by Steve Dower in branch 'master':
bpo-33522: Enable CI builds on Visual Studio Team Services (#6865)
https://github.com/python/cpython/commit/e5f41d2f1e0b8b8e61d5fa427c19bd1ea90fd9a3
msg316924 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2018-05-17 12:49
New changeset 8965d75c90e80b6983b36f3ae9601d6a257d782b by Steve Dower (Miss Islington (bot)) in branch '3.7':
bpo-33522: Enable CI builds on Visual Studio Team Services (GH-6865) (GH-6926)
https://github.com/python/cpython/commit/8965d75c90e80b6983b36f3ae9601d6a257d782b
msg316929 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2018-05-17 13:46
New changeset 0d8f83f59c8f4cc7fe125434ca4ecdcac111810f by Steve Dower in branch '3.6':
bpo-33522: Enable CI builds on Visual Studio Team Services (GH-6865) (GH-6925)
https://github.com/python/cpython/commit/0d8f83f59c8f4cc7fe125434ca4ecdcac111810f
msg316950 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2018-05-17 15:40
This is implemented and merged now. I'll leave it to core-workflow to decide whether and when to make the builds required and/or reduce use of Travis/AppVeyor.
msg317003 - (view) Author: Gregory P. Smith (gregory.p.smith) * (Python committer) Date: 2018-05-18 04:57
Your PRs made modifications to code and did not include a useful commit message or appropriate NEWS entries for the code modifications.

Further, VSTS is unreliable.  core-workflow made a premature decision to turn off Travis and AppVeyor and make VSTS blocking.
msg317006 - (view) Author: Ammar Askar (ammar2) * (Python triager) Date: 2018-05-18 07:13
>core-workflow made a premature decision to turn off Travis and AppVeyor and make VSTS blocking.

It looks like AppVeyor and Travis are still running as of the latest PR: https://github.com/python/cpython/pull/6965

Annoyingly, I don't think there's a way to make certain checks like VSTS be optional and not show up with a red cross on Github.
msg317019 - (view) Author: Stéphane Wirtel (matrixise) * (Python triager) Date: 2018-05-18 08:52
Hi Steve

I just saw VSTS in action, it's a great job, thank you.

Compared to Travis-CI:

* is there more computers for the tests on VSTS?

* with time, what will be the reference if there is a 'green' build? TravisCI or VSTS?

Thank you again for the job.
msg317029 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2018-05-18 14:22
> * is there more computers for the tests on VSTS?

I don't know what Travis is giving us, but Microsoft has provided 20 concurrent builds. They also seem to be more powerful machines, though some caching features are missing and many builds seem to take about the same time.

> * with time, what will be the reference if there is a 'green' build? TravisCI or VSTS?

This is a question for the core-workflow list. I'm deliberately staying out of this part of the discussion.
msg317030 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2018-05-18 14:26
> I don't think there's a way to make certain checks like VSTS be optional and not show up with a red cross on Github

Most of the failures I've seen have been reproducible, so I suspect they're due to race conditions that rarely occurred on Travis. Unfortunately, we are no longer watching the build bots as closely as we used to, so many platform-specific or configuration-specific failures are missed :(
msg317034 - (view) Author: Gregory P. Smith (gregory.p.smith) * (Python committer) Date: 2018-05-18 15:23
I've emailed support@github on this one.  Their UI is horrible, "show all checks" does not show them all.  It shows five at most.

It is an invisible scrolling region.  We're forced to manually mouse over and scroll down in that region in order to confirm that the trustworthy checks have run.
msg317058 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2018-05-18 20:16
GitHub has broken CSS everywhere right now :) Their oauth page doesn't show scroll bars either, which means you can't get to the "authorise" button if you're in more than a couple of organisations.
History
Date User Action Args
2018-05-18 20:16:31steve.dowersetmessages: + msg317058
2018-05-18 15:25:21gregory.p.smithsetstatus: open -> closed
resolution: fixed
stage: resolved
2018-05-18 15:23:52gregory.p.smithsetmessages: + msg317034
2018-05-18 14:26:24steve.dowersetmessages: + msg317030
2018-05-18 14:22:33steve.dowersetmessages: + msg317029
2018-05-18 08:52:25matrixisesetnosy: + matrixise
messages: + msg317019
2018-05-18 07:13:53ammar2setnosy: + ammar2
messages: + msg317006
2018-05-18 04:57:24gregory.p.smithsetnosy: + gregory.p.smith
messages: + msg317003

resolution: fixed -> (no value)
stage: resolved -> (no value)
2018-05-17 15:40:10steve.dowersetresolution: fixed
messages: + msg316950
stage: patch review -> resolved
2018-05-17 13:46:04steve.dowersetmessages: + msg316929
2018-05-17 12:49:04steve.dowersetmessages: + msg316924
2018-05-16 22:21:15miss-islingtonsetpull_requests: + pull_request6596
2018-05-16 22:07:21steve.dowersetpull_requests: + pull_request6595
2018-05-16 21:51:39miss-islingtonsetkeywords: + patch
stage: patch review
pull_requests: + pull_request6593
2018-05-16 21:50:38steve.dowersetmessages: + msg316873
2018-05-16 15:15:18brett.cannonsetmessages: + msg316817
2018-05-15 21:32:34pitrousetnosy: + pitrou
messages: + msg316732
2018-05-15 16:15:54steve.dowercreate