classification
Title: AIX and "specialized downloads" links
Type: Stage: resolved
Components: Versions: Python 3.7, Python 3.6, Python 3.4, Python 3.5, Python 2.7
process
Status: closed Resolution:
Dependencies: Superseder:
Assigned To: Nosy List: Michael.Felt, aixtools@gmail.com, gvanrossum
Priority: normal Keywords:

Created on 2018-05-11 11:50 by Michael.Felt, last changed 2018-05-13 13:10 by Michael.Felt. This issue is now closed.

Messages (5)
msg316395 - (view) Author: Michael Felt (Michael.Felt) * Date: 2018-05-11 11:50
I struggled with how python was packaged by others. Key points being: many dependencies, no assurance you could uninstall the dependencies and/or python.

A little over two years ago I started looking for 'root causes' of problems that potential users of python (on AIX) were having.

To me it is clear that the packaging problems from two years back are just as alive as they were in 2015 and 2016. Since then I have learned a few things about python (thanks to all who helped). I would like to apply this knowledge and provide a 'cleaner' packaging of Python for AIX - both Python3 and Python2.

I would appreciate my downloadable packages being listed on the "other" downloads list. If you wanted to make it complete - the other two I know of are Perzl's site (http://www.perzl.org/aix/index.php?n=main.python), and, of course, the IBM AIX Toolbox (https://www-03.ibm.com/systems/power/software/aix/linux/toolbox/alpha.html#P).

I have involved (currently managed and run it) an AIX portal since 2001 - http://www.rootvg.net. The last 5 or 6 years I have been hosting a second portal I call "aixtools".

In short, I hope you will consider adding - at least - my aixtools wiki pages: http://www.aixtools.net/index.php/python3 and http://www.aixtools.net/index.php/python (for python2).

Many thanks for your consideration,

Michael
msg316399 - (view) Author: Guido van Rossum (gvanrossum) * (Python committer) Date: 2018-05-11 15:18
Given that we don't feel it is worth the effort to support AIX in the CPython source explicitly, I think it's right that we at least link to Michael's efforts in the "other downloads" page.

I don't actually know if this should go to the python.org website tracker (https://github.com/python/pythondotorg/issues) or here (here's appropriate if it's in the CPython source repo -- in that case Michael can submit a PR linked to this issue.)
msg316402 - (view) Author: Michael Felt (Michael.Felt) * Date: 2018-05-11 15:57
FYI: as my primary effort for AIX concerned ctypes.find_library() - and that is now in the Python3-3.7 branch - when I do a PR it will only be for "current" efforts, i.e., Python3-3.7 and later.

As much as I feel it is important I'll backport myself into branches I'll label "aix.vX.Y.Z", where the starting point is always anew from vX.Y.Z

More detailed: (e.g., on 3.4.8, which I am working on now)

git clone -b v3.4.8 git@github.com:aixtools/cpython.git python-3.4.8
git branch aix.v3.4.8
cat ../aix.patch | patch ...
make and test
git commit -m"my message"
git push to_my_fork

As much as possible, I want to be in sync with python - and give you the option of including anything AIX.

As counts for most, if not all, this is "free-time", not paid - but I will always try to respond to questions re: AIX.

Guido - thank you for the support!
msg316414 - (view) Author: Michael Felt (aixtools@gmail.com) Date: 2018-05-11 20:56
P.s. i apologize for probably posting in the incorrect “issues” area. Having followed guido’s link i see an area that is new for me. 

If it is better that i “restart” the discussion there, just ask.
msg316464 - (view) Author: Michael Felt (Michael.Felt) * Date: 2018-05-13 13:10
Took me a while to get this 'posted' properly.

- please see https://github.com/python/pythondotorg/issues/1156

My apologies for the noise.
History
Date User Action Args
2018-05-13 13:10:30Michael.Feltsetstatus: open -> closed

messages: + msg316464
stage: resolved
2018-05-11 20:56:26aixtools@gmail.comsetnosy: + aixtools@gmail.com
messages: + msg316414
2018-05-11 15:57:53Michael.Feltsetmessages: + msg316402
2018-05-11 15:18:08gvanrossumsetmessages: + msg316399
2018-05-11 11:50:27Michael.Feltcreate