classification
Title: dataclasses and __slots__ - non-default argument (member_descriptor)
Type: behavior Stage: resolved
Components: Library (Lib) Versions: Python 3.8, Python 3.7
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: eric.smith Nosy List: eric.smith, stachel
Priority: normal Keywords: patch

Created on 2018-03-19 03:30 by stachel, last changed 2018-03-20 01:39 by eric.smith. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 6152 merged eric.smith, 2018-03-20 00:49
PR 6153 merged miss-islington, 2018-03-20 01:08
Messages (8)
msg314077 - (view) Author: Adrian Stachlewski (stachel) Date: 2018-03-19 03:30
I've tried to declare two classes

@dataclass
class Base:
    __slots__ = ('x',)
    x: Any


@dataclass
class Derived(Base):
    x: int
    y: int

As long as I correctly understood PEP 557 (inheritance part), changing type of variable is possible. This code produce error:

TypeError: non-default argument 'y' follows default argument

'x' variable in Derived class has changed default from MISSING to member_descriptor and that's the reason of the exception.
msg314087 - (view) Author: Eric V. Smith (eric.smith) * (Python committer) Date: 2018-03-19 08:57
This is the same reason that this fails:

class Base:
    __slots__ = ('x',)
    x = 3

with:
ValueError: 'x' in __slots__ conflicts with class variable

In the dataclasses case, the error needs to be improved, and moved to when the base class is being defined.
msg314090 - (view) Author: Adrian Stachlewski (stachel) Date: 2018-03-19 09:14
I don't really get your point. 

@dataclass
class Base:
    __slots__ = ('x',)
    x: Any

This case is described in PEP 557 as correct, so I don't understand why you want to generate error. Also inheritance without defining slots is correct as stated in data model. 

In my opinion, member_descriptor should be treated same as MISSING and everything should work correctly.
msg314091 - (view) Author: Eric V. Smith (eric.smith) * (Python committer) Date: 2018-03-19 11:32
My point is that the problem is that after:

@dataclass
class Base:
    __slots__ = ('x',)
    x: Any

Base.x has a value (it's the member_descriptor for x). That's what's causing the problem that when adding a field to the derived class, it thinks you're adding a field without a default value after one that has a default value.

I agree that I could detect this specific case and allow it. My comment about the error message was inaccurate.
msg314121 - (view) Author: Adrian Stachlewski (stachel) Date: 2018-03-19 21:52
There's also another major problem. Because Base.x has value, __init__ is not prepared correctly (member_descriptor is passed as default). 

@dataclass
class Base:
    __slots__ = ('x',)
    x: Any

Base()  # No TypeError exception

Fixing this should be quite easy, if you want I can prepare PR.
msg314122 - (view) Author: Eric V. Smith (eric.smith) * (Python committer) Date: 2018-03-19 22:30
Thanks, but I'm already looking at this in the context of a different bug.
msg314124 - (view) Author: Eric V. Smith (eric.smith) * (Python committer) Date: 2018-03-20 01:07
New changeset 7389fd935c95b4b6f094312294e703ee0de18719 by Eric V. Smith in branch 'master':
bpo-33100: Dataclasses now handles __slots__ and default values correctly. (GH-6152)
https://github.com/python/cpython/commit/7389fd935c95b4b6f094312294e703ee0de18719
msg314128 - (view) Author: Eric V. Smith (eric.smith) * (Python committer) Date: 2018-03-20 01:31
New changeset 3d41f482594b6aab12a316202b3c06757262109a by Eric V. Smith (Miss Islington (bot)) in branch '3.7':
bpo-33100: Dataclasses now handles __slots__ and default values correctly. (GH-6152) (GH-6153)
https://github.com/python/cpython/commit/3d41f482594b6aab12a316202b3c06757262109a
History
Date User Action Args
2018-03-20 01:39:18eric.smithsetstatus: open -> closed
resolution: fixed
stage: patch review -> resolved
2018-03-20 01:31:25eric.smithsetmessages: + msg314128
2018-03-20 01:08:15miss-islingtonsetpull_requests: + pull_request5911
2018-03-20 01:07:55eric.smithsetmessages: + msg314124
2018-03-20 00:49:32eric.smithsetkeywords: + patch
stage: patch review
pull_requests: + pull_request5910
2018-03-19 22:30:01eric.smithsetmessages: + msg314122
2018-03-19 21:52:16stachelsetmessages: + msg314121
2018-03-19 11:32:31eric.smithsetmessages: + msg314091
2018-03-19 09:14:50stachelsetmessages: + msg314090
2018-03-19 08:57:06eric.smithsetmessages: + msg314087
2018-03-19 03:43:05rhettingersetassignee: eric.smith

nosy: + eric.smith
2018-03-19 03:30:15stachelcreate