classification
Title: Asyncio looping during simultaneously socket read/write and reconnection
Type: behavior Stage: resolved
Components: asyncio Versions: Python 3.7, Python 3.6
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: andr04, asvetlov, yselivanov
Priority: normal Keywords: patch

Created on 2017-11-13 12:39 by andr04, last changed 2017-11-14 10:14 by asvetlov. This issue is now closed.

Files
File name Uploaded Description Edit
raise.py andr04, 2017-11-13 12:39 Bug reproducing with reading
Pull Requests
URL Status Linked Edit
PR 4386 merged andr04, 2017-11-13 13:12
PR 4393 merged asvetlov, 2017-11-14 09:49
Messages (3)
msg306154 - (view) Author: Andrey (andr04) * Date: 2017-11-13 12:39
The bug is happened when the async reading/writing interrupted by other async method which reconnects the socket. The closed socket calls the appropriate handler in the loop due to cannot be removed due to wrong fileno of socket.
msg306192 - (view) Author: Andrew Svetlov (asvetlov) * (Python committer) Date: 2017-11-14 09:19
New changeset e1d62e0b7cc842d6b75b4d480391f4a94e503255 by Andrew Svetlov (Andrey Egorov) in branch 'master':
bpo-32015: Asyncio looping during simultaneously socket read/write an… (#4386)
https://github.com/python/cpython/commit/e1d62e0b7cc842d6b75b4d480391f4a94e503255
msg306196 - (view) Author: Andrew Svetlov (asvetlov) * (Python committer) Date: 2017-11-14 10:14
New changeset cc0961c517c31578f6a40a4dc7ea177d62c256b7 by Andrew Svetlov in branch '3.6':
[3.6] bpo-32015: Asyncio looping during simultaneously socket read/write an… (GH-4386) (#4393)
https://github.com/python/cpython/commit/cc0961c517c31578f6a40a4dc7ea177d62c256b7
History
Date User Action Args
2017-11-14 10:14:58asvetlovsetmessages: + msg306196
2017-11-14 09:49:56asvetlovsetpull_requests: + pull_request4341
2017-11-14 09:19:51asvetlovsetstatus: open -> closed
stage: patch review -> resolved
resolution: fixed
versions: - Python 3.5, Python 3.8
2017-11-14 09:19:06asvetlovsetnosy: + asvetlov
messages: + msg306192
2017-11-13 14:53:27andr04settitle: Asyncio cycling during simultaneously socket read/write and reconnection -> Asyncio looping during simultaneously socket read/write and reconnection
2017-11-13 13:12:25andr04setkeywords: + patch
stage: patch review
pull_requests: + pull_request4334
2017-11-13 12:39:18andr04create